Mailinglist Archive: zypp-commit (301 mails)

< Previous Next >
[zypp-commit] r7565 - in /trunk/sat-solver/testsuite: ./ data.libzypp/bugzilla-tests/ data.libzypp/freshen-tests/ data.libzypp/kernel-tests/ data.libzypp/lock-tests/ data.libzypp/mediaorder-tests/ data.libzypp/p...
  • From: coolo@xxxxxxxxxxxxxxxx
  • Date: Fri, 19 Oct 2007 09:12:11 -0000
  • Message-id: <20071019091211.8B67C2666F@xxxxxxxxxxxxxxxx>
Author: coolo
Date: Fri Oct 19 11:12:10 2007
New Revision: 7565

URL: http://svn.opensuse.org/viewcvs/zypp?rev=7565&view=rev
Log:
adding the rest of the tests and review the failures
238 tests: (188/0) passed, (50/0) failed, 117 ignored

make check in libzypp-testsuite/solver: 10m46s
./runtest.rb data.libzypp: 5.7s
 -> speedup of 113 (not exactly fair measurement though)

Added:
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug217574-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug255011-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug191983-bare-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug222531-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug230685-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug238284-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug239199-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug308252-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug310455-test.xml
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution
      - copied, changed from r7564, trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution2
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-11-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1f-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6f-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7f-test.xml
    trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-8-test.xml
    trunk/sat-solver/testsuite/data.libzypp/kernel-tests/1_2_1-default-manual-test.xml
    trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_1-test.xml
    trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_2-test.xml
    trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_4-test.xml
    trunk/sat-solver/testsuite/data.libzypp/kernel-tests/kernel_kmp-test.xml
    trunk/sat-solver/testsuite/data.libzypp/lock-tests/install-single-test.xml
    trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-all-mediaorder-test.xml
    trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-gnome-mediaorder-test.xml
    trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-mediaorder-test.xml
    trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-kde-desktop-mediaorder-test.xml
    trunk/sat-solver/testsuite/data.libzypp/patch-tests/jumbo-patch-test.xml
    trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-single-update-test.xml
    trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-update-test.xml
    trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atmos-test.xml
    trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atoms-equal-patch-test.xml
    trunk/sat-solver/testsuite/data.libzypp/patch-tests/script-test.xml
Removed:
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution1
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution2
Modified:
    trunk/sat-solver/testsuite/README.FAILS
    trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/ignore

Modified: trunk/sat-solver/testsuite/README.FAILS
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/README.FAILS?rev=7565&r1=7564&r2=7565&view=diff
==============================================================================
--- trunk/sat-solver/testsuite/README.FAILS (original)
+++ trunk/sat-solver/testsuite/README.FAILS Fri Oct 19 11:12:10 2007
@@ -27,7 +27,52 @@
 ./data.libzypp/kernel-tests/1_2_2-default-test.xml
 ./data.libzypp/kernel-tests/1_2_1-smp-test.xml
 ./data.libzypp/kernel-tests/1_2_1-default-test.xml
+./data.libzypp/kernel-tests/1_2_1-default-manual-test.xml
+./data.libzypp/kernel-tests/3_1-test.xml
+./data.libzypp/kernel-tests/3_2-test.xml
+./data.libzypp/kernel-tests/3_4-test.xml
+./data.libzypp/kernel-tests/kernel_kmp-test.xml
        libzypp plays around with kernel deps
 
 ./data.libzypp/bugzilla-tests/bug310618-test.xml
        sat-solver does not like it
+
+./data.libzypp/lock-tests/install-single-test.xml
+       lock is implemented buggy
+
+./data.libzypp/bugzilla-tests/Bug255011-test.xml
+       wrong java picked (uninvested)
+
+./data.libzypp/bugzilla-tests/bug328081-test.xml
+       bundle-lang-common-ko is pretty much unneeded
+
+./data.libzypp/bugzilla-tests/bug310455-test.xml
+       libzypp does not like to change vendors, sat does not care
+
+./data.libzypp/mediaorder-tests/install-all-mediaorder-test.xml
+./data.libzypp/mediaorder-tests/install-default-gnome-mediaorder-test.xml
+./data.libzypp/mediaorder-tests/install-default-mediaorder-test.xml
+./data.libzypp/mediaorder-tests/install-kde-desktop-mediaorder-test.xml
+       the packages from the selections are ignored
+       
+./data.libzypp/bugzilla-tests/bug308252-test.xml
+./data.libzypp/bugzilla-tests/bug239199-test.xml
+./data.libzypp/bugzilla-tests/bug222531-test.xml
+./data.libzypp/patch-tests/jumbo-patch-test.xml
+./data.libzypp/patch-tests/kernel-single-update-test.xml
+./data.libzypp/patch-tests/kernel-update-test.xml
+./data.libzypp/patch-tests/parallel-atmos-test.xml
+./data.libzypp/patch-tests/parallel-atoms-equal-patch-test.xml
+./data.libzypp/patch-tests/script-test.xml
+./data.libzypp/freshen-tests/exercise-1-test.xml
+./data.libzypp/freshen-tests/exercise-11-test.xml
+./data.libzypp/freshen-tests/exercise-1f-test.xml
+./data.libzypp/freshen-tests/exercise-6-test.xml
+./data.libzypp/freshen-tests/exercise-6f-test.xml
+./data.libzypp/freshen-tests/exercise-7-test.xml
+./data.libzypp/freshen-tests/exercise-7f-test.xml
+./data.libzypp/freshen-tests/exercise-8-test.xml
+./data.libzypp/bugzilla-tests/bug230685-test.xml
+./data.libzypp/bugzilla-tests/bug238284-test.xml
+       patches pretty much unimplemented - very likely not a solver problem
+

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug217574-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug217574-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug217574-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug217574-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,975 @@
+<?xml version="1.0"?>
+<!-- Bug217574- Packages wich does not fulfill all requirements while an update -->
+<!-- will not be deleted it the user has set it to "keep"-->
+<test>
+<setup arch="i686">
+       <system file="Bug217574-system.xml.gz"/>
+       <channel file="Bug217574-3-package.xml.gz" name="3" />
+       <channel file="Bug217574-1-package.xml.gz" name="1" />
+</setup>
+<trial>
+<install channel="3" kind="package" name="bc" arch="i586" version="1.06" release="790"/>
+<install channel="3" kind="package" name="beagle" arch="i586" version="0.2.16.2" release="6"/>
+<install channel="3" kind="package" name="3ddiag" arch="i586" version="0.740" release="15"/>
+<install channel="3" kind="pattern" name="sw_management_x11" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="package" name="MozillaFirefox-translations" arch="i586" version="2.0.0.2" release="5"/>
+<install channel="3" kind="package" name="desktop-data-SuSE" arch="noarch" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="sw_management" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="zmd_x11" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="kde_games" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="kde_basis" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="package" name="AdobeICCProfiles" arch="noarch" version="2.0" release="38"/>
+<install channel="3" kind="package" name="OpenOffice_org-de" arch="i586" version="2.1" release="10"/>
+<install channel="3" kind="package" name="audit-libs" arch="i586" version="1.2.9" release="10"/>
+<install channel="3" kind="package" name="autofs" arch="i586" version="4.1.4" release="67"/>
+<install channel="3" kind="package" name="OpenOffice_org-Quickstarter" arch="i586" version="1.0" release="531"/>
+<install channel="3" kind="pattern" name="kde" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="zmd" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="apparmor" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="package" name="CheckHardware" arch="i586" version="0.1" release="1030"/>
+<install channel="3" kind="pattern" name="xgl" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="package" name="Crystalcursors" arch="noarch" version="0.5" release="76"/>
+<install channel="3" kind="package" name="Mesa" arch="i586" version="6.5.2" release="19"/>
+<install channel="3" kind="package" name="ImageMagick-Magick++" arch="i586" version="6.3.0.0" release="33"/>
+<install channel="3" kind="package" name="ImageMagick" arch="i586" version="6.3.0.0" release="33"/>
+<install channel="3" kind="package" name="RealPlayer" arch="i586" version="10.0.8" release="52"/>
+<install channel="3" kind="package" name="MesaGLw" arch="i586" version="6.5.2" release="16"/>
+<install channel="3" kind="package" name="OpenOffice_org-kde" arch="i586" version="2.1" release="10"/>
+<install channel="3" kind="pattern" name="x11" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="games" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="fonts" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="kde_imaging" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="imaging" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="non_oss" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="base" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="pattern" name="yast2_basis" arch="i586" version="10.3" release="14"/>
+<install channel="3" kind="package" name="GraphicsMagick" arch="i586" version="1.1.7" release="41"/>
+<install channel="3" kind="package" name="915resolution" arch="i586" version="0.5.2" release="23"/>
+<install channel="3" kind="package" name="FreeNX" arch="noarch" version="0.5.0" release="38"/>
+<install channel="3" kind="package" name="classpath" arch="i586" version="0.92" release="37"/>
+<install channel="3" kind="package" name="DirectFB" arch="i586" version="1.0.0" release="3"/>
+<install channel="3" kind="package" name="blocxx" arch="i586" version="1.0.0" release="43"/>
+<install channel="3" kind="package" name="blocxx-devel" arch="i586" version="1.0.0" release="43"/>
+<install channel="3" kind="package" name="MozillaFirefox" arch="i586" version="2.0.0.2" release="5"/>
+<install channel="3" kind="package" name="apache2" arch="i586" version="2.2.4" release="9"/>
+<install channel="3" kind="package" name="SuSEfirewall2" arch="noarch" version="3.6_SVNr167" release="3"/>
+<install channel="3" kind="package" name="WindowMaker-applets" arch="i586" version="1.0" release="707"/>
+<install channel="3" kind="package" name="avahi-compat-mDNSResponder" arch="i586" version="0.6.17" release="7"/>
+<install channel="3" kind="package" name="NX" arch="i586" version="1.5.0" release="86"/>
+<install channel="3" kind="package" name="NetworkManager" arch="i586" version="0.6.4" release="71"/>
+<install channel="3" kind="package" name="NetworkManager-kde" arch="i586" version="0.1r631225" release="9"/>
+<install channel="3" kind="package" name="cyrus-sasl" arch="i586" version="2.1.22" release="37"/>
+<install channel="3" kind="package" name="cyrus-sasl-crammd5" arch="i586" version="2.1.22" release="37"/>
+<install channel="3" kind="package" name="cyrus-sasl-digestmd5" arch="i586" version="2.1.22" release="37"/>
+<install channel="3" kind="package" name="cyrus-sasl-plain" arch="i586" version="2.1.22" release="37"/>
+<install channel="3" kind="package" name="cyrus-sasl-saslauthd" arch="i586" version="2.1.22" release="37"/>
+<install channel="3" kind="package" name="amarok" arch="i586" version="1.4.5" release="11"/>
+<install channel="3" kind="package" name="OpenOffice_org" arch="i586" version="2.1" release="10"/>
+<install channel="3" kind="package" name="OpenEXR" arch="i586" version="1.2.2" release="50"/>
+<install channel="3" kind="package" name="bind-libs" arch="i586" version="9.4.0" release="3"/>
+<install channel="3" kind="package" name="PolicyKit" arch="i586" version="0.2_git20060822" release="47"/>
+<install channel="3" kind="package" name="SDL_Pango" arch="i586" version="0.1.2" release="25"/>
+<install channel="3" kind="package" name="bind-utils" arch="i586" version="9.4.0" release="3"/>
+<install channel="3" kind="package" name="autoyast2" arch="noarch" version="2.15.3" release="4"/>
+<install channel="3" kind="package" name="autoyast2-installation" arch="noarch" version="2.15.3" release="4"/>
+<install channel="3" kind="package" name="WindowMaker" arch="i586" version="0.92.0" release="59"/>
+<install channel="3" kind="package" name="SDL" arch="i586" version="1.2.11" release="38"/>
+<install channel="3" kind="package" name="dmraid" arch="i586" version="1.0.0.rc13" release="20"/>
+<install channel="3" kind="package" name="diffutils" arch="i586" version="2.8.7" release="46"/>
+<install channel="3" kind="package" name="digikamimageplugins" arch="i586" version="0.9.1" release="3"/>
+<install channel="3" kind="package" name="dirmngr" arch="i586" version="0.9.5" release="32"/>
+<install channel="3" kind="package" name="digikam" arch="i586" version="0.9.1" release="3"/>
+<install channel="3" kind="package" name="SDL_image" arch="i586" version="1.2.5" release="40"/>
+<install channel="3" kind="package" name="bash" arch="i586" version="3.2" release="14"/>
+<install channel="3" kind="package" name="dialog" arch="i586" version="1.0" release="27"/>
+<install channel="3" kind="package" name="cdparanoia" arch="i586" version="IIIalpha9.8" release="591"/>
+<install channel="3" kind="package" name="aaa_base" arch="i586" version="10.3" release="16"/>
+<install channel="3" kind="package" name="agfa-fonts" arch="noarch" version="2003.03.19" release="60"/>
+<install channel="3" kind="package" name="SDL_mixer" arch="i586" version="1.2.7" release="40"/>
+<install channel="3" kind="package" name="fbset" arch="i586" version="2.1" release="822"/>
+<install channel="3" kind="package" name="freeciv" arch="i586" version="2.1.0" release="40"/>
+<install channel="3" kind="package" name="fftw3" arch="i586" version="3.1.2" release="27"/>
+<install channel="3" kind="package" name="file" arch="i586" version="4.18" release="12"/>
+<install channel="3" kind="package" name="fillup" arch="i586" version="1.42" release="145"/>
+<install channel="3" kind="package" name="findutils" arch="i586" version="4.2.30" release="3"/>
+<install channel="3" kind="package" name="filesystem" arch="i586" version="10.3" release="12"/>
+<install channel="3" kind="package" name="fileshareset" arch="i586" version="2.0" release="251"/>
+<install channel="3" kind="package" name="finger" arch="i586" version="1.3" release="42"/>
+<install channel="3" kind="package" name="flac" arch="i586" version="1.1.2" release="42"/>
+<install channel="3" kind="package" name="flash-player" arch="i586" version="9.0.31.0" release="5"/>
+<install channel="3" kind="package" name="fontconfig" arch="i586" version="2.4.2" release="3"/>
+<install channel="3" kind="package" name="fonts-config" arch="noarch" version="20061025" release="19"/>
+<install channel="3" kind="package" name="fop" arch="noarch" version="0.20.5" release="112"/>
+<install channel="3" kind="package" name="foomatic-filters" arch="i586" version="3.0.2" release="64"/>
+<install channel="3" kind="package" name="freealut" arch="i586" version="1.1.0" release="27"/>
+<install channel="3" kind="package" name="binutils" arch="i586" version="2.17.50.20070219" release="5"/>
+<install channel="3" kind="package" name="bitstream-vera" arch="noarch" version="1.10" release="206"/>
+<install channel="3" kind="package" name="aspell-de" arch="i586" version="0.60.20030222.1" release="26"/>
+<install channel="3" kind="package" name="aspell-en" arch="i586" version="6.0" release="56"/>
+<install channel="3" kind="package" name="audiofile" arch="i586" version="0.2.6" release="43"/>
+<install channel="3" kind="package" name="audit" arch="i586" version="1.2.9" release="10"/>
+<install channel="3" kind="package" name="a2ps" arch="i586" version="4.13" release="1120"/>
+<install channel="3" kind="package" name="bootsplash" arch="i586" version="3.3" release="45"/>
+<install channel="3" kind="package" name="bootsplash-theme-SuSE" arch="i586" version="3.1" release="111"/>
+<install channel="3" kind="package" name="bridge-utils" arch="i586" version="1.2" release="19"/>
+<install channel="3" kind="package" name="deltarpm" arch="i586" version="3.4" release="3"/>
+<install channel="3" kind="package" name="apparmor-docs" arch="noarch" version="2.0.1" release="13"/>
+<install channel="3" kind="package" name="apparmor-parser" arch="i586" version="2.0.1" release="18"/>
+<install channel="3" kind="package" name="SDL_ttf" arch="i586" version="2.0.8" release="41"/>
+<install channel="3" kind="package" name="acl" arch="i586" version="2.2.34" release="40"/>
+<install channel="3" kind="package" name="acpid" arch="i586" version="1.0.4" release="60"/>
+<install channel="3" kind="package" name="cups-drivers" arch="i586" version="1.2.7" release="26"/>
+<install channel="3" kind="package" name="cups-client" arch="i586" version="1.2.8" release="3"/>
+<install channel="3" kind="package" name="cups" arch="i586" version="1.2.8" release="3"/>
+<install channel="3" kind="package" name="cups-libs" arch="i586" version="1.2.8" release="3"/>
+<install channel="3" kind="package" name="curl" arch="i586" version="7.16.1" release="3"/>
+<install channel="3" kind="package" name="SDL_net" arch="i586" version="1.2.6" release="3"/>
+<install channel="3" kind="package" name="SDL_perl" arch="i586" version="1.20.0" release="412"/>
+<install channel="3" kind="package" name="alsa" arch="i586" version="1.0.13" release="32"/>
+<install channel="3" kind="package" name="amarok-libvisual" arch="i586" version="1.4.5" release="11"/>
+<install channel="3" kind="package" name="amarok-xine" arch="i586" version="1.4.5" release="11"/>
+<install channel="3" kind="package" name="apache2-prefork" arch="i586" version="2.2.4" release="9"/>
+<install channel="3" kind="package" name="chromium" arch="i586" version="0.9.12" release="1057"/>
+<install channel="3" kind="package" name="cifs-mount" arch="i586" version="3.0.24" release="8"/>
+<install channel="3" kind="package" name="beagle-index" arch="i586" version="10.3_20070203" release="8"/>
+<install channel="3" kind="package" name="docbook_4" arch="noarch" version="4.5" release="4"/>
+<install channel="3" kind="package" name="dos2unix" arch="i586" version="3.1" release="342"/>
+<install channel="3" kind="package" name="dosbootdisk" arch="i586" version="1.1" release="81"/>
+<install channel="3" kind="package" name="dosfstools" arch="i586" version="2.11" release="42"/>
+<install channel="3" kind="package" name="dvd+rw-tools" arch="i586" version="7.0" release="9"/>
+<install channel="3" kind="package" name="e2fsprogs" arch="i586" version="1.39+1.40_WIP_20061114" release="7"/>
+<install channel="3" kind="package" name="dbus-1-python" arch="i586" version="0.80.1" release="5"/>
+<install channel="3" kind="package" name="dbus-1-qt3" arch="i586" version="0.62" release="52"/>
+<install channel="3" kind="package" name="dbus-1-glib-devel" arch="i586" version="0.73" release="3"/>
+<install channel="3" kind="package" name="dbus-1-glib" arch="i586" version="0.73" release="3"/>
+<install channel="3" kind="package" name="dbus-1-mono" arch="i586" version="0.63" release="42"/>
+<install channel="3" kind="package" name="dbus-1-x11" arch="i586" version="1.0.2" release="13"/>
+<install channel="3" kind="package" name="dbus-1-qt3-devel" arch="i586" version="0.62" release="52"/>
+<install channel="3" kind="package" name="dcraw" arch="i586" version="1.364" release="4"/>
+<install channel="3" kind="package" name="evms-gui" arch="i586" version="2.5.5" release="98"/>
+<install channel="3" kind="package" name="dejagnu" arch="i586" version="1.4.4" release="43"/>
+<install channel="3" kind="package" name="dejavu" arch="noarch" version="2.14" release="5"/>
+<install channel="3" kind="package" name="exiftool" arch="i586" version="6.49" release="17"/>
+<install channel="3" kind="package" name="expat" arch="i586" version="2.0.0" release="39"/>
+<install channel="3" kind="package" name="expect" arch="i586" version="5.43.0" release="41"/>
+<install channel="3" kind="package" name="enscript" arch="i586" version="1.6.4" release="48"/>
+<install channel="3" kind="package" name="esound" arch="i586" version="0.2.36" release="50"/>
+<install channel="3" kind="package" name="ethtool" arch="i586" version="5" release="26"/>
+<install channel="3" kind="package" name="evms" arch="i586" version="2.5.5" release="98"/>
+<install channel="3" kind="package" name="db" arch="i586" version="4.4.20" release="23"/>
+<install channel="3" kind="package" name="db-utils" arch="i586" version="4.4.20" release="23"/>
+<install channel="3" kind="package" name="dbus-1" arch="i586" version="1.0.2" release="13"/>
+<install channel="3" kind="package" name="db43" arch="i586" version="4.3.29" release="25"/>
+<install channel="3" kind="package" name="dbus-1-devel" arch="i586" version="1.0.2" release="13"/>
+<install channel="3" kind="package" name="cdrdao" arch="i586" version="1.2.2" release="42"/>
+<install channel="3" kind="package" name="WindowMaker-themes" arch="noarch" version="0.1" release="278"/>
+<install channel="3" kind="package" name="cdrkit-cdrtools-compat" arch="i586" version="1.1.2" release="6"/>
+<install channel="3" kind="package" name="checkmedia" arch="i586" version="2.1" release="42"/>
+<install channel="3" kind="package" name="busybox" arch="i586" version="1.2.2" release="9"/>
+<install channel="3" kind="package" name="atk" arch="i586" version="1.17.0" release="4"/>
+<install channel="3" kind="package" name="attr" arch="i586" version="2.4.28" release="45"/>
+<install channel="3" kind="package" name="bluez-libs" arch="i586" version="3.9" release="6"/>
+<install channel="3" kind="package" name="bluez-utils" arch="i586" version="3.9" release="9"/>
+<install channel="3" kind="package" name="convmv" arch="noarch" version="1.10" release="27"/>
+<install channel="3" kind="package" name="coreutils" arch="i586" version="6.8" release="5"/>
+<install channel="3" kind="package" name="cpio" arch="i586" version="2.6" release="48"/>
+<install channel="3" kind="package" name="cpp" arch="i586" version="4.1.3" release="37"/>
+<install channel="3" kind="package" name="cpp41" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="cpufrequtils" arch="i586" version="002" release="42"/>
+<install channel="3" kind="package" name="cracklib" arch="i586" version="2.8.9" release="27"/>
+<install channel="3" kind="package" name="cron" arch="i586" version="4.1" release="82"/>
+<install channel="3" kind="package" name="aaa_skel" arch="i586" version="2007.3.7" release="3"/>
+<install channel="3" kind="package" name="aalib" arch="i586" version="1.4.0" release="341"/>
+<install channel="3" kind="package" name="apparmor-profiles" arch="noarch" version="2.0.1" release="26"/>
+<install channel="3" kind="package" name="bzip2" arch="i586" version="1.0.4" release="5"/>
+<install channel="3" kind="package" name="cabextract" arch="i586" version="1.2" release="23"/>
+<install channel="3" kind="package" name="cairo" arch="i586" version="1.2.4" release="24"/>
+<install channel="3" kind="package" name="aspell" arch="i586" version="0.60.5" release="7"/>
+<install channel="3" kind="package" name="cmake" arch="i586" version="2.4.6" release="5"/>
+<install channel="3" kind="package" name="compat-libstdc++" arch="i586" version="5.0.7" release="51"/>
+<install channel="3" kind="package" name="compat" arch="i586" version="2006.1.25" release="36"/>
+<install channel="3" kind="package" name="compat-openssl097g" arch="i586" version="0.9.7g" release="41"/>
+<install channel="3" kind="package" name="compiz" arch="i586" version="0.3.7" release="9"/>
+<install channel="3" kind="package" name="arts" arch="i586" version="1.5.6" release="6"/>
+<install channel="3" kind="package" name="desktop-file-utils" arch="i586" version="0.12" release="3"/>
+<install channel="3" kind="package" name="desktop-translations" arch="noarch" version="10.1" release="74"/>
+<install channel="3" kind="package" name="device-mapper" arch="i586" version="1.02.13" release="12"/>
+<install channel="3" kind="package" name="devs" arch="i586" version="10.3" release="6"/>
+<install channel="3" kind="package" name="dhcdbd" arch="i586" version="1.14" release="22"/>
+<install channel="3" kind="package" name="dhcp" arch="i586" version="3.0.5" release="19"/>
+<install channel="3" kind="package" name="dhcp-client" arch="i586" version="3.0.5" release="19"/>
+<install channel="3" kind="package" name="dhcpcd" arch="i586" version="1.3.22pl4" release="249"/>
+<install channel="3" kind="package" name="apparmor-utils" arch="noarch" version="2.0.1" release="15"/>
+<install channel="3" kind="package" name="boost" arch="i586" version="1.33.1" release="56"/>
+<install channel="3" kind="package" name="freeglut" arch="i586" version="060903" release="31"/>
+<install channel="3" kind="package" name="freetype" arch="i586" version="1.3.1" release="1208"/>
+<install channel="3" kind="package" name="freetype2" arch="i586" version="2.3.1" release="4"/>
+<install channel="3" kind="package" name="fribidi" arch="i586" version="0.10.4" release="533"/>
+<install channel="3" kind="package" name="frozen-bubble" arch="i586" version="2.1.0" release="21"/>
+<install channel="3" kind="package" name="ft2demos" arch="i586" version="2.3.1" release="4"/>
+<install channel="3" kind="package" name="ftgl" arch="i586" version="2.1.2" release="45"/>
+<install channel="3" kind="package" name="fvwm2" arch="i586" version="2.5.21" release="7"/>
+<install channel="3" kind="package" name="gail" arch="i586" version="1.17.0" release="4"/>
+<install channel="3" kind="package" name="gawk" arch="i586" version="3.1.5" release="48"/>
+<install channel="3" kind="package" name="gcc-c++" arch="i586" version="4.1.3" release="37"/>
+<install channel="3" kind="package" name="gcc-gij" arch="i586" version="4.1.3" release="37"/>
+<install channel="3" kind="package" name="gcc" arch="i586" version="4.1.3" release="37"/>
+<install channel="3" kind="package" name="gcc41" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="gcc41-c++" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="gcc41-gij" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="gconf2" arch="i586" version="2.16.0" release="3"/>
+<install channel="3" kind="package" name="gdb" arch="i586" version="6.6" release="19"/>
+<install channel="3" kind="package" name="gdbm" arch="i586" version="1.8.3" release="268"/>
+<install channel="3" kind="package" name="gettext" arch="i586" version="0.16" release="7"/>
+<install channel="3" kind="package" name="gettext-devel" arch="i586" version="0.16" release="7"/>
+<install channel="3" kind="package" name="ghostscript-fonts-other" arch="i586" version="8.15.3" release="40"/>
+<install channel="3" kind="package" name="giflib" arch="i586" version="4.1.4" release="46"/>
+<install channel="3" kind="package" name="ghostscript-library" arch="i586" version="8.15.3" release="40"/>
+<install channel="3" kind="package" name="ghostscript-fonts-std" arch="i586" version="8.15.3" release="40"/>
+<install channel="3" kind="package" name="glibc-devel" arch="i686" version="2.5" release="37"/>
+<install channel="3" kind="package" name="ghostscript-x11" arch="i586" version="8.15.3" release="40"/>
+<install channel="3" kind="package" name="gimp" arch="i586" version="2.2.13" release="48"/>
+<install channel="3" kind="package" name="gimp-help" arch="noarch" version="0.9" release="64"/>
+<install channel="3" kind="package" name="glib2" arch="i586" version="2.12.9" release="5"/>
+<install channel="3" kind="package" name="gle" arch="i586" version="3.0.6" release="699"/>
+<install channel="3" kind="package" name="glib" arch="i586" version="1.2.10" release="637"/>
+<install channel="3" kind="package" name="glib-sharp2" arch="i586" version="2.8.3" release="50"/>
+<install channel="3" kind="package" name="glibc" arch="i686" version="2.5" release="37"/>
+<install channel="3" kind="package" name="glibc-i18ndata" arch="i586" version="2.5" release="37"/>
+<install channel="3" kind="package" name="glibc-locale" arch="i586" version="2.5" release="37"/>
+<install channel="3" kind="package" name="gmime" arch="i586" version="2.2.3" release="42"/>
+<install channel="3" kind="package" name="glitz" arch="i586" version="0.5.6" release="36"/>
+<install channel="3" kind="package" name="gmp" arch="i586" version="4.2.1" release="21"/>
+<install channel="3" kind="package" name="gnokii" arch="i586" version="0.6.14" release="48"/>
+<install channel="3" kind="package" name="gnome-icon-theme" arch="noarch" version="2.17.91" release="5"/>
+<install channel="3" kind="package" name="gnome-keyring" arch="i586" version="0.7.91" release="3"/>
+<install channel="3" kind="package" name="gnome-vfs2" arch="i586" version="2.17.91" release="6"/>
+<install channel="3" kind="package" name="gnutls" arch="i586" version="1.4.4" release="26"/>
+<install channel="3" kind="package" name="gpart" arch="i586" version="0.1h" release="522"/>
+<install channel="3" kind="package" name="gpg" arch="i586" version="1.4.6" release="6"/>
+<install channel="3" kind="package" name="gpg2" arch="i586" version="2.0.1rc1" release="7"/>
+<install channel="3" kind="package" name="gpgme" arch="i586" version="1.1.4" release="3"/>
+<install channel="3" kind="package" name="gpm" arch="i586" version="1.20.1" release="349"/>
+<install channel="3" kind="package" name="grep" arch="i586" version="2.5.1a" release="47"/>
+<install channel="3" kind="package" name="groff" arch="i586" version="1.18.1.1" release="62"/>
+<install channel="3" kind="package" name="grub" arch="i586" version="0.97" release="46"/>
+<install channel="3" kind="package" name="gstreamer010" arch="i586" version="0.10.10" release="26"/>
+<install channel="3" kind="package" name="gsf-sharp" arch="i586" version="0.8.1" release="7"/>
+<install channel="3" kind="package" name="gstreamer010-plugins-base" arch="i586" version="0.10.10" release="25"/>
+<install channel="3" kind="package" name="gtk" arch="i586" version="1.2.10" release="944"/>
+<install channel="3" kind="package" name="gtk-sharp2" arch="i586" version="2.8.3" release="50"/>
+<install channel="3" kind="package" name="gtk2" arch="i586" version="2.10.9" release="4"/>
+<install channel="3" kind="package" name="gtksourceview" arch="i586" version="1.8.4" release="3"/>
+<install channel="3" kind="package" name="gwenview" arch="i586" version="1.4.1" release="21"/>
+<install channel="3" kind="package" name="gzip" arch="i586" version="1.3.11" release="5"/>
+<install channel="3" kind="package" name="hal-resmgr" arch="i586" version="0.1_SVNr124" release="23"/>
+<install channel="3" kind="package" name="hal" arch="i586" version="0.5.8_git20070305" release="5"/>
+<install channel="3" kind="package" name="hdparm" arch="i586" version="6.9" release="15"/>
+<install channel="3" kind="package" name="hfsutils" arch="i586" version="3.2.6" release="1084"/>
+<install channel="3" kind="package" name="hplip" arch="i586" version="1.7.2" release="3"/>
+<install channel="3" kind="package" name="hplip-hpijs" arch="i586" version="1.7.2" release="3"/>
+<install channel="3" kind="package" name="htdig" arch="i586" version="3.2.0b6" release="54"/>
+<install channel="3" kind="package" name="hwinfo" arch="i586" version="13.28" release="3"/>
+<install channel="3" kind="package" name="hwinfo-devel" arch="i586" version="13.28" release="3"/>
+<install channel="3" kind="package" name="icecream" arch="i586" version="0.7.14" release="24"/>
+<install channel="3" kind="package" name="id3lib" arch="i586" version="3.8.3" release="131"/>
+<install channel="3" kind="package" name="ifnteuro" arch="noarch" version="1.2.1" release="248"/>
+<install channel="3" kind="package" name="ifplugd" arch="i586" version="0.28" release="56"/>
+<install channel="3" kind="package" name="imlib" arch="i586" version="1.9.14" release="253"/>
+<install channel="3" kind="package" name="imlib2" arch="i586" version="1.3.0" release="17"/>
+<install channel="3" kind="package" name="imlib2-loaders" arch="i586" version="1.3.0" release="17"/>
+<install channel="3" kind="package" name="info" arch="i586" version="4.8" release="52"/>
+<install channel="3" kind="package" name="info2html" arch="noarch" version="2.0" release="33"/>
+<install channel="3" kind="package" name="initviocons" arch="i586" version="0.4" release="341"/>
+<install channel="3" kind="package" name="insserv" arch="i586" version="1.09.0" release="7"/>
+<install channel="3" kind="package" name="inst-source-utils" arch="noarch" version="2007.3.13" release="3"/>
+<install channel="3" kind="package" name="intlfnts" arch="noarch" version="1.2.1" release="248"/>
+<install channel="3" kind="package" name="iproute2" arch="i586" version="2.6.15" release="57"/>
+<install channel="3" kind="package" name="iptables" arch="i586" version="1.3.7" release="9"/>
+<install channel="3" kind="package" name="iputils" arch="i586" version="ss021109" release="199"/>
+<install channel="3" kind="package" name="irqbalance" arch="i586" version="0.09" release="87"/>
+<install channel="3" kind="package" name="isapnp" arch="i586" version="1.26" release="532"/>
+<install channel="3" kind="package" name="iso_ent" arch="noarch" version="2000.11.03" release="699"/>
+<install channel="3" kind="package" name="ispell" arch="i586" version="3.2.06" release="505"/>
+<install channel="3" kind="package" name="ispell-american" arch="i586" version="3.2.06" release="505"/>
+<install channel="3" kind="package" name="ispell-german" arch="i586" version="1.5" release="288"/>
+<install channel="3" kind="package" name="ispell-ngerman" arch="i586" version="1.5" release="288"/>
+<install channel="3" kind="package" name="jack" arch="i586" version="0.102.20" release="27"/>
+<install channel="3" kind="package" name="java-1_4_2-sun" arch="i586" version="1.4.2_update13" release="12"/>
+<install channel="3" kind="package" name="java-1_4_2-gcj-compat" arch="i586" version="1.4.2.0" release="84"/>
+<install channel="3" kind="package" name="jfsutils" arch="i586" version="1.1.11" release="28"/>
+<install channel="3" kind="package" name="joe" arch="i586" version="3.5" release="27"/>
+<install channel="3" kind="package" name="jpackage-utils" arch="i586" version="1.7.0" release="26"/>
+<install channel="3" kind="package" name="jpeg" arch="i586" version="6b" release="778"/>
+<install channel="3" kind="package" name="k3b" arch="i586" version="0.12.17" release="49"/>
+<install channel="3" kind="package" name="kaffeine" arch="i586" version="0.8.3" release="17"/>
+<install channel="3" kind="package" name="kbd" arch="i586" version="1.12" release="96"/>
+<install channel="3" kind="package" name="kcm_gtk" arch="i586" version="0.7cvs20060209" release="42"/>
+<install channel="3" kind="package" name="kde3-i18n-de" arch="noarch" version="3.5.6" release="3"/>
+<install channel="3" kind="package" name="kdeaddons3-kicker" arch="i586" version="3.5.6" release="3"/>
+<install channel="3" kind="package" name="kdeaddons3-konqueror" arch="i586" version="3.5.6" release="3"/>
+<install channel="3" kind="package" name="kdeartwork3-kscreensaver" arch="i586" version="3.5.6" release="7"/>
+<install channel="3" kind="package" name="kdeartwork3-xscreensaver" arch="i586" version="3.5.6" release="7"/>
+<install channel="3" kind="package" name="kdebase3-nsplugin" arch="i586" version="3.5.6" release="16"/>
+<install channel="3" kind="package" name="kdebase3-session" arch="i586" version="3.5.6" release="16"/>
+<install channel="3" kind="package" name="kdebase3-samba" arch="i586" version="3.5.6" release="16"/>
+<install channel="3" kind="package" name="kdebase3" arch="i586" version="3.5.6" release="16"/>
+<install channel="3" kind="package" name="kdegames3" arch="i586" version="3.5.6" release="7"/>
+<install channel="3" kind="package" name="kdebluetooth" arch="i586" version="0.99.0svn576598" release="57"/>
+<install channel="3" kind="package" name="kdebase3-SuSE" arch="i586" version="10.3" release="25"/>
+<install channel="3" kind="package" name="kdebase3-beagle" arch="i586" version="3.5.6" release="16"/>
+<install channel="3" kind="package" name="kdebase3-kdm" arch="i586" version="3.5.6" release="16"/>
+<install channel="3" kind="package" name="kdebase3-ksysguardd" arch="i586" version="3.5.6" release="16"/>
+<install channel="3" kind="package" name="kdegraphics3" arch="i586" version="3.5.6" release="13"/>
+<install channel="3" kind="package" name="kdegraphics3-kamera" arch="i586" version="3.5.6" release="13"/>
+<install channel="3" kind="package" name="kdegraphics3-pdf" arch="i586" version="3.5.6" release="13"/>
+<install channel="3" kind="package" name="kdegraphics3-postscript" arch="i586" version="3.5.6" release="13"/>
+<install channel="3" kind="package" name="kdegraphics3-scan" arch="i586" version="3.5.6" release="13"/>
+<install channel="3" kind="package" name="kdelibs3" arch="i586" version="3.5.6" release="15"/>
+<install channel="3" kind="package" name="kdemultimedia3" arch="i586" version="3.5.6" release="9"/>
+<install channel="3" kind="package" name="kdemultimedia3-CD" arch="i586" version="3.5.6" release="9"/>
+<install channel="3" kind="package" name="kdelibs3-doc" arch="i586" version="3.5.6" release="15"/>
+<install channel="3" kind="package" name="kdemultimedia3-mixer" arch="i586" version="3.5.6" release="9"/>
+<install channel="3" kind="package" name="kdenetwork3" arch="i586" version="3.5.6" release="10"/>
+<install channel="3" kind="package" name="kdenetwork3-InstantMessenger" arch="i586" version="3.5.6" release="10"/>
+<install channel="3" kind="package" name="kdepim3-kpilot" arch="i586" version="3.5.6" release="12"/>
+<install channel="3" kind="package" name="kdenetwork3-news" arch="i586" version="3.5.6" release="10"/>
+<install channel="3" kind="package" name="kdenetwork3-vnc" arch="i586" version="3.5.6" release="10"/>
+<install channel="3" kind="package" name="kdepim3-networkstatus" arch="i586" version="3.5.6" release="12"/>
+<install channel="3" kind="package" name="kdepim3" arch="i586" version="3.5.6" release="12"/>
+<install channel="3" kind="package" name="kdepim3-notes" arch="i586" version="3.5.6" release="12"/>
+<install channel="3" kind="package" name="kdetv" arch="i586" version="0.8.9" release="28"/>
+<install channel="3" kind="package" name="kdeutils3" arch="i586" version="3.5.6" release="7"/>
+<install channel="3" kind="package" name="kernel-default" arch="i586" version="2.6.20.2" release="3"/>
+<install channel="3" kind="package" name="kernel-xen" arch="i586" version="2.6.20.2" release="3"/>
+<install channel="3" kind="package" name="kernel-xenpae" arch="i586" version="2.6.20.2" release="3"/>
+<install channel="3" kind="package" name="kerry" arch="i586" version="0.2.2" release="8"/>
+<install channel="3" kind="package" name="kio_beagle" arch="i586" version="0.3.1" release="51"/>
+<install channel="3" kind="package" name="kio_iso" arch="i586" version="1.70.1" release="51"/>
+<install channel="3" kind="package" name="kio_slp" arch="i586" version="0.4.1" release="60"/>
+<install channel="3" kind="package" name="kio_ipodslave" arch="i586" version="0.8.pre1" release="48"/>
+<install channel="3" kind="package" name="kipi-plugins" arch="i586" version="0.1.3" release="7"/>
+<install channel="3" kind="package" name="kitchensync" arch="i586" version="0.01svn602778" release="36"/>
+<install channel="3" kind="package" name="klogd" arch="i586" version="1.4.1" release="596"/>
+<install channel="3" kind="package" name="knights" arch="i586" version="0.6" release="474"/>
+<install channel="3" kind="package" name="koffice" arch="i586" version="1.6.2" release="6"/>
+<install channel="3" kind="package" name="koffice-i18n-de" arch="noarch" version="1.6.2" release="3"/>
+<install channel="3" kind="package" name="koffice-illustration" arch="i586" version="1.6.2" release="6"/>
+<install channel="3" kind="package" name="konversation" arch="i586" version="1.0.1" release="40"/>
+<install channel="3" kind="package" name="kpowersave" arch="i586" version="0.7.2" release="8"/>
+<install channel="3" kind="package" name="krb5" arch="i586" version="1.6" release="13"/>
+<install channel="3" kind="package" name="krecord" arch="i586" version="1.16" release="73"/>
+<install channel="3" kind="package" name="ksh" arch="i586" version="93r" release="50"/>
+<install channel="3" kind="package" name="ksudoku" arch="i586" version="0.3" release="69"/>
+<install channel="3" kind="package" name="ksymoops" arch="i586" version="2.4.11" release="42"/>
+<install channel="3" kind="package" name="ktorrent" arch="i586" version="2.1.2" release="3"/>
+<install channel="3" kind="package" name="kwin-decor-suse2" arch="i586" version="0.4" release="33"/>
+<install channel="3" kind="package" name="less" arch="i586" version="394" release="39"/>
+<install channel="3" kind="package" name="lbreakout" arch="i586" version="2.5.2" release="57"/>
+<install channel="3" kind="package" name="lftp" arch="i586" version="3.5.6" release="22"/>
+<install channel="3" kind="package" name="ldapcpplib" arch="i586" version="0.0.4" release="49"/>
+<install channel="3" kind="package" name="libacl" arch="i586" version="2.2.34" release="40"/>
+<install channel="3" kind="package" name="libakode" arch="i586" version="2.0.1" release="46"/>
+<install channel="3" kind="package" name="libao" arch="i586" version="0.8.6" release="56"/>
+<install channel="3" kind="package" name="libapparmor" arch="i586" version="2.0" release="42"/>
+<install channel="3" kind="package" name="libapr-util1" arch="i586" version="1.2.8" release="13"/>
+<install channel="3" kind="package" name="libapr1" arch="i586" version="1.2.8" release="8"/>
+<install channel="3" kind="package" name="libart_lgpl" arch="i586" version="2.3.17" release="45"/>
+<install channel="3" kind="package" name="libattr" arch="i586" version="2.4.28" release="45"/>
+<install channel="3" kind="package" name="libbeagle" arch="i586" version="0.2.16.2" release="6"/>
+<install channel="3" kind="package" name="libbonobo" arch="i586" version="2.17.91" release="3"/>
+<install channel="3" kind="package" name="libbonoboui" arch="i586" version="2.17.91" release="4"/>
+<install channel="3" kind="package" name="libcom_err" arch="i586" version="1.39+1.40_WIP_20061114" release="7"/>
+<install channel="3" kind="package" name="libcroco" arch="i586" version="0.6.1" release="28"/>
+<install channel="3" kind="package" name="libdrm" arch="i586" version="2.3.0" release="9"/>
+<install channel="3" kind="package" name="libdv" arch="i586" version="0.104" release="61"/>
+<install channel="3" kind="package" name="libevent" arch="i586" version="1.3b" release="3"/>
+<install channel="3" kind="package" name="libexif" arch="i586" version="0.6.14" release="28"/>
+<install channel="3" kind="package" name="libgcc41" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="libgcj41" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="libgcrypt" arch="i586" version="1.2.4" release="4"/>
+<install channel="3" kind="package" name="libglade2" arch="i586" version="2.6.0" release="41"/>
+<install channel="3" kind="package" name="libgimpprint" arch="i586" version="4.2.7" release="117"/>
+<install channel="3" kind="package" name="ed" arch="i586" version="0.2" release="904"/>
+<install channel="3" kind="package" name="efont-unicode" arch="noarch" version="0.4.2" release="58"/>
+<install channel="3" kind="package" name="eject" arch="i586" version="2.1.0" release="37"/>
+<install channel="3" kind="package" name="beagle-firefox" arch="i586" version="0.2.16.2" release="6"/>
+<install channel="3" kind="package" name="at" arch="i586" version="3.1.8" release="956"/>
+<install channel="3" kind="package" name="fam" arch="i586" version="2.7.0" release="36"/>
+<install channel="3" kind="package" name="libgnome" arch="i586" version="2.17.91" release="5"/>
+<install channel="3" kind="package" name="libgnomecanvas" arch="i586" version="2.14.0" release="41"/>
+<install channel="3" kind="package" name="libgnomecups" arch="i586" version="0.2.2" release="65"/>
+<install channel="3" kind="package" name="libgnomeprintui" arch="i586" version="2.12.1" release="64"/>
+<install channel="3" kind="package" name="libgnomeprint" arch="i586" version="2.17.91" release="3"/>
+<install channel="3" kind="package" name="libgnomesu" arch="i586" version="1.0.0" release="81"/>
+<install channel="3" kind="package" name="libgnomeui" arch="i586" version="2.17.91" release="4"/>
+<install channel="3" kind="package" name="libgpg-error" arch="i586" version="1.4" release="25"/>
+<install channel="3" kind="package" name="libgpod" arch="i586" version="0.4.2" release="8"/>
+<install channel="3" kind="package" name="libgphoto2" arch="i586" version="2.3.1.3.trunk" release="13"/>
+<install channel="3" kind="package" name="libgsf-gnome" arch="i586" version="1.14.2" release="40"/>
+<install channel="3" kind="package" name="libgsf" arch="i586" version="1.14.2" release="40"/>
+<install channel="3" kind="package" name="libgtkhtml" arch="i586" version="2.11.0" release="54"/>
+<install channel="3" kind="package" name="libgssapi" arch="i586" version="0.10" release="30"/>
+<install channel="3" kind="package" name="libical" arch="i586" version="0.24.RC4" release="92"/>
+<install channel="3" kind="package" name="libicu" arch="i586" version="3.4" release="41"/>
+<install channel="3" kind="package" name="libidl" arch="i586" version="0.8.7" release="33"/>
+<install channel="3" kind="package" name="libidn" arch="i586" version="0.6.8" release="18"/>
+<install channel="3" kind="package" name="libieee1284" arch="i586" version="0.2.10" release="51"/>
+<install channel="3" kind="package" name="libjasper" arch="i586" version="1.701.0" release="49"/>
+<install channel="3" kind="package" name="libjpeg" arch="i586" version="6.2.0" release="778"/>
+<install channel="3" kind="package" name="libkipi" arch="i586" version="0.1.5" release="16"/>
+<install channel="3" kind="package" name="libksba" arch="i586" version="1.0.0" release="25"/>
+<install channel="3" kind="package" name="liblazy" arch="i586" version="0.1.1" release="12"/>
+<install channel="3" kind="package" name="liblcms" arch="i586" version="1.16" release="5"/>
+<install channel="3" kind="package" name="libltdl" arch="i586" version="1.5.22" release="43"/>
+<install channel="3" kind="package" name="libmal" arch="i586" version="0.31" release="215"/>
+<install channel="3" kind="package" name="libmikmod" arch="i586" version="3.1.11" release="40"/>
+<install channel="3" kind="package" name="libmng" arch="i586" version="1.0.9" release="44"/>
+<install channel="3" kind="package" name="libmpcdec" arch="i586" version="1.2.2" release="27"/>
+<install channel="3" kind="package" name="libmtp" arch="i586" version="0.1.4" release="3"/>
+<install channel="3" kind="package" name="libmudflap41" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="libmusicbrainz" arch="i586" version="2.1.4" release="25"/>
+<install channel="3" kind="package" name="libnjb" arch="i586" version="2.2.5" release="39"/>
+<install channel="3" kind="package" name="libnetpbm" arch="i586" version="1.0.0" release="684"/>
+<install channel="3" kind="package" name="libnl" arch="i586" version="1.0" release="43"/>
+<install channel="3" kind="package" name="libnscd" arch="i586" version="2.0.2" release="9"/>
+<install channel="3" kind="package" name="libofa" arch="i586" version="0.9.3" release="21"/>
+<install channel="3" kind="package" name="libogg" arch="i586" version="1.1.3" release="39"/>
+<install channel="3" kind="package" name="liboil" arch="i586" version="0.3.9" release="27"/>
+<install channel="3" kind="package" name="libopensync" arch="i586" version="0.20" release="27"/>
+<install channel="3" kind="package" name="libopencdk" arch="i586" version="0.5.11" release="5"/>
+<install channel="3" kind="package" name="libopensync-plugin-file" arch="i586" version="0.20" release="23"/>
+<install channel="3" kind="package" name="libopensync-plugin-gnokii" arch="i586" version="0.20" release="25"/>
+<install channel="3" kind="package" name="libopensync-plugin-irmc" arch="i586" version="0.20" release="23"/>
+<install channel="3" kind="package" name="libopensync-plugin-gpe" arch="i586" version="0.20" release="22"/>
+<install channel="3" kind="package" name="libopensync-plugin-kdepim" arch="i586" version="0.20" release="31"/>
+<install channel="3" kind="package" name="libopensync-plugin-opie" arch="i586" version="0.20" release="22"/>
+<install channel="3" kind="package" name="libopensync-plugin-palm" arch="i586" version="0.20" release="27"/>
+<install channel="3" kind="package" name="libopensync-plugin-sunbird" arch="i586" version="0.20" release="22"/>
+<install channel="3" kind="package" name="libopensync-plugin-syncml" arch="i586" version="0.20" release="28"/>
+<install channel="3" kind="package" name="libopensync-tools" arch="i586" version="0.20" release="27"/>
+<install channel="3" kind="package" name="libpcap" arch="i586" version="0.9.5" release="8"/>
+<install channel="3" kind="package" name="libpng" arch="i586" version="1.2.12" release="30"/>
+<install channel="3" kind="package" name="libqt4" arch="i586" version="4.2.2" release="23"/>
+<install channel="3" kind="package" name="libqt4-dbus-1" arch="i586" version="4.2.2" release="23"/>
+<install channel="3" kind="package" name="libqt4-sql" arch="i586" version="4.2.2" release="23"/>
+<install channel="3" kind="package" name="libqt4-qt3support" arch="i586" version="4.2.2" release="23"/>
+<install channel="3" kind="package" name="libtiff" arch="i586" version="3.8.2" release="32"/>
+<install channel="3" kind="package" name="libqt4-x11" arch="i586" version="4.2.2" release="23"/>
+<install channel="3" kind="package" name="libqtpod" arch="i586" version="0.3" release="31"/>
+<install channel="3" kind="package" name="libreiserfs" arch="i586" version="0.3.0.5" release="42"/>
+<install channel="3" kind="package" name="librpcsecgss" arch="i586" version="0.14" release="30"/>
+<install channel="3" kind="package" name="librsvg" arch="i586" version="2.16.1" release="4"/>
+<install channel="3" kind="package" name="libsamplerate" arch="i586" version="0.1.2" release="41"/>
+<install channel="3" kind="package" name="libsmbclient" arch="i586" version="3.0.24" release="8"/>
+<install channel="3" kind="package" name="libsndfile" arch="i586" version="1.0.17" release="30"/>
+<install channel="3" kind="package" name="libsoup" arch="i586" version="2.2.100" release="3"/>
+<install channel="3" kind="package" name="libstdc++-devel" arch="i586" version="4.1.3" release="37"/>
+<install channel="3" kind="package" name="libstdc++41" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="libstdc++41-devel" arch="i586" version="4.1.3_20070218" release="3"/>
+<install channel="3" kind="package" name="libstroke" arch="i586" version="0.5.1" release="51"/>
+<install channel="3" kind="package" name="libsyncml" arch="i586" version="0.4.2" release="23"/>
+<install channel="3" kind="package" name="libtunepimp" arch="i586" version="0.5.2" release="25"/>
+<install channel="3" kind="package" name="libtool" arch="i586" version="1.5.22" release="43"/>
+<install channel="3" kind="package" name="libusb" arch="i586" version="0.1.12" release="34"/>
+<install channel="3" kind="package" name="libvisual" arch="i586" version="0.4.0" release="37"/>
+<install channel="3" kind="package" name="libvolume_id" arch="i586" version="106" release="3"/>
+<install channel="3" kind="package" name="libvorbis" arch="i586" version="1.1.2" release="39"/>
+<install channel="3" kind="package" name="libwmf" arch="i586" version="0.2.8.4" release="36"/>
+<install channel="3" kind="package" name="libwnck" arch="i586" version="2.17.91" release="3"/>
+<install channel="3" kind="package" name="libxcrypt" arch="i586" version="2.4" release="37"/>
+<install channel="3" kind="package" name="libxcrypt-devel" arch="i586" version="2.4" release="37"/>
+<install channel="3" kind="package" name="libxml2" arch="i586" version="2.6.27" release="13"/>
+<install channel="3" kind="package" name="libxml2-devel" arch="i586" version="2.6.27" release="13"/>
+<install channel="3" kind="package" name="liby2util-devel" arch="i586" version="2.14.0" release="21"/>
+<install channel="3" kind="package" name="libxslt" arch="i586" version="1.1.20" release="5"/>
+<install channel="3" kind="package" name="liby2util" arch="i586" version="2.14.0" release="21"/>
+<install channel="3" kind="package" name="libzio" arch="i586" version="0.4" release="7"/>
+<install channel="3" kind="package" name="libzypp" arch="i586" version="3.0.0" release="5"/>
+<install channel="3" kind="package" name="libzypp-zmd-backend" arch="i586" version="7.1.1.0_1.0" release="4"/>
+<install channel="3" kind="package" name="lilo" arch="i586" version="22.7" release="60"/>
+<install channel="3" kind="package" name="limal" arch="i586" version="1.2.9" release="19"/>
+<install channel="3" kind="package" name="limal-bootloader" arch="i586" version="1.2.4" release="21"/>
+<install channel="3" kind="package" name="limal-ca-mgm" arch="i586" version="1.2.9" release="18"/>
+<install channel="3" kind="package" name="limal-ca-mgm-perl" arch="i586" version="1.2.9" release="18"/>
+<install channel="3" kind="package" name="lsb" arch="i586" version="3.1" release="29"/>
+<install channel="3" kind="package" name="lsof" arch="i586" version="4.77" release="17"/>
+<install channel="3" kind="package" name="limal-perl" arch="i586" version="1.2.9" release="19"/>
+<install channel="3" kind="package" name="linux-kernel-headers" arch="i586" version="2.6.20" release="3"/>
+<install channel="3" kind="package" name="lirc" arch="i586" version="0.8.1" release="9"/>
+<install channel="3" kind="package" name="log4net" arch="noarch" version="1.2.9" release="53"/>
+<install channel="3" kind="package" name="logrotate" arch="i586" version="3.7.4" release="28"/>
+<install channel="3" kind="package" name="lukemftp" arch="i586" version="1.5" release="624"/>
+<install channel="3" kind="package" name="lua-libs" arch="i586" version="5.1.1" release="28"/>
+<install channel="3" kind="package" name="lvm2" arch="i586" version="2.02.17" release="13"/>
+<install channel="3" kind="package" name="lzo" arch="i586" version="2.02" release="40"/>
+<install channel="3" kind="package" name="m4" arch="i586" version="1.4.8" release="9"/>
+<install channel="3" kind="package" name="mailx" arch="i586" version="12.1" release="34"/>
+<install channel="3" kind="package" name="make" arch="i586" version="3.81" release="31"/>
+<install channel="3" kind="package" name="man" arch="i586" version="2.4.3" release="42"/>
+<install channel="3" kind="package" name="man-pages" arch="noarch" version="2.43" release="8"/>
+<install channel="3" kind="package" name="manufacturer-PPDs" arch="noarch" version="10.2" release="37"/>
+<install channel="3" kind="package" name="master-boot-code" arch="i586" version="1.6" release="42"/>
+<install channel="3" kind="package" name="mdadm" arch="i586" version="2.5.3" release="25"/>
+<install channel="3" kind="package" name="metacity" arch="i586" version="2.17.5" release="4"/>
+<install channel="3" kind="package" name="microcode_ctl" arch="i586" version="1.16" release="5"/>
+<install channel="3" kind="package" name="mingetty" arch="i586" version="0.9.6s" release="114"/>
+<install channel="3" kind="package" name="mkinitrd" arch="i586" version="1.2" release="159"/>
+<install channel="3" kind="package" name="mktemp" arch="i586" version="1.5" release="770"/>
+<install channel="3" kind="package" name="module-init-tools" arch="i586" version="3.2.2" release="77"/>
+<install channel="3" kind="package" name="mono-core" arch="i586" version="1.2.3.1" release="3"/>
+<install channel="3" kind="package" name="mono-data" arch="i586" version="1.2.3.1" release="3"/>
+<install channel="3" kind="package" name="mono-data-sqlite" arch="i586" version="1.2.3.1" release="3"/>
+<install channel="3" kind="package" name="mono-web" arch="i586" version="1.2.3.1" release="3"/>
+<install channel="3" kind="package" name="mozilla-nspr" arch="i586" version="4.6.5" release="3"/>
+<install channel="3" kind="package" name="mozilla-nss" arch="i586" version="3.11.5" release="3"/>
+<install channel="3" kind="package" name="mozilla-xulrunner181" arch="i586" version="1.8.0.99" release="45"/>
+<install channel="3" kind="package" name="multipath-tools" arch="i586" version="0.4.7" release="39"/>
+<install channel="3" kind="package" name="myspell-american" arch="noarch" version="20040623" release="54"/>
+<install channel="3" kind="package" name="myspell-german" arch="noarch" version="20060125" release="16"/>
+<install channel="3" kind="package" name="ncurses-devel" arch="i586" version="5.6" release="5"/>
+<install channel="3" kind="package" name="ncurses" arch="i586" version="5.6" release="5"/>
+<install channel="3" kind="package" name="neon" arch="i586" version="0.26.3" release="5"/>
+<install channel="3" kind="package" name="net-tools" arch="i586" version="1.60" release="613"/>
+<install channel="3" kind="package" name="net-snmp" arch="i586" version="5.4.rc2" release="20"/>
+<install channel="3" kind="package" name="netcfg" arch="noarch" version="10.3" release="5"/>
+<install channel="3" kind="package" name="netcat" arch="i586" version="1.10" release="909"/>
+<install channel="3" kind="package" name="netpbm" arch="i586" version="10.26.22" release="41"/>
+<install channel="3" kind="package" name="nfs-utils" arch="i586" version="1.0.12" release="3"/>
+<install channel="3" kind="package" name="nfsidmap" arch="i586" version="0.16" release="31"/>
+<install channel="3" kind="package" name="nscd" arch="i586" version="2.5" release="37"/>
+<install channel="3" kind="package" name="nss_ldap" arch="i586" version="255" release="3"/>
+<install channel="3" kind="package" name="ntfsprogs" arch="i586" version="1.13.1" release="13"/>
+<install channel="3" kind="package" name="numlockx" arch="i586" version="1.1" release="38"/>
+<install channel="3" kind="package" name="ocrad" arch="i586" version="0.16" release="17"/>
+<install channel="3" kind="package" name="openSUSE-release" arch="i586" version="10.3" release="9"/>
+<install channel="3" kind="package" name="openal" arch="i586" version="0.0.8" release="28"/>
+<install channel="3" kind="package" name="openct" arch="i586" version="0.6.9" release="28"/>
+<install channel="3" kind="package" name="openldap2-client" arch="i586" version="2.3.34" release="3"/>
+<install channel="3" kind="package" name="opensc" arch="i586" version="0.11.1" release="33"/>
+<install channel="3" kind="package" name="openobex" arch="i586" version="1.3" release="32"/>
+<install channel="3" kind="package" name="openmotif-libs" arch="i586" version="2.3.0beta2" release="48"/>
+<install channel="3" kind="package" name="openslp" arch="i586" version="1.2.0" release="59"/>
+<install channel="3" kind="package" name="openssh" arch="i586" version="4.5p1" release="20"/>
+<install channel="3" kind="package" name="opensuse-manual_de" arch="noarch" version="10.2" release="15"/>
+<install channel="3" kind="package" name="opensuse-quickstart_de" arch="noarch" version="10.2" release="13"/>
+<install channel="3" kind="package" name="openssh-askpass" arch="i586" version="4.5p1" release="20"/>
+<install channel="3" kind="package" name="openssl" arch="i586" version="0.9.8e" release="3"/>
+<install channel="3" kind="package" name="openssl-devel" arch="i586" version="0.9.8e" release="3"/>
+<install channel="3" kind="package" name="opensuse-manual_en" arch="noarch" version="10.2" release="36"/>
+<install channel="3" kind="package" name="opensuse-updater" arch="i586" version="0.4" release="51"/>
+<install channel="3" kind="package" name="opensuse-quickstart_en" arch="noarch" version="10.2" release="17"/>
+<install channel="3" kind="package" name="orbit2" arch="i586" version="2.14.6" release="3"/>
+<install channel="3" kind="package" name="pam" arch="i586" version="0.99.7.1" release="6"/>
+<install channel="3" kind="package" name="pam-modules" arch="i586" version="10.3" release="9"/>
+<install channel="3" kind="package" name="pam-config" arch="i586" version="0.15" release="5"/>
+<install channel="3" kind="package" name="pam_ldap" arch="i586" version="184" release="3"/>
+<install channel="3" kind="package" name="pango" arch="i586" version="1.15.6" release="3"/>
+<install channel="3" kind="package" name="parted" arch="i586" version="1.8.2" release="8"/>
+<install channel="3" kind="package" name="patch" arch="i586" version="2.5.9" release="185"/>
+<install channel="3" kind="package" name="pax" arch="i586" version="3.4" release="39"/>
+<install channel="3" kind="package" name="pciutils" arch="i586" version="2.2.4" release="22"/>
+<install channel="3" kind="package" name="pciutils-ids" arch="noarch" version="2007.3.10" release="3"/>
+<install channel="3" kind="package" name="pcre" arch="i586" version="7.0" release="8"/>
+<install channel="3" kind="package" name="pcre-devel" arch="i586" version="7.0" release="8"/>
+<install channel="3" kind="package" name="pcsc-lite" arch="i586" version="1.3.3" release="4"/>
+<install channel="3" kind="package" name="perl" arch="i586" version="5.8.8" release="41"/>
+<install channel="3" kind="package" name="perl-Bit-Vector" arch="i586" version="6.4" release="38"/>
+<install channel="3" kind="package" name="perl-Bootloader" arch="i586" version="0.4.11" release="4"/>
+<install channel="3" kind="package" name="perl-Carp-Clan" arch="i586" version="5.8" release="8"/>
+<install channel="3" kind="package" name="perl-Compress-Zlib" arch="i586" version="2.004" release="3"/>
+<install channel="3" kind="package" name="perl-Config-Crontab" arch="i586" version="1.20" release="17"/>
+<install channel="3" kind="package" name="perl-Config-IniFiles" arch="i586" version="2.39" release="38"/>
+<install channel="3" kind="package" name="perl-Crypt-SSLeay" arch="i586" version="0.51" release="155"/>
+<install channel="3" kind="package" name="perl-Crypt-SmbHash" arch="i586" version="0.12" release="38"/>
+<install channel="3" kind="package" name="perl-DBD-SQLite" arch="i586" version="1.13" release="29"/>
+<install channel="3" kind="package" name="perl-DBI" arch="i586" version="1.54" release="4"/>
+<install channel="3" kind="package" name="perl-Date-Calc" arch="i586" version="5.4" release="39"/>
+<install channel="3" kind="package" name="perl-Digest-HMAC" arch="i586" version="1.01" release="532"/>
+<install channel="3" kind="package" name="perl-Digest-MD4" arch="i586" version="1.5" release="38"/>
+<install channel="3" kind="package" name="perl-Digest-SHA1" arch="i586" version="2.11" release="27"/>
+<install channel="3" kind="package" name="perl-File-Tail" arch="i586" version="0.99.3" release="37"/>
+<install channel="3" kind="package" name="perl-HTML-Parser" arch="i586" version="3.56" release="5"/>
+<install channel="3" kind="package" name="perl-HTML-Tagset" arch="i586" version="3.10" release="37"/>
+<install channel="3" kind="package" name="perl-IO-Zlib" arch="i586" version="1.05" release="3"/>
+<install channel="3" kind="package" name="perl-Net-DNS" arch="i586" version="0.59" release="23"/>
+<install channel="3" kind="package" name="perl-Net-Daemon" arch="i586" version="0.39" release="15"/>
+<install channel="3" kind="package" name="perl-Net-IP" arch="i586" version="1.23" release="39"/>
+<install channel="3" kind="package" name="perl-URI" arch="i586" version="1.35" release="40"/>
+<install channel="3" kind="package" name="perl-Parse-RecDescent" arch="i586" version="1.80" release="284"/>
+<install channel="3" kind="package" name="perl-PlRPC" arch="i586" version="0.2018" release="38"/>
+<install channel="3" kind="package" name="perl-TermReadKey" arch="i586" version="2.30" release="38"/>
+<install channel="3" kind="package" name="perl-TermReadLine-Gnu" arch="i586" version="1.16" release="5"/>
+<install channel="3" kind="package" name="perl-TimeDate" arch="i586" version="1.16" release="161"/>
+<install channel="3" kind="package" name="perl-X500-DN" arch="i586" version="0.28" release="158"/>
+<install channel="3" kind="package" name="perl-XML-Parser" arch="i586" version="2.34" release="68"/>
+<install channel="3" kind="package" name="perl-XML-Writer" arch="i586" version="0.602" release="8"/>
+<install channel="3" kind="package" name="perl-gettext" arch="i586" version="1.05" release="38"/>
+<install channel="3" kind="package" name="perl-libwww-perl" arch="i586" version="5.805" release="40"/>
+<install channel="3" kind="package" name="phalanx" arch="i586" version="22" release="549"/>
+<install channel="3" kind="package" name="perl-spamassassin" arch="i586" version="3.1.8" release="4"/>
+<install channel="3" kind="package" name="permissions" arch="i586" version="2007.2.25" release="3"/>
+<install channel="3" kind="package" name="pmtools" arch="i586" version="20061026" release="10"/>
+<install channel="3" kind="package" name="pilot-link" arch="i586" version="0.12.1" release="35"/>
+<install channel="3" kind="package" name="pinentry" arch="i586" version="0.7.2" release="61"/>
+<install channel="3" kind="package" name="pkg-config" arch="i586" version="0.21" release="4"/>
+<install channel="3" kind="package" name="pm-utils" arch="i586" version="0.20.0.20070202" release="4"/>
+<install channel="3" kind="package" name="poppler-qt" arch="i586" version="0.5.4" release="42"/>
+<install channel="3" kind="package" name="poppler" arch="i586" version="0.5.4" release="42"/>
+<install channel="3" kind="package" name="popt" arch="i586" version="1.7" release="314"/>
+<install channel="3" kind="package" name="portmap" arch="i586" version="5beta" release="777"/>
+<install channel="3" kind="package" name="postfix" arch="i586" version="2.3.2" release="41"/>
+<install channel="3" kind="package" name="powersave-libs" arch="i586" version="0.15.10" release="19"/>
+<install channel="3" kind="package" name="preload" arch="i586" version="0.2" release="54"/>
+<install channel="3" kind="package" name="ppp" arch="i586" version="2.4.4" release="32"/>
+<install channel="3" kind="package" name="pptp" arch="i586" version="1.7.1" release="17"/>
+<install channel="3" kind="package" name="python-qt" arch="i586" version="3.5.6" release="9"/>
+<install channel="3" kind="package" name="procinfo" arch="i586" version="18" release="87"/>
+<install channel="3" kind="package" name="procmail" arch="i586" version="3.22" release="89"/>
+<install channel="3" kind="package" name="procps" arch="i586" version="3.2.7" release="30"/>
+<install channel="3" kind="package" name="providers" arch="noarch" version="2006.11.21" release="10"/>
+<install channel="3" kind="package" name="psmisc" arch="i586" version="22.3" release="24"/>
+<install channel="3" kind="package" name="pwdutils" arch="i586" version="3.1.3" release="12"/>
+<install channel="3" kind="package" name="python" arch="i586" version="2.5" release="34"/>
+<install channel="3" kind="package" name="python-xml" arch="i586" version="2.5" release="34"/>
+<install channel="3" kind="package" name="qca" arch="i586" version="1.0" release="60"/>
+<install channel="3" kind="package" name="qlogic-firmware" arch="noarch" version="1.0" release="49"/>
+<install channel="3" kind="package" name="qscintilla" arch="i586" version="1.65" release="55"/>
+<install channel="3" kind="package" name="qt3" arch="i586" version="3.3.8" release="4"/>
+<install channel="3" kind="package" name="qtcurve-gtk2" arch="i586" version="0.47" release="3"/>
+<install channel="3" kind="package" name="rug" arch="i586" version="7.1.100.0" release="54"/>
+<install channel="3" kind="package" name="rdesktop" arch="i586" version="1.5.0" release="34"/>
+<install channel="3" kind="package" name="readline" arch="i586" version="5.2" release="14"/>
+<install channel="3" kind="package" name="readline-devel" arch="i586" version="5.2" release="14"/>
+<install channel="3" kind="package" name="recode" arch="i586" version="3.6" release="529"/>
+<install channel="3" kind="package" name="reiserfs" arch="i586" version="3.6.19" release="46"/>
+<install channel="3" kind="package" name="release-notes" arch="noarch" version="10.3.0" release="8"/>
+<install channel="3" kind="package" name="resmgr" arch="i586" version="1.1.0_SVNr130" release="5"/>
+<install channel="3" kind="package" name="rpm" arch="i586" version="4.4.2" release="86"/>
+<install channel="3" kind="package" name="rrdtool" arch="i586" version="1.2.18" release="6"/>
+<install channel="3" kind="package" name="rsh" arch="i586" version="0.17" release="601"/>
+<install channel="3" kind="package" name="rsync" arch="i586" version="2.6.8" release="42"/>
+<install channel="3" kind="package" name="ruby" arch="i586" version="1.8.5.pl12" release="3"/>
+<install channel="3" kind="package" name="sax2-tools" arch="i586" version="8.1" release="115"/>
+<install channel="3" kind="package" name="sane-frontends" arch="i586" version="1.0.14" release="64"/>
+<install channel="3" kind="package" name="sax2-gui" arch="i586" version="8.1" release="115"/>
+<install channel="3" kind="package" name="sash" arch="i586" version="3.7" release="71"/>
+<install channel="3" kind="package" name="sane-backends" arch="i586" version="1.0.18" release="9"/>
+<install channel="3" kind="package" name="sax2" arch="i586" version="8.1" release="115"/>
+<install channel="3" kind="package" name="sax2-ident" arch="i586" version="8.1" release="115"/>
+<install channel="3" kind="package" name="sax2-libsax" arch="i586" version="8.1" release="115"/>
+<install channel="3" kind="package" name="sax2-libsax-perl" arch="i586" version="8.1" release="115"/>
+<install channel="3" kind="package" name="scpm" arch="i586" version="1.1.5" release="38"/>
+<install channel="3" kind="package" name="screen" arch="i586" version="4.0.2" release="91"/>
+<install channel="3" kind="package" name="scsi" arch="i586" version="1.7_2.36_1.22_0.18_0.99_0.91" release="36"/>
+<install channel="3" kind="package" name="sed" arch="i586" version="4.1.5" release="30"/>
+<install channel="3" kind="package" name="sensors" arch="i586" version="2.10.2" release="7"/>
+<install channel="3" kind="package" name="sgml-skel" arch="noarch" version="0.6" release="309"/>
+<install channel="3" kind="package" name="shared-mime-info" arch="i586" version="0.20" release="3"/>
+<install channel="3" kind="package" name="sharutils" arch="i586" version="4.6.2" release="32"/>
+<install channel="3" kind="package" name="siga" arch="noarch" version="10.101" release="39"/>
+<install channel="3" kind="package" name="sisctrl" arch="i586" version="0.0.20051202" release="49"/>
+<install channel="3" kind="package" name="slang" arch="i586" version="2.0.5" release="39"/>
+<install channel="3" kind="package" name="smartmontools" arch="i586" version="5.36.cvs20061025" release="15"/>
+<install channel="3" kind="package" name="smartlink-softmodem" arch="i586" version="2.9.10" release="91"/>
+<install channel="3" kind="package" name="smpppd" arch="i586" version="1.59" release="46"/>
+<install channel="3" kind="package" name="spamassassin" arch="i586" version="3.1.8" release="4"/>
+<install channel="3" kind="package" name="speex" arch="i586" version="1.1.99.1" release="21"/>
+<install channel="3" kind="package" name="sqlite" arch="i586" version="3.3.13" release="3"/>
+<install channel="3" kind="package" name="sqlite-zmd" arch="i586" version="3.2.8" release="14"/>
+<install channel="3" kind="package" name="sqlite2" arch="i586" version="2.8.17" release="42"/>
+<install channel="3" kind="package" name="src_vipa" arch="i586" version="2.0.3" release="40"/>
+<install channel="3" kind="package" name="startup-notification" arch="i586" version="0.8" release="52"/>
+<install channel="3" kind="package" name="strace" arch="i586" version="4.5.15" release="5"/>
+<install channel="3" kind="package" name="subversion-tools" arch="i586" version="1.4.3" release="4"/>
+<install channel="3" kind="package" name="sudo" arch="i586" version="1.6.8p12" release="52"/>
+<install channel="3" kind="package" name="supertux" arch="i586" version="0.3.0" release="11"/>
+<install channel="3" kind="package" name="suse-build-key" arch="noarch" version="1.0" release="716"/>
+<install channel="3" kind="package" name="suseRegister" arch="noarch" version="1.2" release="29"/>
+<install channel="3" kind="package" name="susehelp" arch="noarch" version="2006.06.20" release="37"/>
+<install channel="3" kind="package" name="susehelp_de" arch="noarch" version="2006.06.20" release="37"/>
+<install channel="3" kind="package" name="suspend" arch="i586" version="0.50.20070213" release="4"/>
+<install channel="3" kind="package" name="sysconfig" arch="i586" version="0.60.6" release="8"/>
+<install channel="3" kind="package" name="swig" arch="i586" version="1.3.29" release="43"/>
+<install channel="3" kind="package" name="syslinux" arch="i586" version="3.31" release="24"/>
+<install channel="3" kind="package" name="sysfsutils" arch="i586" version="2.1.0" release="27"/>
+<install channel="3" kind="package" name="syslog-ng" arch="i586" version="1.6.11" release="33"/>
+<install channel="3" kind="package" name="sysvinit" arch="i586" version="2.86" release="57"/>
+<install channel="3" kind="package" name="taglib" arch="i586" version="1.4" release="61"/>
+<install channel="3" kind="package" name="tar" arch="i586" version="1.16.1" release="5"/>
+<install channel="3" kind="package" name="tcl" arch="i586" version="8.4.14" release="18"/>
+<install channel="3" kind="package" name="tcsh" arch="i586" version="6.14.00" release="51"/>
+<install channel="3" kind="package" name="tcpd" arch="i586" version="7.6" release="757"/>
+<install channel="3" kind="package" name="tcpdump" arch="i586" version="3.9.5" release="8"/>
+<install channel="3" kind="package" name="telnet" arch="i586" version="1.2" release="42"/>
+<install channel="3" kind="package" name="terminfo" arch="i586" version="5.6" release="5"/>
+<install channel="3" kind="package" name="testgart" arch="i586" version="0.1" release="228"/>
+<install channel="3" kind="package" name="tightvnc" arch="i586" version="1.3.8" release="6"/>
+<install channel="3" kind="package" name="timezone" arch="i586" version="2.5" release="37"/>
+<install channel="3" kind="package" name="tix" arch="i586" version="8.1.4" release="125"/>
+<install channel="3" kind="package" name="tk" arch="i586" version="8.4.14" release="23"/>
+<install channel="3" kind="package" name="tree" arch="i586" version="1.5.0" release="38"/>
+<install channel="3" kind="package" name="udev" arch="i586" version="106" release="3"/>
+<install channel="3" kind="package" name="ufraw" arch="i586" version="0.11" release="3"/>
+<install channel="3" kind="package" name="ufraw-gimp" arch="i586" version="0.11" release="3"/>
+<install channel="3" kind="package" name="ulimit" arch="noarch" version="1.1" release="172"/>
+<install channel="3" kind="package" name="unclutter" arch="i586" version="8" release="888"/>
+<install channel="3" kind="package" name="unzip" arch="i586" version="5.52" release="41"/>
+<install channel="3" kind="package" name="update-alternatives" arch="noarch" version="1.8.3" release="41"/>
+<install channel="3" kind="package" name="usbutils" arch="i586" version="0.72" release="27"/>
+<install channel="3" kind="package" name="utempter" arch="i586" version="0.5.5" release="42"/>
+<install channel="3" kind="package" name="util-linux" arch="i586" version="2.12r" release="81"/>
+<install channel="3" kind="package" name="v4l-conf" arch="i586" version="3.95" release="40"/>
+<install channel="3" kind="package" name="vim" arch="i586" version="7.0" release="55"/>
+<install channel="3" kind="package" name="w3m" arch="i586" version="0.5.1" release="57"/>
+<install channel="3" kind="package" name="wdiff" arch="i586" version="0.5.2" release="699"/>
+<install channel="3" kind="package" name="wbxml2" arch="i586" version="0.9.2_SVN39" release="5"/>
+<install channel="3" kind="package" name="wget" arch="i586" version="1.10.2" release="43"/>
+<install channel="3" kind="package" name="whois" arch="i586" version="4.7.20" release="5"/>
+<install channel="3" kind="package" name="wireless-tools" arch="i586" version="29pre10" release="30"/>
+<install channel="3" kind="package" name="x11-input-wacom" arch="i586" version="0.7.7" release="3"/>
+<install channel="3" kind="package" name="x11-tools" arch="i586" version="0.1" release="64"/>
+<install channel="3" kind="package" name="wodim" arch="i586" version="1.1.2" release="6"/>
+<install channel="3" kind="package" name="words" arch="noarch" version="6" release="44"/>
+<install channel="3" kind="package" name="wpa_supplicant" arch="i586" version="0.5.7" release="3"/>
+<install channel="3" kind="package" name="wv" arch="i586" version="1.2.2" release="7"/>
+<install channel="3" kind="package" name="wvdial" arch="i586" version="1.54" release="112"/>
+<install channel="3" kind="package" name="wvstreams" arch="i586" version="4.2.2" release="20"/>
+<install channel="3" kind="package" name="x11-input-synaptics" arch="i586" version="0.14.6" release="43"/>
+<install channel="3" kind="package" name="xaw3d" arch="i586" version="1.5E" release="276"/>
+<install channel="3" kind="package" name="xdelta" arch="i586" version="1.1.4" release="4"/>
+<install channel="3" kind="package" name="xdg-menu" arch="i586" version="0.2" release="93"/>
+<install channel="3" kind="package" name="xdg-utils" arch="noarch" version="1.0.1" release="23"/>
+<install channel="3" kind="package" name="xdmbgrd" arch="i586" version="0.6" release="35"/>
+<install channel="3" kind="package" name="xen" arch="i586" version="3.0.4_13138" release="9"/>
+<install channel="3" kind="package" name="xen-doc-html" arch="i586" version="3.0.4_13138" release="9"/>
+<install channel="3" kind="package" name="xen-doc-pdf" arch="i586" version="3.0.4_13138" release="9"/>
+<install channel="3" kind="package" name="xen-doc-ps" arch="i586" version="3.0.4_13138" release="9"/>
+<install channel="3" kind="package" name="xen-libs" arch="i586" version="3.0.4_13138" release="9"/>
+<install channel="3" kind="package" name="xen-tools-ioemu" arch="i586" version="3.0.4_13138" release="9"/>
+<install channel="3" kind="package" name="xen-tools" arch="i586" version="3.0.4_13138" release="9"/>
+<install channel="3" kind="package" name="xgl" arch="i586" version="git_070104" release="12"/>
+<install channel="3" kind="package" name="xfsprogs" arch="i586" version="2.8.11_1" release="20"/>
+<install channel="3" kind="package" name="xine-lib" arch="i586" version="1.1.4" release="8"/>
+<install channel="3" kind="package" name="xgl-hardware-list" arch="noarch" version="060526" release="44"/>
+<install channel="3" kind="package" name="xinetd" arch="i586" version="2.3.14" release="40"/>
+<install channel="3" kind="package" name="xkeyboard-config" arch="noarch" version="0.9" release="39"/>
+<install channel="3" kind="package" name="xli" arch="i586" version="20050904" release="51"/>
+<install channel="3" kind="package" name="xlockmore" arch="i586" version="5.23" release="24"/>
+<install channel="3" kind="package" name="xmlcharent" arch="noarch" version="0.3" release="298"/>
+<install channel="3" kind="package" name="xmoto" arch="i586" version="0.2.4" release="10"/>
+<install channel="3" kind="package" name="xmset" arch="i586" version="1.2" release="60"/>
+<install channel="3" kind="package" name="xntp" arch="i586" version="4.2.4" release="4"/>
+<install channel="3" kind="package" name="xorg-x11" arch="i586" version="7.2" release="55"/>
+<install channel="3" kind="package" name="xorg-x11-driver-input" arch="i586" version="7.2" release="40"/>
+<install channel="3" kind="package" name="xorg-x11-Xvnc" arch="i586" version="7.1" release="41"/>
+<install channel="3" kind="package" name="xorg-x11-driver-video" arch="i586" version="7.2" release="63"/>
+<install channel="3" kind="package" name="xorg-x11-fonts-core" arch="noarch" version="7.2" release="29"/>
+<install channel="3" kind="package" name="xorg-x11-libICE" arch="i586" version="7.2" release="24"/>
+<install channel="3" kind="package" name="xorg-x11-fonts" arch="noarch" version="7.2" release="29"/>
+<install channel="3" kind="package" name="xorg-x11-libSM" arch="i586" version="7.2" release="22"/>
+<install channel="3" kind="package" name="xorg-x11-libX11" arch="i586" version="7.2" release="30"/>
+<install channel="3" kind="package" name="xorg-x11-libX11-ccache" arch="i586" version="7.2" release="28"/>
+<install channel="3" kind="package" name="xorg-x11-libXau" arch="i586" version="7.2" release="18"/>
+<install channel="3" kind="package" name="xorg-x11-libXdmcp" arch="i586" version="7.2" release="17"/>
+<install channel="3" kind="package" name="xorg-x11-libXfixes" arch="i586" version="7.2" release="25"/>
+<install channel="3" kind="package" name="xorg-x11-libXext" arch="i586" version="7.2" release="25"/>
+<install channel="3" kind="package" name="xorg-x11-libXmu" arch="i586" version="7.2" release="25"/>
+<install channel="3" kind="package" name="xorg-x11-libXp" arch="i586" version="7.2" release="20"/>
+<install channel="3" kind="package" name="xorg-x11-libXpm" arch="i586" version="7.2" release="24"/>
+<install channel="3" kind="package" name="xorg-x11-libXprintUtil" arch="i586" version="7.2" release="20"/>
+<install channel="3" kind="package" name="xorg-x11-libXrender" arch="i586" version="7.2" release="24"/>
+<install channel="3" kind="package" name="xorg-x11-libXt" arch="i586" version="7.2" release="26"/>
+<install channel="3" kind="package" name="xorg-x11-libXv" arch="i586" version="7.2" release="21"/>
+<install channel="3" kind="package" name="xorg-x11-libfontenc" arch="i586" version="7.2" release="22"/>
+<install channel="3" kind="package" name="xorg-x11-libs" arch="i586" version="7.2" release="46"/>
+<install channel="3" kind="package" name="xorg-x11-libxkbfile" arch="i586" version="7.2" release="24"/>
+<install channel="3" kind="package" name="xorg-x11-server" arch="i586" version="7.2" release="59"/>
+<install channel="3" kind="package" name="xpdf-tools" arch="i586" version="3.01" release="64"/>
+<install channel="3" kind="package" name="yast2-dns-server" arch="noarch" version="2.15.2" release="4"/>
+<install channel="3" kind="package" name="xscreensaver" arch="i586" version="5.01" release="31"/>
+<install channel="3" kind="package" name="xterm" arch="i586" version="224" release="7"/>
+<install channel="3" kind="package" name="xtermset" arch="i586" version="0.5.2" release="160"/>
+<install channel="3" kind="package" name="yast2-autofs" arch="noarch" version="2.15.0" release="7"/>
+<install channel="3" kind="package" name="yast2-firewall" arch="noarch" version="2.15.3" release="3"/>
+<install channel="3" kind="package" name="yast2-apparmor" arch="noarch" version="2.0.1" release="28"/>
+<install channel="3" kind="package" name="yast2" arch="i586" version="2.15.19" release="3"/>
+<install channel="3" kind="package" name="yast2-backup" arch="noarch" version="2.15.2" release="3"/>
+<install channel="3" kind="package" name="yast2-ca-management" arch="noarch" version="2.14.3" release="47"/>
+<install channel="3" kind="package" name="yast2-bootloader" arch="i586" version="2.15.7" release="3"/>
+<install channel="3" kind="package" name="yast2-bluetooth" arch="noarch" version="2.15.1" release="3"/>
+<install channel="3" kind="package" name="yast2-control-center" arch="i586" version="2.14.4" release="3"/>
+<install channel="3" kind="package" name="yast2-dhcp-server" arch="noarch" version="2.15.1" release="9"/>
+<install channel="3" kind="package" name="yast2-devtools" arch="noarch" version="2.14.0" release="14"/>
+<install channel="3" kind="package" name="yast2-core" arch="i586" version="2.15.4" release="3"/>
+<install channel="3" kind="package" name="yast2-core-devel" arch="i586" version="2.15.4" release="3"/>
+<install channel="3" kind="package" name="yast2-country" arch="i586" version="2.15.9" release="3"/>
+<install channel="3" kind="package" name="yast2-installation" arch="noarch" version="2.15.15" release="3"/>
+<install channel="3" kind="package" name="yast2-firstboot" arch="noarch" version="2.15.1" release="3"/>
+<install channel="3" kind="package" name="yast2-hardware-detection" arch="i586" version="2.15.3" release="3"/>
+<install channel="3" kind="package" name="yast2-inetd" arch="noarch" version="2.14.1" release="45"/>
+<install channel="3" kind="package" name="yast2-http-server" arch="noarch" version="2.14.9" release="3"/>
+<install channel="3" kind="package" name="yast2-irda" arch="noarch" version="2.15.1" release="14"/>
+<install channel="3" kind="package" name="yast2-instserver" arch="noarch" version="2.15.2" release="4"/>
+<install channel="3" kind="package" name="yast2-iscsi-client" arch="noarch" version="2.14.8" release="3"/>
+<install channel="3" kind="package" name="yast2-ldap-server" arch="noarch" version="2.15.3" release="3"/>
+<install channel="3" kind="package" name="yast2-kerberos-client" arch="noarch" version="2.15.4" release="3"/>
+<install channel="3" kind="package" name="yast2-ldap" arch="i586" version="2.15.1" release="3"/>
+<install channel="3" kind="package" name="yast2-ldap-client" arch="noarch" version="2.15.6" release="3"/>
+<install channel="3" kind="package" name="yast2-mail" arch="noarch" version="2.15.2" release="3"/>
+<install channel="3" kind="package" name="yast2-mouse" arch="i586" version="2.14.1" release="25"/>
+<install channel="3" kind="package" name="yast2-mail-aliases" arch="noarch" version="2.15.2" release="3"/>
+<install channel="3" kind="package" name="yast2-ncurses" arch="i586" version="2.15.12" release="3"/>
+<install channel="3" kind="package" name="yast2-network" arch="i586" version="2.15.16" release="3"/>
+<install channel="3" kind="package" name="yast2-nfs-client" arch="noarch" version="2.14.0" release="21"/>
+<install channel="3" kind="package" name="yast2-nis-client" arch="i586" version="2.15.1" release="3"/>
+<install channel="3" kind="package" name="yast2-nfs-server" arch="noarch" version="2.15.1" release="4"/>
+<install channel="3" kind="package" name="yast2-nis-server" arch="noarch" version="2.14.1" release="35"/>
+<install channel="3" kind="package" name="yast2-ntp-client" arch="noarch" version="2.15.1" release="7"/>
+<install channel="3" kind="package" name="yast2-online-update" arch="noarch" version="2.15.8" release="3"/>
+<install channel="3" kind="package" name="yast2-packager" arch="i586" version="2.15.22" release="3"/>
+<install channel="3" kind="package" name="yast2-online-update-frontend" arch="noarch" version="2.15.8" release="3"/>
+<install channel="3" kind="package" name="yast2-pam" arch="noarch" version="2.14.0" release="48"/>
+<install channel="3" kind="package" name="yast2-perl-bindings" arch="i586" version="2.14.0" release="26"/>
+<install channel="3" kind="package" name="yast2-phone-services" arch="noarch" version="2.14.0" release="27"/>
+<install channel="3" kind="package" name="yast2-pkg-bindings" arch="i586" version="2.15.12" release="4"/>
+<install channel="3" kind="package" name="yast2-power-management" arch="i586" version="2.14.3" release="24"/>
+<install channel="3" kind="package" name="yast2-powertweak" arch="noarch" version="2.15.1" release="3"/>
+<install channel="3" kind="package" name="yast2-printer" arch="i586" version="2.14.22" release="4"/>
+<install channel="3" kind="package" name="yast2-profile-manager" arch="i586" version="2.14.1" release="34"/>
+<install channel="3" kind="package" name="yast2-trans-es" arch="noarch" version="2.14.4" release="13"/>
+<install channel="3" kind="package" name="yast2-qt" arch="i586" version="2.15.2" release="3"/>
+<install channel="3" kind="package" name="yast2-registration" arch="noarch" version="2.14.2" release="25"/>
+<install channel="3" kind="package" name="yast2-repair" arch="noarch" version="2.15.3" release="3"/>
+<install channel="3" kind="package" name="yast2-restore" arch="noarch" version="2.15.1" release="3"/>
+<install channel="3" kind="package" name="yast2-runlevel" arch="noarch" version="2.15.0" release="7"/>
+<install channel="3" kind="package" name="yast2-samba-client" arch="noarch" version="2.15.3" release="3"/>
+<install channel="3" kind="package" name="yast2-samba-server" arch="noarch" version="2.15.3" release="3"/>
+<install channel="3" kind="package" name="yast2-scanner" arch="noarch" version="2.15.0" release="7"/>
+<install channel="3" kind="package" name="yast2-schema" arch="noarch" version="2.14.2" release="10"/>
+<install channel="3" kind="package" name="yast2-security" arch="noarch" version="2.15.0" release="7"/>
+<install channel="3" kind="package" name="yast2-slp" arch="i586" version="2.14.1" release="22"/>
+<install channel="3" kind="package" name="yast2-sound" arch="i586" version="2.15.4" release="4"/>
+<install channel="3" kind="package" name="yast2-storage" arch="i586" version="2.15.5" release="4"/>
+<install channel="3" kind="package" name="yast2-trans-bg" arch="noarch" version="2.14.8" release="13"/>
+<install channel="3" kind="package" name="yast2-storage-evms" arch="i586" version="2.15.5" release="4"/>
+<install channel="3" kind="package" name="yast2-storage-lib" arch="i586" version="2.15.5" release="4"/>
+<install channel="3" kind="package" name="yast2-sudo" arch="noarch" version="2.15.2" release="3"/>
+<install channel="3" kind="package" name="yast2-support" arch="noarch" version="2.15.0" release="7"/>
+<install channel="3" kind="package" name="yast2-sysconfig" arch="noarch" version="2.15.1" release="3"/>
+<install channel="3" kind="package" name="yast2-testsuite" arch="noarch" version="2.14.0" release="16"/>
+<install channel="3" kind="package" name="yast2-tftp-server" arch="noarch" version="2.14.0" release="25"/>
+<install channel="3" kind="package" name="yast2-theme-openSUSE" arch="noarch" version="2.15.2" release="4"/>
+<install channel="3" kind="package" name="yast2-trans-ar" arch="noarch" version="2.14.5" release="15"/>
+<install channel="3" kind="package" name="yast2-trans-bn" arch="noarch" version="2.13.3" release="39"/>
+<install channel="3" kind="package" name="yast2-trans-ca" arch="noarch" version="2.14.2" release="15"/>
+<install channel="3" kind="package" name="yast2-trans-bs" arch="noarch" version="2.13.3" release="39"/>
+<install channel="3" kind="package" name="yast2-trans-cs" arch="noarch" version="2.14.21" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-cy" arch="noarch" version="2.14.1" release="30"/>
+<install channel="3" kind="package" name="yast2-trans-de" arch="noarch" version="2.14.18" release="5"/>
+<install channel="3" kind="package" name="yast2-trans-da" arch="noarch" version="2.14.17" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-el" arch="noarch" version="2.14.7" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-en_GB" arch="noarch" version="2.14.2" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-en_US" arch="noarch" version="2.14.1" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-et" arch="noarch" version="2.14.12" release="5"/>
+<install channel="3" kind="package" name="yast2-trans-fr" arch="noarch" version="2.14.4" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-fi" arch="noarch" version="2.14.21" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-it" arch="noarch" version="2.14.6" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-he" arch="noarch" version="2.13.2" release="39"/>
+<install channel="3" kind="package" name="yast2-trans-hi" arch="noarch" version="2.13.5" release="34"/>
+<install channel="3" kind="package" name="yast2-trans-hr" arch="noarch" version="2.14.3" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-hu" arch="noarch" version="2.14.23" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-ja" arch="noarch" version="2.14.6" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-mk" arch="noarch" version="2.13.4" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-km" arch="noarch" version="2.14.14" release="5"/>
+<install channel="3" kind="package" name="yast2-trans-ko" arch="noarch" version="2.14.2" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-lt" arch="noarch" version="2.14.14" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-pa" arch="noarch" version="2.14.4" release="15"/>
+<install channel="3" kind="package" name="yast2-trans-pt_BR" arch="noarch" version="2.14.5" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-nb" arch="noarch" version="2.14.5" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-nl" arch="noarch" version="2.14.15" release="5"/>
+<install channel="3" kind="package" name="yast2-trans-pl" arch="noarch" version="2.14.11" release="5"/>
+<install channel="3" kind="package" name="yast2-trans-pt" arch="noarch" version="2.14.8" release="5"/>
+<install channel="3" kind="package" name="yast2-trans-sr" arch="noarch" version="2.14.2" release="25"/>
+<install channel="3" kind="package" name="yast2-trans-ro" arch="noarch" version="2.14.3" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-sl" arch="noarch" version="2.14.5" release="15"/>
+<install channel="3" kind="package" name="yast2-trans-ru" arch="noarch" version="2.14.20" release="3"/>
+<install channel="3" kind="package" name="yast2-trans-sk" arch="noarch" version="2.14.4" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-stats" arch="noarch" version="2.11.0" release="82"/>
+<install channel="3" kind="package" name="yast2-trans-sv" arch="noarch" version="2.14.8" release="15"/>
+<install channel="3" kind="package" name="yast2-trans-uk" arch="noarch" version="2.14.11" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-tr" arch="noarch" version="2.14.8" release="13"/>
+<install channel="3" kind="package" name="yast2-trans-vi" arch="noarch" version="2.14.6" release="16"/>
+<install channel="3" kind="package" name="yast2-trans-zh_CN" arch="noarch" version="2.14.4" release="5"/>
+<install channel="3" kind="package" name="yast2-transfer" arch="i586" version="2.14.0" release="27"/>
+<install channel="3" kind="package" name="yast2-trans-zh_TW" arch="noarch" version="2.14.7" release="5"/>
+<install channel="3" kind="package" name="yast2-tune" arch="i586" version="2.15.1" release="9"/>
+<install channel="3" kind="package" name="yast2-update" arch="i586" version="2.15.5" release="3"/>
+<install channel="3" kind="package" name="yast2-tv" arch="noarch" version="2.15.3" release="5"/>
+<install channel="3" kind="package" name="yast2-users" arch="i586" version="2.15.17" release="3"/>
+<install channel="3" kind="package" name="yast2-x11" arch="noarch" version="2.15.5" release="3"/>
+<install channel="3" kind="package" name="yast2-vm" arch="i586" version="2.15.3" release="3"/>
+<install channel="3" kind="package" name="yast2-xml" arch="i586" version="2.14.0" release="14"/>
+<install channel="3" kind="package" name="yp-tools" arch="i586" version="2.9" release="41"/>
+<install channel="3" kind="package" name="ypbind" arch="i586" version="1.20.5" release="3"/>
+<install channel="3" kind="package" name="zen-updater" arch="i586" version="7.1.100" release="59"/>
+<install channel="3" kind="package" name="zip" arch="i586" version="2.31" release="40"/>
+<install channel="3" kind="package" name="zisofs-tools" arch="i586" version="1.0.6" release="40"/>
+<install channel="3" kind="package" name="zlib" arch="i586" version="1.2.3" release="42"/>
+<install channel="3" kind="package" name="zlib-devel" arch="i586" version="1.2.3" release="42"/>
+<install channel="3" kind="package" name="zvbi" arch="i586" version="0.2.16" release="50"/>
+<install channel="3" kind="package" name="zmd" arch="i586" version="7.1.100.0" release="68"/>
+<install channel="3" kind="package" name="zsh" arch="i586" version="4.3.2" release="39"/>
+<install channel="3" kind="package" name="zypper" arch="i586" version="0.7.0" release="7"/>
+<uninstall  kind="package" name="twolame"/>
+<uninstall  kind="package" name="autoyast2-utils"/>
+<uninstall  kind="package" name="bootcycle"/>
+<uninstall  kind="package" name="pam_chroot"/>
+<uninstall  kind="package" name="yast2-bootfloppy"/>
+<uninstall  kind="package" name="OpenOffice_org-templates-labels-letter"/>
+<uninstall  kind="package" name="faac"/>
+<uninstall  kind="package" name="vlan"/>
+<uninstall  kind="package" name="OpenOffice_org-templates-presentation-layouts"/>
+<uninstall  kind="package" name="lame"/>
+<uninstall  kind="package" name="gnome-filesystem"/>
+<uninstall  kind="package" name="faad2"/>
+<uninstall  kind="package" name="libmp4v2"/>
+<uninstall  kind="package" name="wol"/>
+<uninstall  kind="package" name="ash"/>
+<uninstall  kind="package" name="mkisofs"/>
+<uninstall  kind="package" name="yast2-cim"/>
+<uninstall  kind="package" name="yast2-slp-server"/>
+<uninstall  kind="package" name="yast2-boot-server"/>
+<uninstall  kind="package" name="fastjar"/>
+<uninstall  kind="package" name="pam_userpass"/>
+<uninstall  kind="package" name="mDNSResponder-lib"/>
+<uninstall  kind="package" name="OpenOffice_org-templates-de"/>
+<uninstall  kind="package" name="yast2-storage-devel"/>
+<uninstall  kind="package" name="prctl"/>
+<uninstall  kind="package" name="x11-input-gunze"/>
+<uninstall  kind="package" name="mad"/>
+<uninstall  kind="package" name="w32codec-all"/>
+<uninstall  kind="package" name="yast2-trans-id"/>
+<uninstall  kind="package" name="pkgconfig"/>
+<uninstall  kind="package" name="yast2-theme-NLD"/>
+<uninstall  kind="package" name="yast2-heartbeat"/>
+<uninstall  kind="package" name="x264"/>
+<uninstall  kind="package" name="libkexif"/>
+<uninstall  kind="package" name="xvid"/>
+<uninstall  kind="package" name="OpenOffice_org-templates-labels-a4"/>
+<uninstall  kind="package" name="pam_mktemp"/>
+<uninstall  kind="package" name="mpt-status"/>
+<uninstall  kind="package" name="qtcurve-kde"/>
+<uninstall  kind="package" name="yast2-devel"/>
+<uninstall  kind="package" name="yast2-iscsi-server"/>
+<uninstall  kind="package" name="yast2-trans-el_GR"/>
+<uninstall  kind="package" name="gnome-mime-data"/>
+<uninstall  kind="package" name="sane"/>
+<uninstall  kind="package" name="yast2-cd-creator"/>
+<uninstall  kind="package" name="yast2-trans-sl_SI"/>
+<uninstall  kind="package" name="MPlayer"/>
+<uninstall  kind="package" name="yast2-storage-debuginfo"/>
+<keep kind="package" name="yast2-storage-debuginfo"/>
+<reportproblems/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug255011-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug255011-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug255011-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/Bug255011-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,24 @@
+<?xml version="1.0"?>
+<!-- Bug255011 both kmp packages should be installed if two kernels are installed -->
+<test>
+<setup arch="i686">
+       <channel file="Bug255011-1-package.xml" name="1" />
+       <channel file="Bug255011-3-package.xml" name="3" />
+        <locale name="en"/>
+</setup>
+<trial>
+<install channel="1" kind="product" name="SUSE_SLES_SP1"/>
+<install channel="3" kind="product" name="Open_Enterprise_Server"/>
+<install channel="1" kind="pattern" name="base"/>
+<install channel="1" kind="pattern" name="gnome"/>
+<install channel="1" kind="pattern" name="print_server"/>
+<install channel="1" kind="pattern" name="apparmor"/>
+<install channel="1" kind="pattern" name="x11"/>
+<install channel="1" kind="package" name="kernel-default"/>
+<install channel="1" kind="package" name="kernel-xen"/>
+<install channel="1" kind="package" name="yast2-trans-en_US"/>
+<install channel="3" kind="pattern" name="novell-ncp"/>
+<install channel="3" kind="pattern" name="novell-vix"/>
+<install channel="3" kind="package" name="novell-cluster-services"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug191983-bare-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug191983-bare-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug191983-bare-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug191983-bare-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<test>
+<setup arch="i686">
+  <channel name="sles10" file="../repos/sles10/sles-10-i386-1407-packages.xml.gz"/>
+  <channel name="stable" file="../repos/stable/stable-i386-20060718-packages.xml.gz"/>
+</setup>
+<trial>
+  <install channel="sles10" package="apache2-mod_python"/>
+  <install channel="sles10" package="apache2-prefork"/>
+  <reportproblems/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug222531-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug222531-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug222531-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug222531-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,16 @@
+<?xml version="1.0"?>
+<!-- testcase for bug222531 solver ignores keep state  -->
+<test>
+<setup arch="i686">
+       <system file="bug222531-system.xml"/>
+       <channel file="bug222531-packages1.xml" name="1" />
+       <channel file="bug222531-packages2.xml" name="2" />
+</setup>
+<trial>
+<keep kind="package" name="libzypp"/>
+<keep kind="package" name="libzypp" channel="1"/>
+<keep kind="package" name="libzypp" channel="2"/>
+<install channel="2" kind="patch" name="libzypp"/>
+<reportproblems/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug230685-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug230685-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug230685-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug230685-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,15 @@
+<?xml version="1.0"?>
+<!-- testcase generated by YaST for bug230685 -->
+<test>
+<setup arch="x86_64">
+       <system file="bug230685-system.xml"/>
+       <channel file="bug230685-6-package.xml" name="6" />
+       <channel file="bug230685-9-package.xml" name="9" />
+</setup>
+<trial>
+<showpool all="yes"/>
+<install channel="9" kind="patch" name="MozillaFirefox2"/>
+<install channel="9" kind="patch" name="MozillaFirefox"/>
+<reportproblems/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug238284-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug238284-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug238284-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug238284-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,18 @@
+<?xml version="1.0"?>
+<!-- testcase generated by YaST for bug 238284-->
+<test>
+<setup arch="i686">
+       <system file="bug238284-system.xml"/>
+       <channel file="bug238284-2-package.xml" name="2" />
+       <channel file="bug238284-5-package.xml" name="5" />
+       <channel file="bug238284-7-package.xml" name="7" />
+       <channel file="bug238284-3-package.xml" name="3" />
+       <channel file="bug238284-4-package.xml" name="4" />
+</setup>
+<trial>
+<showpool all="yes"/>
+<establish/>
+<showpool all="true" prefix=">!> ESTABLISHED:"/>
+<install channel="7" kind="patch" name="xine-lib"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug239199-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug239199-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug239199-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug239199-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,22 @@
+<?xml version="1.0"?>
+<!-- testcase generated by YaST for bug239199-->
+<test>
+<setup arch="x86_64">
+       <system file="bug239199-system.xml.gz"/>
+       <channel file="bug239199-3-package.xml.gz" name="3" />
+       <channel file="bug239199-10-package.xml.gz" name="10" />
+       <channel file="bug239199-13-package.xml.gz" name="13" />
+</setup>
+<trial>
+<showpool all="yes"/>
+<establish/>
+<showpool all="true" prefix=">!> ESTABLISHED:"/>
+<install channel="3" kind="package" name="kdelibs3-32bit" version="3.5.5" release="45.2" arch="x86_64"/>
+<install channel="10" kind="package" name="kdelibs3-arts" version="3.5.6" release="19.1" arch="x86_64"/>
+<install channel="10" kind="package" name="kdelibs3-devel-doc" version="3.5.6" release="20.1" arch="noarch"/>
+<install channel="10" kind="package" name="kdelibs3-doc" version="3.5.6" release="19.1" arch="x86_64"/>
+<install channel="10" kind="package" name="kdelibs3-devel" version="3.5.6" release="19.1" arch="x86_64"/>
+<install channel="10" kind="package" name="kdelibs3" version="3.5.6" release="19.1" arch="x86_64"/>
+<install channel="13" kind="package" name="k3b" version="0.99.1.0rc4" release="101.mh.3" arch="x86_64"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug308252-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug308252-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug308252-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug308252-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,14 @@
+<?xml version="1.0"?>
+<!-- testcase for bug308252 -->
+<test>
+<setup arch="i686">
+       <system file="bug308252-system.xml.gz"/>
+       <channel file="bug308252-3-package.xml.gz" name="3" />
+       <locale name="en_US" />
+       <locale name="en" />
+</setup>
+<trial>
+<establish/>
+<showpool all="true" prefix=">!> ESTABLISHED:"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug310455-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug310455-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug310455-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug310455-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,15 @@
+<?xml version="1.0"?>
+<!-- bug310455 -->
+<test>
+<setup arch="i686">
+       <system file="bug310455-system.xml.gz"/>
+       <channel file="bug310455-1-package.xml.gz" name="1" />
+       <channel file="bug310455-4-package.xml.gz" name="4" />
+       <locale name="en" />
+       <locale name="en_GB" />
+</setup>
+<trial>
+<install channel="1" kind="package" name="amarok-xine" />
+<reportproblems/>
+</trial>
+</test>

Copied: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution (from r7564, trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution2)
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution?p2=trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution&p1=trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.solution2&r1=7564&r2=7565&rev=7565&view=diff
==============================================================================
    (empty)

Added: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/bug328081-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,15 @@
+<?xml version="1.0"?>
+<!-- testcase generated by YaST Bug 328081-->
+<test>
+<setup arch="i686">
+       <channel file="bug328081-package.xml.gz" name="1" />
+       <locale name="en" />
+       <locale name="en_US" />
+</setup>
+<trial>
+<install channel="1" kind="product" name="openSUSE" arch="i686" version="10.3" release=""/>
+<install channel="1" kind="package" name="kernel-default" arch="i586" version="2.6.22.5" release="31"/>
+<install channel="1" kind="pattern" name="base" arch="i586" version="10.3" release="153"/>
+<install kind="package" name="yast2-theme-openSUSE"/>
+</trial>
+</test>

Modified: trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/ignore
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/ignore?rev=7565&r1=7564&r2=7565&view=diff
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/ignore (original)
+++ trunk/sat-solver/testsuite/data.libzypp/bugzilla-tests/ignore Fri Oct 19 11:12:10 2007
@@ -24,3 +24,5 @@
 bug292077-test.xml
 #takesolution not support
 bug292077-test.xml
+#sat-solver tries all solution by default 
+bug191983-bare-test.xml

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,22 @@
+<?xml version="1.0"?>
+<!--
+   A-1.0 is installed
+   A-1.1 is available
+   Patch-A-1.1 is available
+
+   - establish -
+
+   : patch-A-1-1 incomplete
+-->
+<test>
+<setup>
+  <system file="exercise-1-system.xml.gz"/>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish/>
+</trial>
+<trial>
+  <establish freshen="1"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-11-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-11-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-11-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-11-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,18 @@
+<?xml version="1.0"?>
+<!--
+   Nothing is installed
+   A-1.1 is available
+   Patch-A-1.1 is available but unneeded
+   Patch-A-1.1 is to be installed
+
+   : ERROR Patch-A-1-1 does not apply
+-->
+<test>
+<setup>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish/>
+  <install channel="test" kind="patch" package="Patch-A"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1f-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1f-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1f-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-1f-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,20 @@
+<?xml version="1.0"?>
+<!--
+   A-1.0 is installed
+   A-1.1 is available
+   Patch-A-1.1 is available
+
+   - freshen -
+
+   : install patch-A-1-1
+   : install A-1.1
+-->
+<test>
+<setup>
+  <system file="exercise-1-system.xml.gz"/>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish freshen="1"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,21 @@
+<?xml version="1.0"?>
+<!--
+   A-1.0 is available
+   A-1.1 is available
+   Patch-A-1.1 is available but unneeded
+   B-1.0 is to be installed which requires A
+
+   : B-1.0 is installed
+   : A-1.1 is installed
+   : patch-A-1-1 is satisfied
+-->
+<test allow_virtual_conflicts="yes">
+<setup>
+  <channel name="core" file="exercise-6-packages.xml.gz"/>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish/>
+  <install channel="core" package="B"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6f-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6f-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6f-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-6f-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,23 @@
+<?xml version="1.0"?>
+<!--
+   Nothing is installed
+   A-1.0 is available
+   A-1.1 is available
+   Patch-A-1.1 is available but unneeded
+   B-1.0 is to be installed which requires A
+
+   : B-1.0 is installed
+   : A-1.1 is installed
+   : patch-A-1-1 is satisfied
+-->
+<test allow_virtual_conflicts="yes">
+<setup>
+  <channel name="core" file="exercise-6-packages.xml.gz"/>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish/>
+  <install channel="core" package="B"/>
+  <establish freshen="1"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,21 @@
+<?xml version="1.0"?>
+<!--
+   A-1.0 is available
+   A-1.2 is available
+   Patch-A-1.1 is available but unneeded
+   B-1.0 is to be installed which requires A
+
+   : B-1.0 is installed
+   : A-1.2 is installed
+   : patch-A-1-1 is satisfied
+-->
+<test allow_virtual_conflicts="yes">
+<setup>
+  <channel name="core" file="exercise-7-packages.xml.gz"/>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish/>
+  <install channel="core" package="B"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7f-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7f-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7f-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-7f-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,29 @@
+<?xml version="1.0"?>
+<!--
+   nothing is installed
+   A-1.1 is available
+   A-1.2 is available
+   Patch-A-1.1 is available but unneeded, requires A >= 1.1
+   B-1.0 is to be installed which requires A
+
+   Solution#1
+   : B-1.0 is installed
+   : A-1.1 is installed
+   : patch-A-1-1 is satisfied
+
+   Solution#1
+   : B-1.0 is installed
+   : A-1.2 is installed
+   : patch-A-1-1 is satisfied
+-->
+<test allow_virtual_conflicts="yes">
+<setup>
+  <channel name="core" file="exercise-7-packages.xml.gz"/>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish/>
+  <install channel="core" package="B"/>
+  <establish freshen="1"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-8-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-8-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-8-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/freshen-tests/exercise-8-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,25 @@
+<?xml version="1.0"?>
+<!--
+   Nothing is installed
+   A-1.0 is available
+   A-1.1 is available
+   Patch-A-1.1 is available but unneeded
+   Patch-A-1.1 is to be installed
+
+   : Error: Patch-A-1-1 does not apply 
+-->
+<test allow_virtual_conflicts="yes">
+<setup>
+  <channel name="core" file="exercise-1-system.xml.gz"/>
+  <channel name="test" file="exercise-1-packages.xml.gz"/>
+</setup>
+<trial>
+  <establish/>
+  <install channel="test" kind="patch" package="Patch-A"/>
+</trial>
+<trial>
+  <establish/>
+  <install channel="test" kind="patch" package="Patch-A"/>
+  <establish freshen="1"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/kernel-tests/1_2_1-default-manual-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/kernel-tests/1_2_1-default-manual-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/kernel-tests/1_2_1-default-manual-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/kernel-tests/1_2_1-default-manual-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,28 @@
+<?xml version="1.0"?>
+<test>
+<setup>
+  <system file="1.2.1-default-system.xml.gz"/>
+  <channel name="packages" file="1.2.1-default-packages.xml.gz"/>
+  <hardwareInfo path="kernel-hardware"/>
+</setup>
+<!-- 
+    (1.2) Kernel ABI has changed
+
+      The KMPs and the kernel become incompatible. This results in
+      a mismatch in kernel(name) = version Provides of the kernel and
+      requires of the KMP. The resolver should indicate a conflict to
+      be resolved interactively.
+
+      (1.2.1) No updated some-kmp-$flavor packages are available
+
+       The resolver should propose to either install the new kernel and
+       remove the KMP, keep the KMP and the old kernel, or possibly
+       ignore the conflict and still install the new kernel.
+-->
+
+<trial>
+  <install channel="packages" kind="package" name="kernel-default"/>
+  <reportproblems/>
+</trial>
+
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_1-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_1-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_1-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_1-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,31 @@
+<?xml version="1.0"?>
+<test>
+<setup>
+  <channel name="packages1" file="beta8-packages.xml.gz"/>
+  <channel name="packages2" file="2.6.16_rc5_git14-2-packages.xml.gz"/>
+  <hardwareInfo path="kernel-hardware"/>
+</setup>
+<!-- 
+(3) System Installation
+
+    During system installation, we must make sure that only one kernel
+    package gets installed, and that all KMPs that should be installed
+    get installed.
+
+    (3.1) KMP requests always to be installed
+
+      A KMP can request always to be installed. For that, each
+      some-kmp-$flavor package has a `Supplements: kernel-$flavor' tag.
+      The package that matches the installed kernel-$flavor package
+      gets installed.
+
+      The novfs-kmp-$flavor packages use this mechanism. Make sure that
+      the novfs-kmp package that matches the kernel gets installed.
+-->
+
+<trial>
+ <install channel="packages2" kind="package" name="kernel-default"/>
+  <reportproblems/>
+</trial>
+
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_2-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_2-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_2-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_2-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,33 @@
+<?xml version="1.0"?>
+<!--
+(3) System Installation
+
+    During system installation, we must make sure that only one kernel
+    package gets installed, and that all KMPs that should be installed
+    get installed.
+    (3.2) Package requires a KMP
+
+      A package has a `Requires: some-kmp' tag. Each of the
+      some-kmp-$flavor packages has a `Provides: some-kmp =
+      version-release' tag. The some-kmp-$flavor package matching the
+      installed kernel should get installed.
+
+      The tpctl package employs this mechanism. Make sure that when
+      tpctl is selected, the tpctl-kmp-$flavor package matching the
+      installed kernel is installed as well. (This case is discussed in
+      bug 156513).
+-->
+<test>
+<setup>
+  <channel name="sl10_packages" file="sl10.1-beta7-packages.xml.gz"/>
+  <channel name="sl10_selections" file="sl10.1-beta7-selections.xml.gz"/>
+  <locale name="de"/>
+  <locale name="de_DE"/>
+  <mediaid/>
+</setup>
+<trial>
+  <install channel="sl10_packages" kind="package" name="tpctl"/>
+  <install channel="sl10_packages" kind="package" name="kernel-default"/>
+  <reportproblems/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_4-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_4-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_4-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/kernel-tests/3_4-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,31 @@
+<?xml version="1.0"?>
+<test>
+<setup>
+  <channel name="packages1" file="beta8-packages.xml.gz"/>
+  <channel name="packages2" file="2.6.16_rc5_git14-2-packages.xml.gz"/>
+  <hardwareInfo path="kernel-hardware"/>
+</setup>
+<!-- 
+(3) System Installation
+
+    During system installation, we must make sure that only one kernel
+    package gets installed, and that all KMPs that should be installed
+    get installed.
+    (3.4) Multiple kernels selected
+
+      multiple kernel-$flavor selected during installation and someone
+      requires foo-kmp (and no hw supplements) => make sure that multiple
+      foo-kmp-$flavor packages get installed
+
+
+-->
+
+<trial>
+ <install channel="packages2" kind="package" name="kernel-default"/>
+ <install channel="packages2" kind="package" name="kernel-smp"/>
+ <install channel="packages2" kind="package" name="novfs"/>
+
+  <reportproblems/>
+</trial>
+
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/kernel-tests/kernel_kmp-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/kernel-tests/kernel_kmp-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/kernel-tests/kernel_kmp-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/kernel-tests/kernel_kmp-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,10 @@
+<test>
+       <setup arch="i586">
+               <system file="kernel-system.xml.gz"/>
+               <channel name="kmp" file="kernel-repo.xml"/>
+       </setup>
+       <trial>
+               <addRequire name="foo-kmp"/>
+               <reportproblems/>
+       </trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/lock-tests/install-single-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/lock-tests/install-single-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/lock-tests/install-single-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/lock-tests/install-single-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,15 @@
+<?xml version="1.0"?>
+<!--
+   install single package on empty system. A is locked but it will be
+   installed, cause the user has made BOTH operations. So the lock will
+   be breaked.
+-->
+<test>
+<setup>
+  <channel name="test" file="single-package.xml"/>
+</setup>
+<trial>
+  <lock package="A" channel="test"/>
+  <install channel="test" package="A"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-all-mediaorder-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-all-mediaorder-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-all-mediaorder-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-all-mediaorder-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,45 @@
+<?xml version="1.0"?>
+<!--
+  install all selections except
+   - Mobile (multiple)
+   - DVD-Asia
+-->
+<test>
+<setup arch="i386">
+  <channel name="packages" file="sl10.1-beta3-packages.xml.gz"/>
+  <channel name="selections" file="sl10.1-beta3-selections.xml.gz"/>
+  <locale name="de"/>
+  <mediaid/>
+</setup>
+<trial>
+  <install channel="selections" kind="selection" name="Basis-Devel"/>
+  <install channel="selections" kind="selection" name="Basis-Sound"/>
+  <install channel="selections" kind="selection" name="default"/>
+  <install channel="selections" kind="selection" name="Fonts"/>
+  <install channel="selections" kind="selection" name="Games"/>
+  <install channel="selections" kind="selection" name="Gnome"/>
+  <install channel="selections" kind="selection" name="Gnome-Devel"/>
+  <install channel="selections" kind="selection" name="Hacker"/>
+  <install channel="selections" kind="selection" name="Java"/>
+  <install channel="selections" kind="selection" name="Kde"/>
+  <install channel="selections" kind="selection" name="Kde-Desktop"/>
+  <install channel="selections" kind="selection" name="Kde-Devel"/>
+  <install channel="selections" kind="selection" name="Kernel-Devel"/>
+  <install channel="selections" kind="selection" name="LAMP2"/>
+  <install channel="selections" kind="selection" name="Laptop"/>
+  <install channel="selections" kind="selection" name="Latex"/>
+  <install channel="selections" kind="selection" name="LDAP-Server"/>
+  <install channel="selections" kind="selection" name="Mobile"/>
+  <install channel="selections" kind="selection" name="Mono"/>
+  <install channel="selections" kind="selection" name="Multimedia"/>
+  <install channel="selections" kind="selection" name="Network"/>
+  <install channel="selections" kind="selection" name="Non-OSS"/>
+  <install channel="selections" kind="selection" name="Office"/>
+  <install channel="selections" kind="selection" name="SuSE-Documentation"/>
+  <install channel="selections" kind="selection" name="Tcl-Development"/>
+  <install channel="selections" kind="selection" name="Voip"/>
+  <install channel="selections" kind="selection" name="X11"/>
+  <install channel="selections" kind="selection" name="Xen"/>
+  <mediaorder/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-gnome-mediaorder-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-gnome-mediaorder-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-gnome-mediaorder-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-gnome-mediaorder-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,18 @@
+<?xml version="1.0"?>
+<!--
+  install default gnome selection
+
+  incomplete: sl10.1-beta3-packages.xml does not include libboost_regex
+-->
+<test>
+<setup arch="i386">
+  <channel name="packages" file="sl10.1-beta3-packages.xml.gz"/>
+  <channel name="selections" file="sl10.1-beta3-selections.xml.gz"/>
+  <locale name="en"/>
+  <mediaid/>
+</setup>
+<trial>
+  <install channel="selections" kind="selection" name="default-Gnome"/>
+  <mediaorder/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-mediaorder-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-mediaorder-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-mediaorder-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-default-mediaorder-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,18 @@
+<?xml version="1.0"?>
+<!--
+  install minmal selection
+
+  incomplete: sl10.1-beta3-packages.xml does not include libboost_regex !
+-->
+<test>
+<setup arch="i386">
+  <channel name="packages" file="sl10.1-beta3-packages.xml.gz"/>
+  <channel name="selections" file="sl10.1-beta3-selections.xml.gz"/>
+  <locale name="de"/>
+  <mediaid/>
+</setup>
+<trial>
+  <install channel="selections" kind="selection" name="default"/>
+  <mediaorder/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-kde-desktop-mediaorder-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-kde-desktop-mediaorder-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-kde-desktop-mediaorder-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/mediaorder-tests/install-kde-desktop-mediaorder-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,16 @@
+<?xml version="1.0"?>
+<!--
+  install minmal selection
+-->
+<test>
+<setup arch="i386">
+  <channel name="packages" file="sl10.1-beta3-packages.xml.gz"/>
+  <channel name="selections" file="sl10.1-beta3-selections.xml.gz"/>
+  <locale name="de"/>
+  <mediaid/>
+</setup>
+<trial>
+  <install channel="selections" kind="selection" name="Kde-Desktop"/>
+  <mediaorder/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/patch-tests/jumbo-patch-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/patch-tests/jumbo-patch-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/patch-tests/jumbo-patch-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/patch-tests/jumbo-patch-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,18 @@
+<?xml version="1.0"?>
+<!--
+This testcase described the behaviour of patch which requires other patches
+e.G. this is used for service packs (Fate 120233)
+-->
+<test>
+<setup>
+  <arch name="i586"/>
+  <system file="jumbo-patch-test-installed.xml"/>
+  <channel file="jumbo-patch.xml" name="jumbo"/>
+</setup>
+<trial>
+  <showpool all="yes"/>
+  <establish/>
+  <showpool all="true" prefix=">!> ESTABLISHED:"/>
+  <install channel="jumbo" kind="patch" package="patch-jumbo"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-single-update-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-single-update-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-single-update-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-single-update-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,20 @@
+<?xml version="1.0"?>
+<!--
+  An kernel patch which has ONLY the kernel packages will be triggered
+  for installation. He has to update packages (*kmp*, apparmor,...) from
+  an older patch too ( lokated in multi_source )
+-->
+<test>
+<setup>
+  <arch name="i586"/>
+  <system file="kernel-installed.xml"/>
+  <channel file="patch-kernel1.xml" name="multi_source"/>
+  <channel file="patch-kernel2.xml" name="single_source"/>
+</setup>
+<trial>
+  <showpool all="yes"/>
+  <establish/>
+  <showpool all="true" prefix="ESTABLISHED:"/>
+  <install channel="single_source" kind="patch" package="single-kernel"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-update-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-update-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-update-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/patch-tests/kernel-update-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,17 @@
+<?xml version="1.0"?>
+<!--
+  Update a kernel patch which include ALL *kmp*, apparmor,....
+-->
+<test>
+<setup>
+  <arch name="i586"/>
+  <system file="kernel-installed.xml"/>
+  <channel file="patch-kernel1.xml" name="new_source"/>
+</setup>
+<trial>
+  <showpool all="yes"/>
+  <establish/>
+  <showpool all="true" prefix="ESTABLISHED:"/>
+  <install channel="new_source" kind="patch" package="kernel"/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atmos-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atmos-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atmos-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atmos-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,17 @@
+<?xml version="1.0"?>
+<!--
+   patch-B1 will be installed. patch-A1 has an atom with the same
+   same. No error concerning parallel installation of the atom will
+   be displayed and patch-B1 will be installed
+-->
+<test>
+<setup>
+  <arch name="i586"/>
+  <system file="patchA-installed.xml"/>
+  <channel file="patchB-new.xml" name="new_source"/>
+</setup>
+<trial>
+  <install channel="new_source" kind="patch" package="patch-B1"/>
+  <reportproblems/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atoms-equal-patch-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atoms-equal-patch-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atoms-equal-patch-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/patch-tests/parallel-atoms-equal-patch-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,17 @@
+<?xml version="1.0"?>
+<!--
+   patch-A1 with the NEW version installed. patch-A1 has an atom with the same
+   same. No error concerning parallel installation of the atom will
+   be displayed and patch-A1 will be updated.
+-->
+<test>
+<setup>
+  <arch name="i586"/>
+  <system file="patchA-installed.xml"/>
+  <channel file="patchA-new.xml" name="new_source"/>
+</setup>
+<trial>
+  <install channel="new_source" kind="patch" package="patch-A1"/>
+  <reportproblems/>
+</trial>
+</test>

Added: trunk/sat-solver/testsuite/data.libzypp/patch-tests/script-test.xml
URL: http://svn.opensuse.org/viewcvs/zypp/trunk/sat-solver/testsuite/data.libzypp/patch-tests/script-test.xml?rev=7565&view=auto
==============================================================================
--- trunk/sat-solver/testsuite/data.libzypp/patch-tests/script-test.xml (added)
+++ trunk/sat-solver/testsuite/data.libzypp/patch-tests/script-test.xml Fri Oct 19 11:12:10 2007
@@ -0,0 +1,17 @@
+<?xml version="1.0"?>
+<!--
+   load patch data from you.suse.de and install script(is satisfied)
+   but not message ( is unneeded )
+-->
+<test>
+<setup>
+  <system file="glibc-i586-package.xml"/>
+  <channel file="patch-fetchmsttfonts.sh-1829.xml" name="script"/>
+  <channel file="patch-message.xml" name="message"/>
+</setup>
+<trial>
+  <establish/>
+  <showpool all="true" prefix=">!> ESTABLISHED:"/>
+  <install channel="script" kind="patch" name="fetchmsttfonts.sh"/>
+</trial>
+</test>

--
To unsubscribe, e-mail: zypp-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: zypp-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages