Mailinglist Archive: yast-devel (35 mails)

< Previous Next >
[yast-devel] Snapper-0.8.9 not building on old distros
Hi,

since we rewrote snapper's zypp plugin from Python to C++, snapper has new
build dependencies that break the build for old distros.

https://build.opensuse.org/package/show/filesystems:snapper/snapper

I suspect that many of the build targets were addded just because we could,
not because they serve a purpose. Can we simply drop them? If not, what should
our supported distro policy for Snapper be?

| Distro | Good Version | Bad Version | Bad Ver EOL | Reason
|
|------------------+--------------+-------------+-------------+----------------------------------------------|
| Centos, SciLinux | ? | 7 | 2020-2024 | no
libjson-c-devel |
| RHEL | ? | 7 | | no
libjson-c-devel |
| Debian | 10 | 9 | 2020-2022 |
boost/process.hpp: No such file or directory |
| Fedora | 27 | 26 | 2018-05-29 |
boost/process.hpp: No such file or directory |
| SLE | 15-GA | 12-SP4 | |
boost/process.hpp: No such file or directory |
| oS Leap | 15.0 | 42.3 | 2019-07-01 |
boost/process.hpp: No such file or directory |
| xUbuntu | 18.04 (LTS) | 17.10 | 2018-07-19 |
boost/process.hpp: No such file or directory |


--
Martin Vidner, YaST Team
http://en.opensuse.org/User:Mvidner
< Previous Next >