Mailinglist Archive: yast-devel (55 mails)

< Previous Next >
[yast-devel] y2debugger=1 sometimes freezes YaST at start

Hi all,

I got a feedback that using y2debugger=1 boot option to start the
ruby debugger in installation freezes the installer with just a black screen.


I tried that in SLES12-SP2 in a VBox VM and I was able to reproduce it.

Then I wanted to debug it and the only info I got was the
"Launched YaST2 component 'y2base' ..." line in y2log and nothing more.

Then I though I could use gdb to inspect the process state, I run
"extend gdb" to load the gdb debugger into inst-sys and since that
I was not able to reproduce it anymore :-(

I tried that also in KVM VM, but I was not able to reproduce it in
about 6 attempts, worked as expected...

It looks like a nasty race condition somewhere, but it's hard to guess where, it
might be in ruby-bindings, byebug, Ruby itself, or somewhere else.

It's a nice example of a Heisenbug [1].


So the current workaround is just to reboot the installer and try it again.

If it still happens then try loading the debugger. I guess it will
disappear at this point ;-)

If you can still reproduce it after loading gdb then do not miss the unique
opportunity to actually debug this very rare condition!




[1] https://en.wikipedia.org/wiki/Heisenbug

--
Ladislav Slezák
YaST Developer

SUSE LINUX, s.r.o.
Corso IIa
Křižíkova 148/34
18600 Praha 8
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages