Mailinglist Archive: yast-devel (91 mails)

< Previous Next >
[yast-devel] y2r again
Hello all,

I finally had time to try converting my YCP module again. As mentioned earlier,
I had to upgrade my yast2-core to something after 2.24.x. I tried upgrading
just this package on openSUSE 12.3 (using the package from 13.1), but
apparently it’d break a LOT of stuff.

I decided to try upgrading the whole system to 13.1, recompiled y2r… and now it
fails further while trying to load LibStorage.so. I tried feeding it the
LibStorage.so from the installation image via LD_PRELOAD, but got an “undefined
symbol: PL_thr_key” error. Since the installation image used Perl 5.16.2 and I
am now on Perl 5.18, I downgraded Perl to 5.16 with the same results.

I saw in another forum that this missing symbol indicates that this .so module
was compiled in a pthread-enabled Perl interpreter, and the one supplied with
the system is not, which I find odd. Where can I find the source to
LibStorage.so so I can recompile it, or is there a way to skip loading it in
y2r?


Erico M. Mendonça
Dedicated Support Engineer
SUSE
Rua Joaquim Floriano, 466 – Ed. Corporate 12º andar, Itaim Bibi – São Paulo –
SP / Brasil
Tel: +55 (11) 3345-3900
Cel: + 55 (61) 8594-9557
erico.mendonca@xxxxxxxx
www.suse.com
N�����r��y隊\���^��~�{.n�+�������Ǩ��r��i�m��0��ޙ��ɫ-u�ޗ�0�������Ǩ�
< Previous Next >
Follow Ups