Mailinglist Archive: yast-devel (50 mails)

< Previous Next >
Re: [yast-devel] cannot find client installation/misc.rb
On Wed, 23 Dec 2015 06:05:52 -0500
Felix Miata <mrmazda@xxxxxxxxxxxxx> wrote:

Josef Reidinger composed on 2015-12-23 11:41 (UTC+0100):

On Wed, 23 Dec 2015 05:33:00 -0500 Felix Miata wrote:

Internal error. Please report a bug report with logs.
[subject]
Caller: /user/lib/ruby/vendor_ruby/2.1.0/yast/yast.rb:116:in
'find_include_file'

This message is generated in 42.1/KDE3/QT (on host msi85) when
selecting to add from community repositories (trying to use YaST2
or yast to add Packman).

Is this a known problem? Is a new bug report really needed? If yes,
which logs, all of /var/log/YaST2/? Subset?

Hmm, it needs yast2-installation installed. If it is not installed,
then we have problem with dependencies and should be reported.

All logs, or just selected one(s)?

# ls -l /var/log/YaST2
-rw-r--r-- 1 root root 59 Oct 6 21:48 arch.info
-rw-r--r-- 1 root root 14902 Oct 6 21:47 config_diff_2015_10_06.log
-rw-rw-r-- 1 root root 303 Oct 20 05:36 config_diff_2015_10_20.log
-rw-rw-r-- 1 root root 863 Nov 21 12:36 config_diff_2015_11_21.log
-rw-r--r-- 1 root root 725 Oct 6 21:48 curl_log
-rw-r--r-- 1 root root 15395 Oct 6 21:48 disk_sda.info
-rw-r--r-- 1 root root 30 Oct 6 21:48 free.info
-rw-r--r-- 1 root root 68244 Oct 6 21:48 macro_inst_initial.ycp
-rw-r--r-- 1 root root 26183 Dec 19 01:46 mkinitrd.log
-rw-r--r-- 1 root root 39825 Oct 6 21:48 pbl-instsys.log
-rw-r--r-- 1 root root 254471 Dec 19 01:48 perl-BL-standalone-log
-rw-r--r-- 1 root root 291 Oct 6 21:48 sntp.log
-rw-r--r-- 1 root root 4675484 Dec 23 05:27 y2log
-rw-r--r-- 1 root root 897818 Oct 6 21:48 y2log-1.gz
-rw-r--r-- 1 root root 3644 Oct 6 21:48 y2logmkinitrd
-rw-r--r-- 1 root root 3640 Oct 6 21:48 y2start.log
# rpm -qa | grep yast2
yast2-3.1.155-1.1.x86_64
yast2-auth-client-3.3.5-1.1.noarch
yast2-bootloader-3.1.161-3.1.x86_64
yast2-branding-openSUSE-3.1.35-1.1.noarch
yast2-control-center-3.1.5-2.5.x86_64
yast2-control-center-qt-3.1.5-2.5.x86_64
yast2-core-3.1.18-1.1.x86_64
yast2-country-3.1.22.1-1.1.x86_64
yast2-country-data-3.1.22.1-1.1.x86_64
yast2-hardware-detection-3.1.7-8.4.x86_64
yast2-journal-3.1.2-4.2.noarch
yast2-ldap-3.1.13-5.4.x86_64
yast2-metapackage-handler-3.1.4-6.2.noarch
yast2-network-3.1.134-3.1.x86_64
yast2-nfs-client-3.1.16-5.2.noarch
yast2-nfs-common-3.1.8-5.2.noarch
yast2-ntp-client-3.1.20-1.1.noarch
yast2-packager-3.1.83-1.2.x86_64
yast2-pam-3.1.1-3.2.noarch
yast2-perl-bindings-3.1.2-7.2.x86_64
yast2-pkg-bindings-3.1.31-1.2.x86_64
yast2-printer-3.1.2-1.1.x86_64
yast2-qt-branding-openSUSE-42.1-6.2.noarch
yast2-ruby-bindings-3.1.40-1.1.x86_64
yast2-samba-client-3.1.15-10.2.noarch
yast2-samba-server-3.1.12-10.2.noarch
yast2-scanner-3.1.2-2.2.x86_64
yast2-security-3.1.12-1.6.noarch
yast2-services-manager-3.1.40-12.1.noarch
yast2-sound-3.1.7-6.6.x86_64
yast2-storage-3.1.71-2.1.x86_64
yast2-sudo-3.1.2-5.2.noarch
yast2-sysconfig-3.1.3-5.2.noarch
yast2-trans-en_US-3.1.0-5.2.noarch
yast2-trans-stats-2.19.0-17.1.noarch
yast2-transfer-3.1.2-1.2.x86_64
yast2-users-3.1.40-1.2.x86_64
yast2-xml-3.1.1-3.2.x86_64
yast2-ycp-ui-bindings-3.1.9-3.4.x86_64

In such case we do not need logs, just write that it try to use file
from yast2-installation and it is not installed, so it failed.
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >