Mailinglist Archive: yast-devel (127 mails)

< Previous Next >
Re: [yast-devel] yast2-users not synchronized
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 12.11.2015 17:37, Imobach González Sosa wrote:
Hi all,

I've detected that in yast2-users the SLE-12-GA branch and the IBS
package are not synchronized. According to the repo, the latest
version for SLE 12 (P0) should be 3.1.35.1[1]. However, in IBS I
found the latest version to be 3.1.37[2].

If I'm right, maybe cherry-picking the needed changes from
SLE-12-SP1 into SLE-12-GA should be enough. Or do you prefer
another approach?

Let's see what can we do about it...

1. This can't change:
https://build.suse.de/package/view_file/SUSE:SLE-12:Update/yast2-users/yast2-users.changes?expand=1
so SLE-12-GA branch must contain 3.1.37
2.
https://github.com/yast/yast-users/blame/SLE-12-GA/package/yast2-users.changes
- - the latest version that seems to be released is 3.1.35 - but that's
not true, time of this entry needs fixing to match BS
3. The newest package including updates released in SLE-12-GA is here
https://github.com/yast/yast-users/blame/SLE-12-SP1/package/yast2-users.changes
- - 3.1.37 seems to be the latest released version

Looks like that cherry-picking will solve it.

Anyway, this brings another set of questions: How to prevent from such
mistakes? Isn't the current workflow too complicated so it confuses
developers? Should we really ask everyone to submit manually to
maintenance OBS from maintenance branches? Would automatic submission
help? Can we at least check that we submit from->to correct location?

Thx && Bye
Lukas

- --

Lukas Ocilka, Systems Management (Yast) Team Leader
SLE Department, SUSE Linux
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlZFjg0ACgkQVSqMdRCqTizo6ACgkrOK2/Q3EFVIFMvb8hZDgetM
NGwAn11YjhPDfZGc1p1PXXpoQLU5vy5/
=NaBi
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >