Mailinglist Archive: yast-devel (211 mails)

< Previous Next >
Re: [yast-devel] yast2 --qt requires unavailable libyui6
  • From: Andrei Borzenkov <arvidjaar@xxxxxxxxx>
  • Date: Mon, 19 Oct 2015 13:47:36 +0300
  • Message-id: <CAA91j0Vhn=o9UJA9_tuKfezaapCsiA2QvrzP4DMFAdh8RjcpuQ@mail.gmail.com>
On Mon, Oct 19, 2015 at 11:53 AM, Ladislav Slezak <lslezak@xxxxxxx> wrote:
Dne 16.10.2015 v 23:26 Felix Miata napsal(a):
RE: http://lists.opensuse.org/opensuse-factory/2015-10/msg00474.html

Is requirement of unavailable libyui6 expected behavior on TW? Shouldn't
presence of libyui7 and deps cause removal of libyui6 and deps? Is this a
misfortune of following widespread recommendation to use up rather than dup
to upgrade TW?


Um, I'm not a packaging expert, but for me it looks like the dependency
is somewhat broken:

# rpm -q --obsoletes libyui7
yast2-libyui < 2.42.0
# rpm -q --provides libyui6
libyui.so.6()(64bit)
libyui6 = 3.1.4-1.8
libyui6(x86-64) = 3.1.4-1.8
yast2-libyui = 2.42.0

So libyui7 does not obsolete libyui6 because the obsolete version
does not match the libyui6 version...


Nor it should - the versionned library packages exist exactly to
enable multiple different major library versions to coexist. So having
both libyui6 and libyui7 is absolutely normal - there could be users
of libyui6 that are not yet (or never) ported to libyui7.

For "normal" libraries dependency should automatically be added by RPM
build. But apparently removal of libyui6 does not trigger any error
due to unsatisfied "require". So the actual problem is in yast
packaging - either it should manually include Requires for correct
version(s) or RPM build should be extended to handle this library
type.
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups