Mailinglist Archive: yast-devel (211 mails)

< Previous Next >
[yast-devel] yast2 --qt requires unavailable libyui6
RE: http://lists.opensuse.org/opensuse-factory/2015-10/msg00474.html

Is requirement of unavailable libyui6 expected behavior on TW? Shouldn't
presence of libyui7 and deps cause removal of libyui6 and deps? Is this a
misfortune of following widespread recommendation to use up rather than dup
to upgrade TW?

# rpmqa yui
libyui-ncurses-pkg7-2.48.1-1.1.x86_64
libyui-ncurses6-2.47.2-1.1.x86_64
libyui-ncurses7-2.47.4-1.1.x86_64
libyui-qt-graph6-2.44.3-1.4.x86_64
libyui-qt6-2.46.18-1.3.x86_64
libyui6-3.2.0-1.1.x86_64
libyui7-3.2.3-1.1.x86_64
# yast2 --qt
# rpmqa qt | grep y
libyui-qt-graph6-2.44.3-1.4.x86_64
libyui-qt6-2.46.18-1.3.x86_64
yast2-control-center-qt-3.1.5-2.3.x86_64
yast2-qt-branding-openSUSE-13.2-11.3.noarch
# zypper rm libyui6
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 4 packages are going to be REMOVED:
libyui-ncurses6 libyui-qt-graph6 libyui-qt6 libyui6

4 packages to remove.
After the operation, 3.3 MiB will be freed.
Continue? [y/n/? shows all options] (y): y
(1/4) Removing libyui-qt-graph6-2.44.3-1.4
....................................................................................[done]
(2/4) Removing libyui-qt6-2.46.18-1.3
.........................................................................................[done]
(3/4) Removing libyui-ncurses6-2.47.2-1.1
.....................................................................................[done]
(4/4) Removing libyui6-3.2.0-1.1
..............................................................................................[done]
big41:~ # yast2 --qt
Qt GUI wanted but not found, falling back to ncurses.
# zypper in libyui6
Loading repository data...
Reading installed packages...
'libyui6' not found in package names. Trying capabilities.
No provider of 'libyui6' found.
Resolving package dependencies...

Nothing to do.
# zypper in libyui-qt7
...
The following NEW package is going to be installed:
libyui-qt7 2.46.20-1.1
...
(1/1) Installing: libyui-qt7-2.46.20-1.1
......................................................................................[done]
committingCommitResult (total 1, done 1, error 0, skipped 0, updateMessages 0)
# zypper in libyui-qt-pkg7
The following NEW package is going to be installed:
libyui-qt-pkg7 2.45.4-1.1
...
(1/1) Installing: libyui-qt-pkg7-2.45.4-1.1
...................................................................................[done]
committingCommitResult (total 1, done 1, error 0, skipped 0, updateMessages 0)
# yast2 --qt
#
--
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >