Mailinglist Archive: yast-devel (25 mails)

< Previous Next >
Re: [yast-devel] Versioning yast-security
Dne 22.9.2015 v 18:50 Ancor Gonzalez Sosa napsal(a):
[...]
That will lead to version 3.11.1.2 in SLE-12-GA but... which version
number should I use in the SLE-12-SP1 branch?

The version in SLE-12-SP1 must be greater than any (future) version in
SLE-12-GA to
correctly update the package during upgrade from GA to SP1 (otherwise the solver
would keep the old version).

That means the version must be 3.11.2 in SLE-12-SP1.

To solve the version conflict with TW increase the version in master to 3.12.0.
That will also indicate that the package is not compatible with SLE12
and it should help to avoid submitting the package to SLE12 by mistake...

(Don't forget also to change the Jenkins autosubmitting for SLE-12-SP1.)

--

Best Regards

Ladislav Slez√°k
Yast Developer
------------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: lslezak@xxxxxxx
Lihovarsk√° 1060/12 tel: +420 284 028 960
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz/
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References