Mailinglist Archive: yast-devel (25 mails)

< Previous Next >
[yast-devel] Versioning yast-security
  • From: Ancor Gonzalez Sosa <ancor@xxxxxxx>
  • Date: Tue, 22 Sep 2015 18:50:27 +0200
  • Message-id: <560186D3.3020705@suse.de>
To fix this bug [1], I have to revert an old commit from the SLE
branches, leaving it in openSUSE.

I'm not sure what to do with the version numbers.

Version in master is 3.11.1 and includes the fix TW that should be
reverted for SLE [2].

Version in SLE-12-GA is 3.11.1.1, which is the same as above (everything
was recently backported) plus adjustements needed to build and run in
SLE-12-GA [3].

Now I need to branch SLE12-SP1 from master. Master will stay as it is
and the mentioned fix will be reverted in two branches: SLE-12-GA and
SLE-12-SP1.

That will lead to version 3.11.1.2 in SLE-12-GA but... which version
number should I use in the SLE-12-SP1 branch?

[1] https://bugzilla.suse.com/show_bug.cgi?id=946889
[2]
https://github.com/yast/yast-security/blob/master/package/yast2-security.changes
[3]
https://github.com/yast/yast-security/blob/SLE-12-GA/package/yast2-security.changes

--
Ancor González Sosa
YaST Team at SUSE Linux GmbH
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups