Mailinglist Archive: yast-devel (72 mails)

< Previous Next >
Re: [yast-devel] yast2-auth-server fails to build with GCC 5 (fwd)
Hi Howard,
welcome on board, if you need any help regarding yast do not hesitate
to ask yast team. As this issue blocks gcc5 integration, I think it
should have priority as rest of yast is already adapted.
So do not hesitate to contact us on mailing list or on freenode#yast

Thanks
Josef

On Tue, 28 Apr 2015 11:25:25 +0200 (CEST)
Richard Biener <rguenther@xxxxxxx> wrote:

On Tue, 28 Apr 2015, Milisav Radmanic wrote:



Am 27.04.2015 um 11:23 schrieb Josef Reidinger:
On Mon, 27 Apr 2015 10:45:21 +0200 (CEST)
Richard Biener <rguenther@xxxxxxx> wrote:

On Fri, 10 Apr 2015, Josef Reidinger wrote:

Hi,
I think you did it right to write ckornacker and varkoly,
they are maintainers of yast2-auth-server. YaST team itself
do not handle it, just do mass changes affecting all modules.
The issue is still not fixed in Factory and blocks GCC 5
adoption. The YaST development model doesn't seem sustainable
if such fixes can't be applied within two weeks.
It has nothing do to with yast developement model, just with
specific part of yast that is not maintained by Yast Team.

I just found that ckornacker no longer work for SUSE. So I add to
CC also Mili and if you really need to do something I recommend to
escalate it to him or visit him personally. So Peter looks only
one who maintain these new modules now. In urgent case I can also
merge your fix, but I do not want to act behind maintainers back.

Josef

thanks Josef, I apologize we're in the hot phase of a product
release and did not have time yet to focus on this.
I'm adding Howard Guo, he is replacing ckornacker in that respect.
Please explain the issue and he will take it from there (I'm
currently travelling and won't be able to address this before
Thursday.

See below with a trivial patch.


From rguenther@xxxxxxx Thu Apr 9 10:51:07 2015
Date: Thu, 9 Apr 2015 10:51:07 +0200 (CEST)
From: Richard Biener <rguenther@xxxxxxx>
To: ckornacker@xxxxxxxx, varkoly@xxxxxxxx
Subject: yast2-auth-server fails to build with GCC 5


See patch below (default args are not valid in a typedef context).

Thanks,
Richard.

--- yast2-auth-server-3.1.13/lib/slapd-config.h.orig
2015-04-09 10:47:38.777711978 +0200 +++
yast2-auth-server-3.1.13/lib/slapd-config.h 2015-04-09
10:47:45.377785905 +0200 @@ -28,7 +28,7 @@ #define SLAPD_LOG_ERR 1

typedef void (SlapdConfigLogCallback) (int level, const std::string
&msg,
- const char* file=0, const int line=0, const char*
function=0 );
+ const char* file, const int line, const char* function );

class OlcConfigEntry
{

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups