Mailinglist Archive: yast-devel (53 mails)

< Previous Next >
Re: [yast-devel] convert ycp to ruby about yast-geo-cluster
  • From: Dongmao Zhang <dmzhang@xxxxxxxx>
  • Date: Tue, 11 Feb 2014 15:41:00 +0800
  • Message-id: <52F9D40C.60804@suse.com>
I think I resolved this problem. I
used another development environment.
it works well.



于 2014年02月10日 17:06, Dongmao Zhang 写道:
I tested the yast-geo-cluster in my devel environment.

it shows this:


opensuse131-3:~/yast-geo-cluster # rake run
rake aborted!
no implicit conversion of nil into String
/root/yast-geo-cluster/Rakefile:1:in `<top (required)>'
(See full trace by running task with --trace)


Do you have any clue?




于 2014年01月25日 00:10, Josef Reidinger 写道:
On Fri, 24 Jan 2014 15:21:06 +0800
Dongmao Zhang<dmzhang@xxxxxxxx> wrote:

hi,josef,
Sorry to bother you again. When I was testing yast-geo-cluster.
I find some part code is missing. 'include/geo-cluster/dialogs.rb'
does no have the ConfigureDialog. Can you help me to convert it ?


Dongmao Zhang



Hi Dongmao,
thanks for spotting it. It is bug in y2r or I did something wrong, but
I can reproduce it, so probably bug. I use one work-around that allows
me to regenerate it using source you sent me before and create pull
request[1] for your code.
Please check it and merge if you are OK with it.

Josef

[1] https://github.com/yast/yast-geo-cluster/pull/1


--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
References