Mailinglist Archive: yast-devel (62 mails)

< Previous Next >
Re: [yast-devel] Dropping openSUSE-12.3 support in YaST:Head
On Tue, 19 Nov 2013 17:24:50 +0100
Ladislav Slezak <lslezak@xxxxxxx> wrote:


Hi all,


currently we build YaST:Head packages for openSUSE 12.3, 13.1 and for
Factory.

We should disable/remove 12.3 build because

- Yast packages are targeted to Factory, we cannot ensure they build
or they work correctly with older releases (the older release the
more problems there likely will be)

- There can be build problems, like yast2 does not build for 12.3
currently, the testsuite gets stuck. The problem can be in the older
Ruby, incompatible rspec packages... Some other packages fail in
rspec tests, etc..

- And unfortunately we do not have enough developers to fully support
older releases, so IMO it's better to drop it rather then keeping it
in broken state.


Because 13.1 is really fresh I'd like to keep 12.3 build for some
time, I propose 2 weeks. After 2 weeks I'll remove/disable it.

Is that OK for you? Any ideas or objections to this proposal?


I agreed, we also have problems with dependencies as for some changes
new version of libraries/tools are needed.
Common state supporting last stable + factory looks good for me.

Josef



--

Ladislav Slez√°k
Appliance department / YaST Developer
Lihovarsk√° 1060/12
190 00 Prague 9 / Czech Republic
tel: +420 284 028 960
lslezak@xxxxxxxx
SUSE

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >
References