Mailinglist Archive: yast-devel (66 mails)

< Previous Next >
[yast-devel] YaST Runlevel in Ruby
Hi,

Last week, I've decided to start a pilot project: YaST Runlevel written completely in Ruby. I've just got it to the state when I dare to publish it :) Please try...

See the project here: https://github.com/kobliha/yast-runlevel-ruby

How to run
sudo cp src/runlevel-ruby.rb /usr/share/YaST2/clients/
sudo yast2 runlevel-ruby

Right now, it
- lists services you can modify (enabled or disabled)
- shows their current state
- offers to start/stop or disable/enable them
- can save the current configuration

What is missing
- dependencies: install yast2.rpm from YaST:Head:ruby at
build.opensuse.org
- whole packaging into RPM/Gem
- setting the default target (default runlevel)

Comments and patches are welcomed! :) It was really easy to write such YaST module in Ruby. I'll blog about it later.

Bye
Lukas

--

Lukas Ocilka, Cloud & Systems Management Department
SUSE LINUX s.r.o., Praha
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: yast-devel+owner@xxxxxxxxxxxx

< Previous Next >