Mailinglist Archive: yast-devel (27 mails)

< Previous Next >
[yast-devel] patch for yast2-devtools
Hi,

please review atteched patch for yast2-devtools. The reason for
the patch is as following:

A few days ago I changed yast2-core and increased the version
numbers of liby2util and libycpvalues. But the plugin in
yast2-xml does not link against those libraries so the
buildservice does not rebuild yast2-xml thus the users following
factory update yast2-core but not yast2-xml and the system gets
broken (reported by customer).

So the plugins have to be linked against those libraries which
the patch does.

Regards,
Arvin

--
Arvin Schnell, <aschnell@xxxxxxx>
Senior Software Engineer, Research & Development
SUSE LINUX Products GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB
16746 (AG Nürnberg)
Maxfeldstraße 5
90409 Nürnberg
Germany
diff --git a/devtools/bin/y2autoconf b/devtools/bin/y2autoconf
index 2115c4b..1587f4d 100755
--- a/devtools/bin/y2autoconf
+++ b/devtools/bin/y2autoconf
@@ -283,7 +283,7 @@ PKG_CHECK_EXISTS([yast2-core],[
CFLAGS="${CFLAGS} -Wall -Wformat=2 -Wmissing-prototypes"
CXXFLAGS="${CXXFLAGS} ${Y2CORE_CFLAGS} -Wall -Wformat=2"

-: ${AGENT_LIBADD:=\'-L$(libdir) -lscr\'}
+: ${AGENT_LIBADD:=\'-L$(libdir) -lscr -ly2util -lycpvalues\'}
AC_SUBST(AGENT_LIBADD)

AC_DISABLE_STATIC
< Previous Next >
This Thread
  • No further messages