Mailinglist Archive: yast-devel (17 mails)

< Previous Next >
[yast-devel] Re: own server component in YaST, symbol not found
  • From: Martin Vidner <mvidner@xxxxxxx>
  • Date: Tue, 9 Nov 2010 18:24:18 +0100
  • Message-id: <20101109172418.GF7558@xxxxxxxxxxxxxxxx>
On Mon, Nov 08, 2010 at 10:50:47PM +0100, Pavel Nemec wrote:
the problem is that, contrary to expectations, the WFM plugin needs
to be linked explicitly to the executable.

You know what. I thought that. So I tried to link it. I am using cmake.
however
FindYast.cmake return this
-- YaST2 found: includes in /usr/include/YaST2, library in /usr/lib/liby2.so
-- plugins in /usr/local/lib/YaST2/plugin
-- scr in YAST_PLUGIN_SCR_LIBRARY-NOTFOUND
-- wfm in YAST_PLUGIN_WFM_LIBRARY-NOTFOUND
-- UI in YAST_PLUGIN_UI_LIBRARY-NOTFOUND

Is this bug?

Maybe, but I must admit I am not familiar with CMake. So it is hard
to tell if you do not tell us how you use it. I assume you compiled
and installed yast2-core to the /usr/local prefix, and...?

Anyway, look in these files to find examples of using the module:
(under http://svn.opensuse.org/svn/yast/trunk )
control-center/CMakeLists.txt:INCLUDE(YastCommon)
qt/CMakeLists.txt:INCLUDE(YastCommon)
qt-graph/CMakeLists.txt:FIND_PACKAGE(Yast)
qt-graph/CMakeLists.txt:INCLUDE(YastCommon)
qt-pkg/CMakeLists.txt:FIND_PACKAGE(Yast)
qt-pkg/CMakeLists.txt:INCLUDE(YastCommon)
ruby-bindings/CMakeLists.txt:FIND_PACKAGE(Yast REQUIRED)
--
Martin Vidner, YaST developer
http://en.opensuse.org/User:Mvidner

Kuracke oddeleni v restauraci je jako fekalni oddeleni v bazenu
< Previous Next >
This Thread
References