Mailinglist Archive: yast-devel (17 mails)

< Previous Next >
[yast-devel] Re: own server component in YaST, rpmbuild
  • From: Martin Vidner <mvidner@xxxxxxx>
  • Date: Tue, 9 Nov 2010 18:15:40 +0100
  • Message-id: <20101109171540.GE7558@xxxxxxxxxxxxxxxx>
On Mon, Nov 08, 2010 at 11:19:21PM +0100, Pavel Nemec wrote:
I tried to debug yast, however I find out that debuginfo packages are out of
sync.

They are, if you install updates but don't have (enabled) the
debuginfo repo for them:
http://download.opensuse.org/update/11.3-test
http://download.opensuse.org/debug/update/11.3-test
(you probably use the variants without "-test")

So i tried compile my yast2-core with rpmbuild
I got:strange error:

Running /usr/src/packages/BUILD/yast2-
core-2.19.2/scr/testsuite/scr.test/scr.exp ...
Running dir...
Running order...
Running error...
Running simple...
Running register...
FAIL: Wrong stderr for register
Running overload...
Running direct...

=== scr Summary ===

# of expected passes 6
# of unexpected failures 1
make[4]: *** [check-DEJAGNU] Error 1
make[4]: Leaving directory `/usr/src/packages/BUILD/yast2-
core-2.19.2/scr/testsuite'
[...]
error: Bad exit status from /var/tmp/rpm-tmp.0QVCTm (%install)

As this was clean build,, it look like that yast2-core-2.19 is broken. Is it
worth bug report?

Well, we do not use rpmbuild, because it does not provide a
consistent environment. If you still want to rebuild the rpm, please
try build.rpm or "osc build" (osc.rpm)

--
Martin Vidner, YaST developer
http://en.opensuse.org/User:Mvidner

Kuracke oddeleni v restauraci je jako fekalni oddeleni v bazenu
< Previous Next >
This Thread
References