Mailinglist Archive: yast-devel (233 mails)

< Previous Next >
[yast-devel] WebYaST: package naming conventions
  • From: Jiří Suchomel <jsuchome@xxxxxxx>
  • Date: Fri, 23 Oct 2009 13:49:04 +0200
  • Message-id: <200910231349.04744.jsuchome@xxxxxxx>
Hi,
I wanted to close bug 548676 ("mail_settings vs. mailsettings name
inconsistency"), however, I found that we do not have any unique conventions
of how to name a packages. We have packages:

- with underscore in the name: yast2-webclient-patch_updates
- with dash: yast2-webclient-custom-services
- withoutwordseparators: yast2-webclient-systemtime

... so, shouldn't we unify it?
Dash looks good in the name, because we have it already in the "yast2-web"
part, but than we cannot find a consistency with controller/model names,
which should have underscores or nothing.

With underscore, we can could have it same at every place
(yast2-webclient-patch_updates, patch_updates_controller.rb,
PatchUpdatesController), however the package name is ugly.

Without separators, package name and controller/model names could be the same
( yast2-webclient-systemtime, SystemtimeController), but object names look
bad...


Jiri

--
Jiri Suchomel

SUSE LINUX, s.r.o. e-mail: jsuchome@xxxxxxx
Lihovarská 1060/12 tel: +420 284 028 960
190 00 Praha 9, Czech Republic http://www.suse.cz
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups