Mailinglist Archive: yast-devel (233 mails)

< Previous Next >
Re: [yast-devel] Yast Memory Error
  • From: Klaus Kaempf <kkaempf@xxxxxxx>
  • Date: Thu, 15 Oct 2009 13:24:05 +0200
  • Message-id: <20091015112405.GA16956@xxxxxxxxxxxxx>
* Ladislav Slezak <lslezak@xxxxxxx> [Oct 15. 2009 13:17]:
On 15.10.2009 11:34, Klaus Kaempf wrote:

rpm -V should report such wrong dependencies. If it doesn't, its a
packaging fault (not requiring the correct version).

The dependencies are usually defined like this:

Requires: yast2 >= 2.16.46

We would have to add explicit

Requires: yast2 < 2.18.0

to ensure that 2.18.x package will not be installed.

Hmm, I see.


AFAIK we would have to add this extra dependency for all Requires
for all Yast packages and we would have to change this dependency for each
distribution release.

Maybe this extra dependencies could be added automatically by '/usr/bin/y2tool
create-spec' call which generates the final .spec file from .spec.in.

Or is there a better way?


Requiring an ABI version could solve this, e.g.

Requires: yast(abi) = 2.17

(Stolen from http://fedoraproject.org/wiki/Packaging/Ruby ;-))

Klaus
---
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG N├╝rnberg)

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >