Mailinglist Archive: yast-devel (233 mails)

< Previous Next >
Re: [yast-devel] Yast Memory Error
  • From: Martin Vidner <mvidner@xxxxxxx>
  • Date: Thu, 15 Oct 2009 11:11:52 +0200
  • Message-id: <20091015091152.GE9895@xxxxxxxxxxxxxxxx>
On Thu, Oct 15, 2009 at 10:00:58AM +0200, Sascha 'saigkill' Manns wrote:
A Donnerstag 15 Oktober 2009 09:25:37 wrote Martin Vidner:
When does it crash? What version are you using?
Use Bugzilla (assign to me) or meet us on
irc://irc.opensuse.org/yast .
I've checked the Packages:
http://pastebin.ca/1621656

OK, most packages have 2.17.x version, which corresponds to openSUSE
11.1, but some of them have 2.18.x (oS 11.2), in particular
yast2-ycp-ui-bindings-2.18.5-1.1
The crash happens in Wizard.ycp which deals with UI code, so it is
most likely a binary incompatiblity of that package.

I assume that you are mixing yast packages from different
repositories. (trying out libyui, perhaps?) In general that is a bad
idea because our libraries are not behaving well with respect to
library versioning and the shared library policy, sorry.

Please run "zypper se -s yast2" to see where your packages are
coming from, and fix it using zypper. Something like this could do
it:
zypper in yast2-ycp-ui-bindings\<2.18 yast2-libyui\<2.18
--
Martin Vidner, YaST developer
http://en.opensuse.org/User:Mvidner

Kuracke oddeleni v restauraci je jako fekalni oddeleni v bazenu
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >