Mailinglist Archive: yast-devel (163 mails)

< Previous Next >
[yast-devel] Distribution dependent Requires: in *.spec file (SLE11 vs. 11.2)
  • From: Ladislav Slezak <lslezak@xxxxxxx>
  • Date: Tue, 22 Sep 2009 16:48:34 +0200
  • Message-id: <4AB8E3C2.7020606@xxxxxxx>
Hi all,

We need to have correct WebYaST package dependencies to YaST
in both 11.2 and SLE11 distributions.

Because yast packages have completely different version numbers we
have to explicitly check this in *.spec file using %suse_version
macro.


Example (just committed in 'service' REST plugin):

-----------------------------------------------------------
# YaPI/SERVICES.pm
%if 0%{?suse_version} == 0 || %suse_version > 1110
# 11.2 or newer
Requires: yast2 >= 2.18.24
%else
# 11.1 or SLES11
Requires: yast2 >= 2.17.10.2
%endif
-----------------------------------------------------------

Please adapt your packages accordingly.

See http://en.opensuse.org/Build_Service/cross_distribution_package_how_to
for more details.


--

Best Regards

Ladislav Slez√°k
Yast Developer
------------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: lslezak@xxxxxxx
Lihovarsk√° 1060/12 tel: +420 284 028 960
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz/
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages