Mailinglist Archive: yast-devel (152 mails)

< Previous Next >
[yast-devel] RFC: splitting yast2-core package
  • From: Ladislav Slezak <lslezak@xxxxxxx>
  • Date: Wed, 29 Jul 2009 13:18:52 +0200
  • Message-id: <4A70301C.5000608@xxxxxxx>

Hi all,

Currently yast2-core package requires also DBus and PolicyKit packages (because
of
the DBus service and the DBus agent).

This makes updating or compiling the interpreter more complicated and the DBus
service is always installed (even when not needed) which is bad from security
point
of view.

So my proposal is to split the package into three parts:
- yast2-core - the core interpreter + agents (no DBus or PolicyKit dependency)
- yast2-dbus-client - the DBus agent (requires DBus),
currently needed by yast2-storage only
- yast2-dbus-server - YaST DBus services (require DBus + PolicyKit),
needed by WebYast (so it should not be installed by default)

I have already prepared the new packages in tmp/lslezak SVN branch, RPMs are in
my
OBS project (home:lslezak:Factory).

Please review the proposal. If there are no objections I'll submit the packages
to
Factory soon...

Thank you.

--

Best Regards

Ladislav Slez√°k
Yast Developer
------------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: lslezak@xxxxxxx
Lihovarsk√° 1060/12 tel: +420 284 028 960
190 00 Prague 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz/
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >