Mailinglist Archive: yast-devel (152 mails)

< Previous Next >
Re: [Bulk] Re: [yast-devel] How to submit patch
  • From: Jiri Srain <jsrain@xxxxxxx>
  • Date: Mon, 13 Jul 2009 11:00:44 +0200
  • Message-id: <200907131100.44398.jsrain@xxxxxxx>
Dne pondělí 13 Červenec 2009 10:54:04 Dave Plater napsal(a):
Jiri Srain wrote:
Hi Dave!

It obviously depends on which version do you want the patch apply to. It
is always more useful to create a patch against SVN head of a particular
branch than against a released package.

In any case, the bugfix should go to 11.2 (which means, in the speach of
SVN, to trunk - http://svn.opensuse.org/svn/yast/trunk/, see also
http://en.opensuse.org/YaST_Development_Branches for the complete list of
active branches and their definition). Either you can attach the patch to
bzilla, or (preferred alternative) I can grant you access to the SVN
repository so that you can directly apply it and submit the package to
the YaST:Head Development project in OBS, which is in the end more
flexible also in the future - just tell me which way you prefer.

Hope that helps,
Jiri

Dne neděle 12 Červenec 2009 10:13:13 Dave Plater napsal(a):
Hi, I wish to submit a patch which fixes the size column in
yast2-qt-pkg-YQPkgList.cc re:
https://bugzilla.novell.com/show_bug.cgi?id=513242 what version of
qt-pkg should I make the patch against?
Regards
Dave P

Hi Jiri, I don't trust myself yet to operate on SVN I'm still
familiarizing myself with build service mechanisms and patching so I
will post it to bugzilla and patch against head's 2.18.9.

OK, or just check out current version from SVN and provide patch against it -
you cannot break anything this way and you are sure that the patch will be
applicable without changes.

Another question, when I built my altered yast2-qt-pkg-2.18.9 in build
service, I needed both libsatsolver-0.14.1 and 0.14.2 to build, why
would that be?

Which repository (or repositories) did you build it against? If you build
against Factory, obviously you need also some of the libraries which are in
Factory. You should try to build it against 11.1 without any repositories
added, then it should work fine (unless there have been other changes done,
then you need to patch the 11.1 version).

HTH,
Jiri


--
Regards,

Jiri Srain
YaST Team Leader
---------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: jsrain@xxxxxxx
Lihovarska 1060/12 tel: +420 284 028 959
190 00 Praha 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups