Mailinglist Archive: yast-devel (34 mails)

< Previous Next >
[yast-devel] Question about Python and Ruby bindings
  • From: Jeff Shantz <jeff.shantz@xxxxxxxxx>
  • Date: Thu, 28 May 2009 12:51:05 -0400
  • Message-id: <6e6afd8c0905280951j510e5f4am97327106372b7e32@xxxxxxxxxxxxxx>
Hi all,

First off, let me apologize if my questions have already been covered.
I searched the archives and Googled for answers, but didn't come up
with much.

I am developing the YaST education module as part of the Google Summer
of Code. I am interested in using the Python bindings, and currently
have yast2-python-bindings-2.17.3-1.41 installed on openSUSE 11.1. I
created a template using the config-python skeleton, but when I do a
make/make install and then try to run my module, I get an error that
no such client module is found in the search path (/y2update/clients,
/root/.yast2/clients, /usr/share/YaST2/clients). I assume that the
problem lies in the fact that a .py file has been installed in
/usr/share/YaST2/clients instead of a .ycp file. Do I need to create
a .ycp wrapper to load my Python module, or what is the "standard"
way?

Second question, out of interest. I see that Ruby bindings exist for
YaST, but haven't seen much documentation on them except for a few
blog posts from 2007. Are the Ruby bindings production ready, or
still considered unstable?

If these questions are in the wrong list, please direct me to the
right place. Thanks all.

Regards,
Jeff Shantz
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
List Navigation