Mailinglist Archive: yast-devel (36 mails)

< Previous Next >
[yast-devel] Bad library path for ruby bindings
  • From: jreidinger <jreidinger@xxxxxxx>
  • Date: Thu, 21 May 2009 11:21:31 +0200
  • Message-id: <4A151D1B.3010004@xxxxxxx>
Hi, I try webyast and this write in modules:
Error loading language plugin
/usr/lib64/YaST2/plugin/libpy2lang_ruby.so: libpy2wfm.so.2: cannot open
shared object file: No such file or directory false Error loading
language plugin /usr/lib64/YaST2/plugin/libpy2lang_ruby.so:
libpy2wfm.so.2: cannot open shared object file: No such file or directory

libpy2wfm is already in yast2 plugin directory, but also ldd doesn't
show it.
So I see two bugs - first is in webyast that show this errors and second
is this behavior.

ls -l /usr/lib64/YaST2/plugin/libpy2wfm.so.2*
lrwxrwxrwx 1 root root 18 2009-05-19 13:02 libpy2wfm.so.2 ->
libpy2wfm.so.2.0.0
-rwxr-xr-x 1 root root 118344 2009-05-19 09:54 libpy2wfm.so.2.0.0


ldd libpy2lang_ruby.so
linux-vdso.so.1 => (0x00007fff0b1ff000)
liby2.so.2 => /usr/lib64/liby2.so.2 (0x00007f2802cbd000)
libycp.so.3 => /usr/lib64/libycp.so.3 (0x00007f2802982000)
libpy2wfm.so.2 => not found
libruby.so.1.8 => /usr/lib64/libruby.so.1.8 (0x00007f280267d000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f2802370000)
libm.so.6 => /lib64/libm.so.6 (0x00007f280211a000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f2801f02000)
libc.so.6 => /lib64/libc.so.6 (0x00007f2801ba8000)
liby2util.so.4 => /usr/lib64/liby2util.so.4 (0x00007f2801985000)
libutil.so.1 => /lib64/libutil.so.1 (0x00007f2801782000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f280157d000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f2801361000)
libblocxx.so.6 => /usr/lib64/libblocxx.so.6 (0x00007f280103a000)
libpcre.so.0 => /usr/lib64/libpcre.so.0 (0x00007f2800e09000)
libxcrypt.so.2 => /lib64/libxcrypt.so.2 (0x00007f2800bd5000)
libycpvalues.so.3 => /usr/lib64/libycpvalues.so.3 (0x00007f2800967000)
libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f2800729000)
/lib64/ld-linux-x86-64.so.2 (0x00007f2803126000)
libssl.so.0.9.8 => /usr/lib64/libssl.so.0.9.8 (0x00007f28004db000)
libcrypto.so.0.9.8 => /usr/lib64/libcrypto.so.0.9.8 (0x00007f280015d000)
libz.so.1 => /lib64/libz.so.1 (0x00007f27fff47000)

symlink solve this problem
linux-i632:/usr/lib64 # ln -s YaST2/plugin/libpy2wfm.so.2 libpy2wfm.so.2

Josef
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages