Mailinglist Archive: yast-devel (116 mails)

< Previous Next >
Re: [yast-devel] DnsServerAPI.pm
  • From: Jiri Srain <jsrain@xxxxxxx>
  • Date: Tue, 10 Jun 2008 12:58:03 +0200
  • Message-id: <200806101258.07242.jsrain@xxxxxxx>
Hi!

Dne Tuesday 10 of June 2008 09:44:17 Michal Zugec napsal(a):
Hi!
Because of dependencies I moved $SUBJ from yast2-dns-server into yast2
package.
This was because of bnc#392606 (yast-http-server dependency), but if any
other packages are affected, please fix them. All changes are in svn trunk,
packages are not in autobuild yet.

Is this really the best way to go? This way we polute the yast2.rpm package
with code which does not work without another package (yast2-dns-server) at
all. With this code in, yast2.rpm should IMHO recommend the yast2-dns-server
package, which does not conform with it being understoon as "base libraries".

I personally find the dependency of yast2-apache on yast2-dns-server
acceptable, as the price for integration of YaST modules.

--
Regards,

Jiri Srain
YaST Team Leader
---------------------------------------------------------------------
SUSE LINUX, s.r.o. e-mail: jsrain@xxxxxxx
Lihovarska 1060/12 tel: +420 284 028 959
190 00 Praha 9 fax: +420 284 028 951
Czech Republic http://www.suse.cz
< Previous Next >
References