Mailinglist Archive: yast-devel (116 mails)

< Previous Next >
Re: [yast-devel] DnsServerAPI.pm
  • From: Lukas Ocilka <lukas.ocilka@xxxxxxx>
  • Date: Tue, 10 Jun 2008 12:02:04 +0200
  • Message-id: <484E511C.50400@xxxxxxx>
Michal Zugec wrote:
Hi!
Because of dependencies I moved $SUBJ from yast2-dns-server into yast2 package. This was because of bnc#392606 (yast-http-server dependency), but if any other packages are affected, please fix them. All changes are in svn trunk, packages are not in autobuild yet.

I've removed your changes in VERSION files in trunk (openSUSE 11.1). Version line 2.16.X must be kept for openSUSE 11.0 maintenance as we can't have two different packages with the same version.

The next version of package yast2 in trunk will be 2.17.0. That version should also contain:
--- cut ---
Provides: yast2-dns-server:/usr/share/YaST2/modules/DnsServerAPI.pm
--- cut ---
(not done yet)

The next version of yast2-dns-server will be 2.17.0 too (not done yet).

Other packages requiring DnsServerAPI should require yast2 >= 2.17.0 (not done yet).
Package yast2 should conflict with yast2-dns-server <= 2.17.0 (not done yet).

Please, make sure that your changes are consistent and that all the dependencies are correct.

Thanks && Bye
Lukas

< Previous Next >
References