Mailinglist Archive: yast-devel (38 mails)

< Previous Next >
Re: [yast-devel] running YaST on Fedora Core 9
  • From: Michal Zugec <mzugec@xxxxxxx>
  • Date: Thu, 29 May 2008 10:09:16 +0200
  • Message-id: <483E64AC.8090802@xxxxxxx>
Machal,

Did you have a look at the {zypp,yast}-backport [0][1] repositories in OBS?
They compile zypper and yast also against Fedora and some feedback about those
repos would in fact be great.

No, I didn't know about them before. But I can see target Fedora (in version 8, I want current 9) with almost empty content ;-(. Only few packages are there. But this is probably Build Service problem, not your spec files

Update: There is Fedora 9 now ;-)

Did you have anything special to do? Or could you mainly just go ahead and
compile?

Mostly I just compile from sources. But about yast2-iscsi-client I must change and comment some distribution dependent code.

Looking forward to hear your input (as one of the maintainers of those repos)

I have some ideas. For instance we need for non-rpm distributions (yes, we want "expand" also there ;-)) custom pkg-bindings, and for Package[s] functions use map instead of string or list :

instead of

if( !Package::InstallMsg( "open-iscsi",
_("<p>To configure the iSCSI initiator, the <b>%1</b> package must be installed.</p>") +
_("<p>Install it now?</p>")) )
{
Popup::Error( Message::CannotContinueWithoutPackagesInstalled() );


we should use

if( !Package::InstallMsg( $["suse":"open-iscsi", "redhat":"iscsi-initiator-utils",
_("<p>To configure the iSCSI initiator, the <b>%1</b> package must be installed.</p>") +
_("<p>Install it now?</p>")) )
{
Popup::Error( Message::CannotContinueWithoutPackagesInstalled() );


etc.

Bye,
Michal

--
Best Regards,
Michal Zugec
Software developer
---------------------------------------------------------------------
SuSE CR, s.r.o. e-mail: mzugec@xxxxxxx
Lihovarska 1060/12 tel: +420 284 028 960
190 00 Praha 9 fax: +420 296 542 374
Czech Republic http://www.suse.cz/

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups