Mailinglist Archive: yast-devel (191 mails)

< Previous Next >
Re: [yast-devel] Package-Bindings
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Thu, 20 Mar 2008 00:19:23 +0100
  • Message-id: <20080319231923.GB1962@xxxxxxx>
On Wed, Mar 19, 2008 at 06:52:51PM +0100, Klaus Kaempf wrote:
* Katarina Machalkova <kmachalkova@xxxxxxx> [Mar 19. 2008 16:12]:

But what would you, as the user (not sat-solver developer) expect, if you
saw
an option saying 'Update all packages in this list, if newer version is
available' ?
Wouldn't you want exactly that - mark packages for which a newer version
appeared on configured repositories in the meantime, as the candidates for
update?

Actually, no.

The distinction is between available and installable updates.

I might be interested in (all) available updates but those actually
installable are of much greater value.

And whats a normal desktop user (keep in mind, with PackageKit you
don't need to be root for updating your system) supposed to do with
update conflicts ?
I don't think she's able to decide between updating foo or bar.
The solver, together with the policies defined by the admin, is the
right place for such decisions.

There really needs to be a "run full blown YAST2 Online Update (after su)"
option in those PackageKit updaters.

Ciao, Marcus
--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups