Mailinglist Archive: yast-devel (191 mails)

< Previous Next >
Re: [yast-devel] Package-Bindings
  • From: Klaus Kaempf <kkaempf@xxxxxxx>
  • Date: Wed, 19 Mar 2008 18:52:51 +0100
  • Message-id: <20080319175251.GA3682@xxxxxxxxxxxxx>
* Katarina Machalkova <kmachalkova@xxxxxxx> [Mar 19. 2008 16:12]:

But what would you, as the user (not sat-solver developer) expect, if you saw
an option saying 'Update all packages in this list, if newer version is
available' ?
Wouldn't you want exactly that - mark packages for which a newer version
appeared on configured repositories in the meantime, as the candidates for
update?

Actually, no.

The distinction is between available and installable updates.

I might be interested in (all) available updates but those actually
installable are of much greater value.

And whats a normal desktop user (keep in mind, with PackageKit you
don't need to be root for updating your system) supposed to do with
update conflicts ?
I don't think she's able to decide between updating foo or bar.
The solver, together with the policies defined by the admin, is the
right place for such decisions.

Again, I'm talking about the default case. This doesn't exclude an
'show all available updates' mode in the frontend tools.

Klaus
---
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG N├╝rnberg)

--
To unsubscribe, e-mail: yast-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: yast-devel+help@xxxxxxxxxxxx

< Previous Next >