Mailinglist Archive: yast-devel (191 mails)

< Previous Next >
Re: [yast-devel] Package-Bindings
  • From: Katarina Machalkova <kmachalkova@xxxxxxx>
  • Date: Wed, 19 Mar 2008 16:12:32 +0100
  • Message-id: <200803191612.37375.kmachalkova@xxxxxxx>
Be aware that 'newer edition available' is *not* the correct criterium
for update in the future.
The selection of packagages eligible for update is a (sat-)solver
function, taking solver policies and conflict resolution into account.

But what would you, as the user (not sat-solver developer) expect, if you saw
an option saying 'Update all packages in this list, if newer version is
available' ?
Wouldn't you want exactly that - mark packages for which a newer version
appeared on configured repositories in the meantime, as the candidates for
update?

Of course, solver might not respect your decision ("Hey, I won't update this
package for you"), just as it not always respects your decision if you mark
package for update manually.

frozenB.
--
\\\\\ Katarina Machalkova
\\\\\\\__o YaST developer
__\\\\\\\'/_ & hedgehog painter
< Previous Next >