Mailinglist Archive: yast-commit (1998 mails)

< Previous Next >
[yast-commit] Build failed in Jenkins: yast-cio-master #3
  • From: admin@xxxxxxxxxxxx
  • Date: Fri, 20 Apr 2018 01:51:50 +0000 (UTC)
  • Message-id: <2128726410.1.1524189110855.JavaMail.jenkins@ci-opensuse>
See <http://ci.opensuse.org/job/yast-cio-master/3/display/redirect?page=changes>

Changes:

[Josef Reidinger] make package s390 only

[Josef Reidinger] changes

[Josef Reidinger] workaround build in travis

------------------------------------------
[...truncated 23.56 KB...]
[ 14s] [33/212] keeping libnghttp2-14-1.31.1-1.1
[ 14s] [34/212] keeping libnpth0-1.5-2.1
[ 14s] [35/212] keeping libpcre1-8.41-4.1
[ 14s] [36/212] keeping libpopt0-1.16-30.1
[ 14s] [37/212] keeping libruby2_5-2_5-2.5.0-4.1
[ 14s] [38/212] keeping libsasl2-3-2.1.26-17.1
[ 14s] [39/212] keeping libsepol1-2.6-1.4
[ 14s] [40/212] keeping libsmartcols1-2.31.1-3.1
[ 14s] [41/212] keeping libsqlite3-0-3.23.1-1.1
[ 14s] [42/212] keeping libudev-mini1-237-3.1
[ 14s] [43/212] keeping libunistring2-0.9.9-2.1
[ 14s] [44/212] keeping libustr-1_0-1-1.0.4-35.1
[ 14s] [45/212] keeping libuuid1-2.31.1-3.1
[ 14s] [46/212] keeping libverto1-0.2.6-7.1
[ 14s] [47/212] keeping libx86emu1-1.12-1.3
[ 14s] [48/212] keeping libyaml-0-2-0.1.7-1.1
[ 14s] [49/212] keeping libz1-1.2.11-3.9
[ 14s] [50/212] keeping patch-2.7.6-1.1
[ 14s] [51/212] keeping perl-base-5.26.1-5.1
[ 14s] [52/212] keeping pkg-config-0.29.2-2.1
[ 14s] [53/212] keeping brp-extract-appdata-2016.05.04-2.1
[ 14s] [54/212] keeping build-mkbaselibs-20180329-1.1
[ 14s] [55/212] keeping attr-2.4.47-8.1
[ 14s] [56/212] keeping libacl1-2.2.52-13.6
[ 14s] [57/212] keeping libassuan0-2.5.1-2.1
[ 14s] [58/212] keeping libblkid1-2.31.1-3.1
[ 14s] [59/212] keeping libgcrypt20-1.8.2-3.1
[ 14s] [60/212] cumulate libglib-2_0-0-2.56.1-1.1
[ 14s] [61/212] keeping libidn2-0-2.0.4-1.3
[ 14s] [62/212] keeping libisl19-0.19-1.1
[ 14s] [63/212] keeping libjemalloc2-5.0.1-2.1
[ 14s] [64/212] keeping libksba8-1.3.5-2.1
[ 14s] [65/212] deleting unwanted liblsan0-8.0.1+r258445-1.9
[ 14s] cumulate liblsan0-8.0.1+r258445-1.10
[ 14s] [66/212] keeping libmpfr6-4.0.1-1.1
[ 14s] [67/212] keeping libopenssl1_1-1.1.0h-1.1
[ 14s] [68/212] keeping libp11-kit0-0.23.2-3.1
[ 14s] [69/212] keeping libselinux1-2.6-2.1
[ 14s] [70/212] deleting unwanted libstdc++6-8.0.1+r258445-1.9
[ 14s] cumulate libstdc++6-8.0.1+r258445-1.10
[ 14s] [71/212] keeping libsystemd0-mini-237-3.1
[ 14s] [72/212] deleting unwanted libtsan0-8.0.1+r258445-1.9
[ 14s] cumulate libtsan0-8.0.1+r258445-1.10
[ 14s] [73/212] keeping libusb-1_0-0-1.0.22-1.1
[ 14s] [74/212] keeping libhogweed4-3.4-2.1
[ 14s] [75/212] keeping libkmod2-25-4.1
[ 14s] [76/212] keeping libmagic1-5.32-6.1
[ 14s] [77/212] keeping libxml2-2-2.9.8-2.1
[ 14s] [78/212] keeping libzio1-1.06-3.1
[ 14s] [79/212] keeping file-5.32-6.1
[ 14s] [80/212] keeping libaugeas0-1.10.1-1.1
[ 14s] [81/212] keeping libasan4-7.3.1+r258812-2.1
[ 14s] [82/212] keeping libcilkrts5-7.3.1+r258812-2.1
[ 14s] [83/212] keeping libdb-4_8-4.8.30-36.1
[ 14s] [84/212] keeping libfdisk1-2.31.1-3.1
[ 14s] [85/212] keeping libldap-2_4-2-2.4.46-32.1
[ 14s] [86/212] keeping libmodman1-2.0.1-18.1
[ 14s] [87/212] keeping libmount1-2.31.1-3.1
[ 14s] [88/212] keeping libmpc3-1.1.0-1.1
[ 14s] [89/212] keeping libpsl5-0.20.1-1.1
[ 14s] [90/212] keeping libubsan0-7.3.1+r258812-2.1
[ 14s] [91/212] keeping libyui8-3.4.0-2.9
[ 14s] [92/212] keeping libboost_system1_66_0-1.66.0-3.1
[ 14s] [93/212] keeping libsemanage1-2.6-1.4
[ 14s] [94/212] keeping libproxy1-0.4.15-2.1
[ 14s] [95/212] keeping libboost_thread1_66_0-1.66.0-3.1
[ 14s] [96/212] keeping cpp7-7.3.1+r258812-2.1
[ 14s] [97/212] keeping perl-5.26.1-5.1
[ 14s] [98/212] keeping brp-check-suse-84.87+git20170602.cec5415-1.3
[ 14s] [99/212] keeping perl-XML-NamespaceSupport-1.12-1.3
[ 14s] [100/212] keeping perl-XML-SAX-Base-1.09-1.4
[ 14s] [101/212] cumulate perl-XML-Writer-0.625-1.6
[ 14s] [102/212] keeping perl-gettext-1.07-1.16
[ 14s] [103/212] keeping perl-XML-Parser-2.44-1.110
[ 14s] [104/212] keeping perl-XML-SAX-1.00-1.1
[ 14s] [105/212] keeping perl-XML-SAX-Expat-0.51-3.6
[ 14s] [106/212] keeping perl-XML-Simple-2.25-1.1
[ 14s] [107/212] keeping terminfo-base-6.1-5.1
[ 14s] [108/212] keeping libelf1-0.170-2.1
[ 14s] [109/212] keeping dwz-0.12-5.1
[ 14s] [110/212] keeping libebl-plugins-0.170-2.1
[ 14s] [111/212] keeping libncurses6-6.1-5.1
[ 14s] [112/212] keeping libdw1-0.170-2.1
[ 14s] [113/212] keeping libreadline7-7.0-1.1
[ 14s] [114/212] keeping ncurses-utils-6.1-5.1
[ 14s] [115/212] keeping bash-4.4-104.1
[ 14s] [116/212] keeping augeas-1.10.1-1.1
[ 14s] [117/212] keeping cpp-7-2.9
[ 14s] [118/212] keeping bzip2-1.0.6-41.1
[ 14s] [119/212] keeping cracklib-2.9.6-2.1
[ 14s] [120/212] keeping hwinfo-21.52-1.1
[ 14s] [121/212] keeping xz-5.2.3-5.1
[ 14s] [122/212] keeping info-6.5-4.1
[ 14s] [123/212] keeping iproute2-4.16-1.1
[ 14s] [124/212] keeping yast2-core-4.0.2-3.7
[ 14s] [125/212] keeping cpio-2.12-4.10
[ 14s] [126/212] keeping diffutils-3.6-2.1
[ 14s] [127/212] keeping gzip-1.9-2.1
[ 14s] [128/212] keeping libcrack2-2.9.6-2.1
[ 14s] [129/212] cumulate m4-1.4.18-3.4
[ 14s] [130/212] keeping make-4.2.1-5.1
[ 14s] [131/212] keeping which-2.21-4.1
[ 14s] [132/212] keeping findutils-4.6.0-3.1
[ 14s] [133/212] keeping gettext-runtime-mini-0.19.8.1-5.3
[ 14s] [134/212] keeping grep-3.1-2.1
[ 14s] [135/212] keeping libtasn1-4.13-2.1
[ 14s] [136/212] keeping tar-1.29-5.6
[ 14s] [137/212] keeping sed-4.5-2.1
[ 14s] [138/212] keeping yast2-ycp-ui-bindings-4.0.0-2.3
[ 14s] [139/212] keeping coreutils-8.29-2.1
[ 14s] [140/212] keeping systemd-rpm-macros-3-13.1
[ 14s] [141/212] keeping libtasn1-6-4.13-2.1
[ 14s] [142/212] keeping linux-glibc-devel-4.16-1.1
[ 14s] [143/212] keeping glibc-locale-2.27-4.1
[ 14s] [144/212] keeping update-alternatives-1.19.0.4-2.1
[ 14s] [145/212] cumulate autoconf-2.69-15.11
[ 14s] [146/212] keeping gettext-tools-mini-0.19.8.1-5.3
[ 14s] [147/212] keeping yast2-perl-bindings-4.0.1-1.5
[ 14s] [148/212] keeping permissions-20180125-1.1
[ 14s] [149/212] keeping krb5-mini-1.15.2-4.4
[ 14s] [150/212] keeping ruby2.5-stdlib-2.5.0-4.1
[ 14s] [151/212] keeping rpm-4.14.1-5.1
[ 14s] [152/212] keeping glibc-devel-2.27-4.1
[ 14s] [153/212] keeping libtirpc3-1.0.3-1.1
[ 14s] [154/212] cumulate automake-1.15.1-3.1
[ 14s] [155/212] keeping gawk-4.2.1-1.3
[ 14s] [156/212] keeping libssh4-0.7.5-5.1
[ 14s] [157/212] keeping binutils-2.30-4.1
[ 14s] [158/212] keeping ruby2.5-2.5.0-4.1
[ 14s] [159/212] keeping libgnutls30-3.6.2-3.1
[ 14s] [160/212] keeping rpmlint-mini-1.10-5.11
[ 14s] [161/212] keeping libsolv-tools-0.6.34-1.1
[ 14s] [162/212] keeping rpmlint-Factory-1.0-93.1
[ 14s] [163/212] keeping ruby-2.5-1.1
[ 14s] [164/212] keeping ruby2.5-rubygem-abstract_method-1.2.1-2.8
[ 14s] [165/212] keeping ruby2.5-rubygem-fast_gettext-1.6.0-1.3
[ 14s] [166/212] cumulate ruby2.5-rubygem-rspec-support-3.7.1-1.1
[ 14s] [167/212] keeping libnsl2-1.2.0-2.1
[ 14s] [168/212] cumulate ruby2.5-rubygem-packaging_rake_tasks-1.4.4-53.4
[ 14s] [169/212] cumulate ruby2.5-rubygem-diff-lcs-1.3-1.8
[ 14s] [170/212] keeping ruby2.5-rubygem-gem2rpm-0.10.1-13.4
[ 14s] [171/212] keeping ruby2.5-rubygem-unf_ext-0.0.7.5-10.3
[ 14s] [172/212] keeping ruby2.5-rubygem-ruby-augeas-0.5.0-3.8
[ 14s] [173/212] cumulate yast2-buildtools-4.0.5-1.1
[ 14s] [174/212] keeping build-compare-20171204T112209.f06fbac-1.2
[ 14s] [175/212] keeping libcurl4-7.59.0-1.1
[ 14s] [176/212] keeping sysconfig-0.84.2-2.1
[ 14s] [177/212] keeping gpg2-2.2.6-1.1
[ 14s] [178/212] keeping gcc7-7.3.1+r258812-2.1
[ 14s] [179/212] keeping gcc-7-2.9
[ 14s] [180/212] keeping ruby2.5-rubygem-cfa-0.6.3-19.3
[ 14s] [181/212] keeping ruby2.5-rubygem-cheetah-0.5.0-1.8
[ 14s] [182/212] cumulate ruby2.5-rubygem-rspec-expectations-3.7.0-1.3
[ 14s] [183/212] cumulate ruby2.5-rubygem-rspec-mocks-3.7.0-1.3
[ 14s] [184/212] keeping ruby2.5-rubygem-unf-0.1.4-6.17
[ 14s] [185/212] cumulate ruby2.5-rubygem-yast-rake-0.2.21-1.1
[ 14s] [186/212] keeping libgpgme11-1.10.0-3.1
[ 14s] [187/212] cumulate ruby2.5-rubygem-rspec-core-3.7.1-1.1
[ 14s] [188/212] cumulate yast2-devtools-4.0.5-1.1
[ 14s] [189/212] keeping pam-1.3.0-7.1
[ 14s] [190/212] keeping yast2-ruby-bindings-4.0.6-1.1
[ 14s] [191/212] keeping gcc-PIE-7-2.9
[ 14s] [192/212] keeping ruby2.5-rubygem-simpleidn-0.1.1-1.1
[ 14s] [193/212] cumulate ruby2.5-rubygem-rspec-3.7.0-1.3
[ 14s] [194/212] keeping yast2-hardware-detection-4.0.0-1.1
[ 14s] [195/212] keeping systemd-mini-237-3.1
[ 14s] [196/212] keeping shadow-4.5-8.1
[ 14s] [197/212] keeping libzypp-17.3.0-1.1
[ 14s] [198/212] keeping sysuser-shadow-2.0-2.4
[ 14s] [199/212] keeping yast2-pkg-bindings-4.0.9-1.8
[ 14s] [200/212] keeping util-linux-systemd-2.31.1-3.1
[ 14s] [201/212] keeping sysconfig-netconfig-0.84.2-2.1
[ 14s] [202/212] keeping system-group-hardware-20170617-6.1
[ 14s] [203/212] keeping yast2-4.0.71-1.1
[ 14s] [204/212] keeping libutempter0-1.1.6-10.1
[ 14s] [205/212] keeping util-linux-2.31.1-3.1
[ 14s] [206/212] keeping ruby-common-2.1-12.1
[ 14s] [207/212] keeping aaa_base-84.87+git20180409.04c9dae-1.1
[ 14s] [208/212] keeping rpm-build-4.14.1-5.1
[ 14s] [209/212] keeping aaa_base-malloccheck-84.87+git20180409.04c9dae-1.1
[ 14s] [210/212] cumulate desktop-file-utils-0.23-4.1
[ 14s] [211/212] cumulate update-desktop-files-84.87-1.1
[ 14s] [212/212] keeping post-build-checks-84.87+git20180412.b38aed4-1.1
[ 14s] now installing cumulated packages
[ 14s] Preparing...
########################################
[ 14s] Updating / installing...
[ 14s]
ruby2.5-rubygem-rspec-support-3.7.1-1.########################################
[ 14s] libgcc_s1-8.0.1+r258445-1.10
########################################
[ 14s] ruby2.5-rubygem-diff-lcs-1.3-1.8
########################################
[ 14s] update-alternatives: using /usr/bin/htmldiff.ruby2.5-1.3 to provide
/usr/bin/htmldiff (htmldiff) in auto mode
[ 15s] update-alternatives: using /usr/bin/htmldiff.ruby2.5-1.3 to provide
/usr/bin/htmldiff-1.3 (htmldiff-1.3) in auto mode
[ 15s] update-alternatives: using /usr/bin/htmldiff.ruby2.5-1.3 to provide
/usr/bin/htmldiff.ruby2.5 (htmldiff.ruby2.5) in auto mode
[ 15s] update-alternatives: using /usr/bin/ldiff.ruby2.5-1.3 to provide
/usr/bin/ldiff (ldiff) in auto mode
[ 15s] update-alternatives: using /usr/bin/ldiff.ruby2.5-1.3 to provide
/usr/bin/ldiff-1.3 (ldiff-1.3) in auto mode
[ 15s] update-alternatives: using /usr/bin/ldiff.ruby2.5-1.3 to provide
/usr/bin/ldiff.ruby2.5 (ldiff.ruby2.5) in auto mode
[ 15s]
ruby2.5-rubygem-rspec-expectations-3.7########################################
[ 15s] ruby2.5-rubygem-rspec-mocks-3.7.0-1.3
########################################
[ 15s] ruby2.5-rubygem-rspec-core-3.7.1-1.1
########################################
[ 15s] update-alternatives: using /usr/bin/rspec.ruby2.5-3.7.1 to provide
/usr/bin/rspec (rspec) in auto mode
[ 16s] update-alternatives: using /usr/bin/rspec.ruby2.5-3.7.1 to provide
/usr/bin/rspec-3.7.1 (rspec-3.7.1) in auto mode
[ 16s] update-alternatives: using /usr/bin/rspec.ruby2.5-3.7.1 to provide
/usr/bin/rspec.ruby2.5 (rspec.ruby2.5) in auto mode
[ 16s]
ruby2.5-rubygem-packaging_rake_tasks-1########################################
[ 16s] m4-1.4.18-3.4
########################################
[ 16s] autoconf-2.69-15.11
########################################
[ 16s] automake-1.15.1-3.1
########################################
[ 24s] perl-XML-Writer-0.625-1.6
########################################
[ 24s] yast2-buildtools-4.0.5-1.1
########################################
[ 24s] libglib-2_0-0-2.56.1-1.1
########################################
[ 24s] desktop-file-utils-0.23-4.1
########################################
[ 24s] update-desktop-files-84.87-1.1
########################################
[ 24s] yast2-devtools-4.0.5-1.1
########################################
[ 25s] ruby2.5-rubygem-yast-rake-0.2.21-1.1
########################################
[ 25s] ruby2.5-rubygem-rspec-3.7.0-1.3
########################################
[ 25s] liblsan0-8.0.1+r258445-1.10
########################################
[ 25s] libstdc++6-8.0.1+r258445-1.10
########################################
[ 25s] libtsan0-8.0.1+r258445-1.10
########################################
[ 25s] libmpxwrappers2-8.0.1+r258445-1.10
########################################
[ 25s] libmpx2-8.0.1+r258445-1.10
########################################
[ 25s] libitm1-8.0.1+r258445-1.10
########################################
[ 25s] libgomp1-8.0.1+r258445-1.10
########################################
[ 25s] libatomic1-8.0.1+r258445-1.10
########################################
[ 26s] kernel-obs-build-4.16.2-1.7
########################################
[ 26s] removing nis flags from
/var/tmp/build-root-openSUSE_Factory/etc/nsswitch.conf...
[ 26s] now finalizing build dir...
[ 27s] -----------------------------------------------------------------
[ 27s] I have the following modifications for yast2-cio.spec:
[ 27s] 28c28
[ 27s] < Release: 0
[ 27s] ---
[ 27s] > Release: 1
[ 27s] -----------------------------------------------------------------
[ 27s] ----- building yast2-cio.spec (user abuild)
[ 27s] -----------------------------------------------------------------
[ 27s] -----------------------------------------------------------------
[ 27s] + exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --nosignature
/home/abuild/rpmbuild/SOURCES/yast2-cio.spec
[ 27s] error: Architecture is not included: x86_64
[ 27s]
[ 27s] yast-jenkins failed "build yast2-cio.spec" at Fri Apr 20 01:51:50 UTC
2018.
[ 27s]

The buildroot was: /var/tmp/build-root-openSUSE_Factory
rm -rf YaST:Head
rake aborted!
Command failed with status (1): [yes | osc -A 'https://api.opensuse.org/' b...]

Tasks: TOP => osc:sr => osc:commit => osc:build
(See full trace by running task with --trace)
cleaning
Build step 'Execute shell' marked build as failure

< Previous Next >
This Thread
Follow Ups