Mailinglist Archive: yast-commit (618 mails)

< Previous Next >
[yast-commit] Build failed in Jenkins: yast-system-role-ha-master #2
  • From: jenkins@xxxxxxx
  • Date: Wed, 28 Feb 2018 15:25:45 +0000 (UTC)
  • Message-id: <1108153098.272.1519831545851.JavaMail.jenkins@ci>
See <https://ci.suse.de/job/yast-system-role-ha-master/2/display/redirect>

------------------------------------------
[...truncated 9.66 KB...]
[ 2s] deleting libidn2-0
[ 2s] deleting libldap-2_4-2
[ 2s] deleting libnghttp2-14
[ 2s] deleting libopenssl1_1_0
[ 2s] deleting libpsl5
[ 2s] deleting libpython3_6m1_0
[ 2s] deleting librhash0
[ 2s] deleting libsasl2-3
[ 2s] deleting libssh2-1
[ 2s] deleting libstdc++-devel
[ 2s] deleting libstdc++6-devel-gcc7
[ 2s] deleting libunistring2
[ 2s] deleting libuv1
[ 2s] deleting libyui-devel
[ 2s] deleting libyui8
[ 2s] deleting ncurses-devel
[ 2s] deleting pkg-config
[ 3s] deleting python-rpm-macros
[ 3s] deleting python3-base
[ 3s] [1/121] keeping file-magic-5.32-4.7
[ 3s] [2/121] keeping kernel-obs-build-4.12.14-13.5
[ 3s] [3/121] keeping libtirpc-netconfig-1.0.2-1.86
[ 3s] [4/121] keeping system-user-root-20170617-1.433
[ 3s] [5/121] keeping terminfo-base-6.1-1.6
[ 3s] [6/121] cumulate yast2-installation-control-4.0.9-2.1
[ 3s] [7/121] keeping filesystem-15.0-5.1
[ 3s] [8/121] keeping glibc-2.26-7.3
[ 3s] [9/121] keeping fillup-1.42-2.4
[ 3s] [10/121] keeping libatomic1-7.3.0+r257042-1.9
[ 3s] [11/121] keeping libattr1-2.4.47-1.389
[ 3s] [12/121] keeping libaudit1-2.8.1-2.7
[ 3s] [13/121] keeping libbz2-1-1.0.6-2.115
[ 3s] [14/121] keeping libcap-ng0-0.7.8-1.474
[ 3s] [15/121] keeping libcap2-2.25-1.382
[ 3s] [16/121] keeping libcom_err2-1.43.8-2.7
[ 3s] [17/121] keeping libexpat1-2.2.5-1.98
[ 3s] [18/121] keeping libgcc_s1-7.3.0+r257042-1.9
[ 3s] [19/121] keeping libgdbm4-1.12-1.377
[ 3s] [20/121] keeping libgmp10-6.1.2-1.350
[ 3s] [21/121] keeping libgomp1-7.3.0+r257042-1.9
[ 3s] [22/121] keeping libitm1-7.3.0+r257042-1.9
[ 3s] [23/121] keeping libkeyutils1-1.5.10-2.114
[ 3s] [24/121] keeping liblua5_3-5-5.3.4-1.38
[ 3s] [25/121] keeping liblzma5-5.2.3-1.426
[ 3s] [26/121] keeping libmpx2-7.3.0+r257042-1.9
[ 3s] [27/121] keeping libmpxwrappers2-7.3.0+r257042-1.9
[ 3s] [28/121] keeping libpcre1-8.41-3.89
[ 3s] [29/121] keeping libpopt0-1.16-2.116
[ 3s] [30/121] keeping libsepol1-2.6-1.111
[ 3s] [31/121] keeping libsmartcols1-2.31.1-2.3
[ 3s] [32/121] keeping libustr-1_0-1-1.0.4-1.387
[ 3s] [33/121] keeping libuuid1-2.31.1-2.3
[ 3s] [34/121] keeping libverto1-0.2.6-2.116
[ 3s] [35/121] keeping libz1-1.2.11-1.380
[ 3s] [36/121] keeping patch-2.7.5-1.426
[ 3s] [37/121] keeping perl-base-5.26.1-4.6
[ 3s] [38/121] keeping brp-extract-appdata-2016.05.04-1.9
[ 3s] [39/121] keeping build-mkbaselibs-20180209-1.2
[ 3s] [40/121] keeping attr-2.4.47-1.389
[ 3s] [41/121] keeping libacl1-2.2.52-2.105
[ 3s] [42/121] keeping libasan4-7.3.0+r257042-1.9
[ 3s] [43/121] keeping libblkid1-2.31.1-2.3
[ 3s] [44/121] keeping libisl15-0.18-1.402
[ 3s] [45/121] keeping liblsan0-7.3.0+r257042-1.9
[ 3s] [46/121] keeping libmpfr6-4.0.1-1.5
[ 3s] [47/121] keeping libselinux1-2.6-1.92
[ 3s] [48/121] keeping libstdc++6-7.3.0+r257042-1.9
[ 3s] [49/121] keeping libtsan0-7.3.0+r257042-1.9
[ 3s] [50/121] keeping libmagic1-5.32-4.7
[ 3s] [51/121] keeping libxml2-2-2.9.7-1.8
[ 3s] [52/121] keeping libzio1-1.06-1.7
[ 3s] [53/121] keeping file-5.32-4.7
[ 3s] [54/121] keeping libcilkrts5-7.3.0+r257042-1.9
[ 3s] [55/121] keeping libdb-4_8-4.8.30-4.11
[ 3s] [56/121] keeping libfdisk1-2.31.1-2.3
[ 3s] [57/121] keeping libmount1-2.31.1-2.3
[ 3s] [58/121] keeping libmpc3-1.1.0-1.6
[ 3s] [59/121] keeping libubsan0-7.3.0+r257042-1.9
[ 3s] [60/121] keeping libncurses6-6.1-1.6
[ 3s] [61/121] keeping libsemanage1-2.6-1.101
[ 3s] [62/121] keeping libreadline7-7.0-5.5
[ 3s] [63/121] keeping ncurses-utils-6.1-1.6
[ 3s] [64/121] keeping cpp7-7.3.0+r257042-1.9
[ 3s] [65/121] keeping perl-5.26.1-4.6
[ 3s] [66/121] keeping brp-check-suse-84.87+git20170602.cec5415-1.9
[ 3s] [67/121] keeping bash-4.4-5.5
[ 3s] [68/121] cumulate libxml2-tools-2.9.7-1.8
[ 3s] [69/121] keeping cpp-7-1.522
[ 3s] [70/121] keeping bzip2-1.0.6-2.115
[ 3s] [71/121] keeping xz-5.2.3-1.426
[ 3s] [72/121] keeping info-6.5-2.7
[ 3s] [73/121] keeping iproute2-4.12-3.13
[ 3s] [74/121] keeping cpio-2.12-1.398
[ 3s] [75/121] keeping diffutils-3.6-1.13
[ 3s] [76/121] keeping gzip-1.9-1.11
[ 3s] [77/121] keeping make-4.2.1-5.7
[ 3s] [78/121] keeping which-2.21-1.446
[ 3s] [79/121] keeping findutils-4.6.0-1.235
[ 3s] [80/121] keeping gettext-runtime-mini-0.19.8.1-2.83
[ 3s] [81/121] keeping grep-3.1-1.54
[ 3s] [82/121] keeping tar-1.29-1.17
[ 3s] [83/121] keeping sed-4.4-1.39
[ 3s] [84/121] keeping coreutils-8.29-1.3
[ 3s] [85/121] keeping systemd-rpm-macros-3-5.1
[ 3s] [86/121] keeping linux-glibc-devel-4.15-1.6
[ 3s] [87/121] keeping glibc-locale-2.26-7.3
[ 3s] [88/121] keeping update-alternatives-1.19.0.4-2.7
[ 3s] [89/121] keeping gettext-tools-mini-0.19.8.1-2.83
[ 3s] [90/121] keeping permissions-20180125-1.2
[ 3s] [91/121] keeping krb5-mini-1.15.2-4.72
[ 3s] [92/121] keeping glibc-devel-2.26-7.3
[ 3s] [93/121] keeping libtirpc3-1.0.2-1.86
[ 3s] [94/121] keeping gawk-4.2.0-1.102
[ 3s] [95/121] keeping binutils-2.29.1-4.6
[ 3s] [96/121] keeping libnsl2-1.2.0-2.2
[ 3s] [97/121] keeping gcc7-7.3.0+r257042-1.9
[ 3s] [98/121] keeping gcc-7-1.522
[ 3s] [99/121] keeping hostname-3.16-2.8
[ 3s] [100/121] keeping gcc-PIE-7-1.522
[ 3s] [101/121] keeping libcrack2-2.9.6-1.117
[ 3s] [102/121] keeping libelf1-0.168-2.122
[ 3s] [103/121] keeping dwz-0.12-1.442
[ 3s] [104/121] keeping cracklib-2.9.6-1.117
[ 3s] [105/121] keeping libebl-plugins-0.168-2.122
[ 3s] [106/121] keeping libdw1-0.168-2.122
[ 3s] [107/121] keeping pam-1.3.0-2.83
[ 3s] [108/121] keeping pam-modules-12.1-3.2
[ 3s] [109/121] keeping shadow-4.5-4.96
[ 3s] [110/121] keeping rpm-4.14.1-3.3
[ 3s] [111/121] keeping sysuser-shadow-2.0-2.110
[ 3s] [112/121] keeping rpmlint-mini-1.10-3.14
[ 3s] [113/121] keeping build-compare-20171204T112209.f06fbac-1.20
[ 3s] [114/121] keeping rpmlint-Factory-1.0-3.5
[ 3s] [115/121] keeping system-group-hardware-20170617-4.114
[ 3s] [116/121] keeping libutempter0-1.1.6-2.126
[ 3s] [117/121] keeping util-linux-2.31.1-2.3
[ 3s] [118/121] keeping aaa_base-84.87+git20180208.8eeab90-1.1
[ 3s] [119/121] keeping rpm-build-4.14.1-3.3
[ 3s] [120/121] keeping aaa_base-malloccheck-84.87+git20180208.8eeab90-1.1
[ 3s] [121/121] keeping post-build-checks-84.87+git20171221.9eed556-1.2
[ 3s] now installing cumulated packages
[ 3s] Preparing...
########################################
[ 3s] Updating / installing...
[ 3s] libxml2-tools-2.9.7-1.8
########################################
[ 3s] yast2-installation-control-4.0.9-2.1
########################################
[ 3s] removing nis flags from
/var/tmp/build-root-SUSE_SLE-15_GA/etc/nsswitch.conf...
[ 3s] now finalizing build dir...
[ 3s] -----------------------------------------------------------------
[ 3s] I have the following modifications for system-role-ha.spec:
[ 3s] 39c39
[ 3s] < Release: 0
[ 3s] ---
[ 3s] > Release: 1
[ 3s] -----------------------------------------------------------------
[ 3s] ----- building system-role-ha.spec (user abuild)
[ 3s] -----------------------------------------------------------------
[ 3s] -----------------------------------------------------------------
[ 4s] + exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --nosignature
--define '_build_create_debug 1'
/home/abuild/rpmbuild/SOURCES/system-role-ha.spec
[ 4s] warning: line 45: Invalid version (double separator '-'):
system-role-ha: Provides: installer_module_extension() = system-role-ha
[ 4s] setting SOURCE_DATE_EPOCH=1519819200
[ 4s] Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.GASiMZ
[ 4s] + umask 022
[ 4s] + cd /home/abuild/rpmbuild/BUILD
[ 4s] + cd /home/abuild/rpmbuild/BUILD
[ 4s] + rm -rf system-role-ha-15.0.2
[ 4s] + /usr/bin/bzip2 -dc
/home/abuild/rpmbuild/SOURCES/system-role-ha-15.0.2.tar.bz2
[ 4s] + /usr/bin/tar -xvvof -
[ 4s] -rw-r--r-- root/root 3708 2018-02-28 15:18
system-role-ha-15.0.2/CONTRIBUTING.md
[ 4s] drwxr-xr-x Creating directory: system-role-ha-15.0.2
[ 4s] -rw-r--r-- root/root 41 2018-02-28 15:18
system-role-ha-15.0.2/Dockerfile
[ 4s] -rw-r--r-- root/root 1075 2018-02-28 15:18
system-role-ha-15.0.2/LICENSE
[ 4s] -rw-r--r-- root/root 27 2018-02-28 15:18
system-role-ha-15.0.2/POTFILES
[ 4s] -rw-r--r-- root/root 285 2018-02-28 15:18
system-role-ha-15.0.2/README.md
[ 4s] -rw-r--r-- root/root 15 2018-02-28 15:18
system-role-ha-15.0.2/RPMNAME
[ 4s] -rw-r--r-- root/root 134 2018-02-28 15:18
system-role-ha-15.0.2/Rakefile
[ 4s] -rw-r--r-- root/root 178 2018-02-28 15:18
system-role-ha-15.0.2/control/Makefile
[ 4s] drwxr-xr-x Creating directory:
system-role-ha-15.0.2/control
[ 4s] -rw-r--r-- root/root 165 2018-02-28 15:18
system-role-ha-15.0.2/control/README.md
[ 4s] lrwxrwxrwx root/root 0 2018-02-28 15:18
system-role-ha-15.0.2/control/installation.glade -> installation.xml
[ 4s] -rw-r--r-- root/root 3148 2018-02-28 15:18
system-role-ha-15.0.2/control/installation.xml
[ 4s] -rw-r--r-- root/root 219 2018-02-28 15:18
system-role-ha-15.0.2/package/system-role-ha.changes
[ 4s] drwxr-xr-x Creating directory:
system-role-ha-15.0.2/package
[ 4s] -rw-r--r-- root/root 2330 2018-02-28 15:18
system-role-ha-15.0.2/package/system-role-ha.spec
[ 4s] + STATUS=0
[ 4s] + '[' 0 -ne 0 ']'
[ 4s] + cd system-role-ha-15.0.2
[ 4s] + /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
[ 4s] + exit 0
[ 4s] Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.BL1srN
[ 4s] + umask 022
[ 4s] + cd /home/abuild/rpmbuild/BUILD
[ 4s] + cd system-role-ha-15.0.2
[ 4s] + mkdir -p
/home/abuild/rpmbuild/BUILDROOT/system-role-ha-15.0.2-1.x86_64
[ 4s] + install -m 644 control/installation.xml
/home/abuild/rpmbuild/BUILDROOT/system-role-ha-15.0.2-1.x86_64/
[ 4s] + mkdir -p
/home/abuild/rpmbuild/BUILDROOT/system-role-ha-15.0.2-1.x86_64//usr/share/doc/packages/system-role-ha
[ 4s] + install -m 644 LICENSE
/home/abuild/rpmbuild/BUILDROOT/system-role-ha-15.0.2-1.x86_64//usr/share/doc/packages/system-role-ha
[ 4s] + /usr/lib/rpm/find-debuginfo.sh -j2 --build-id-seed 15.0.2-1
--unique-debug-suffix -15.0.2-1.x86_64 --unique-debug-src-base
system-role-ha-15.0.2-1.x86_64 --run-dwz --dwz-low-mem-die-limit 10000000
--dwz-max-die-limit 50000000 -S debugsourcefiles.list
/home/abuild/rpmbuild/BUILD/system-role-ha-15.0.2
[ 4s] + /usr/lib/rpm/brp-compress
[ 4s] + /usr/lib/rpm/brp-suse
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-05-permissions
[ 4s] setting / to root:root 0755. (wrong owner/group abuild:abuild)
[ 4s] setting /usr/ to root:root 0755. (wrong owner/group abuild:abuild)
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-15-strip-debug
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-25-symlink
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-30-desktop
[ 4s] WARNING: '/usr/lib/rpm/brp-desktop.data/suse-screensavers.menu' does
not exist
[ 4s] WARNING: '/usr/lib/rpm/brp-desktop.data/applications-kmenuedit.menu'
does not exist
[ 4s] WARNING: '/usr/lib/rpm/brp-desktop.data/custom.menu' does not exist
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-35-rpath
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-40-rootfs
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-45-tcl
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-50-check-python
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-55-boot-scripts
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-60-hook
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-65-lib64-linux
[ 4s] calling /usr/lib/rpm/brp-suse.d/brp-72-extract-appdata
[ 4s] Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.MPPW4C
[ 4s] + umask 022
[ 4s] + cd /home/abuild/rpmbuild/BUILD
[ 4s] + cd system-role-ha-15.0.2
[ 4s] + make -C control check
[ 4s] make: Entering directory
'/home/abuild/rpmbuild/BUILD/system-role-ha-15.0.2/control'
[ 4s] xmllint --relaxng /usr/share/YaST2/control/control.rng --noout *.xml
[ 4s] Relax-NG validity error : Extra element system_roles in interleave
[ 4s] installation.xml:21: element system_roles: Relax-NG validity error :
Element update failed to validate content
[ 4s] Relax-NG validity error : Extra element update in interleave
[ 4s] installation.xml:20: element update: Relax-NG validity error : Element
productDefines failed to validate content
[ 4s] installation.xml fails to validate
[ 4s] make: *** [Makefile:4: check] Error 3
[ 4s] make: Leaving directory
'/home/abuild/rpmbuild/BUILD/system-role-ha-15.0.2/control'
[ 4s] error: Bad exit status from /var/tmp/rpm-tmp.MPPW4C (%check)
[ 4s]
[ 4s]
[ 4s] RPM build errors:
[ 4s] line 45: Invalid version (double separator '-'): system-role-ha:
Provides: installer_module_extension() = system-role-ha
[ 4s] Bad exit status from /var/tmp/rpm-tmp.MPPW4C (%check)
[ 4s]
[ 4s] yast-ci-worker-3 failed "build system-role-ha.spec" at Wed Feb 28
15:25:45 UTC 2018.
[ 4s]

The buildroot was: /var/tmp/build-root-SUSE_SLE-15_GA
rm -rf Devel:YaST:Head
rake aborted!
Command failed with status (1): [yes | osc -A 'https://api.suse.de/' build ...]

Tasks: TOP => osc:sr => osc:commit => osc:build
(See full trace by running task with --trace)
cleaning
Build step 'Execute shell' marked build as failure

< Previous Next >
List Navigation
This Thread
Follow Ups
References