Mailinglist Archive: yast-commit (619 mails)

< Previous Next >
[yast-commit] Build failed in Jenkins: yast-yast.github.io-master #47
  • From: admin@xxxxxxxxxxxx
  • Date: Tue, 13 Feb 2018 13:23:35 +0000 (UTC)
  • Message-id: <1533857286.25.1518528215086.JavaMail.jenkins@ci-opensuse>
See
<http://ci.opensuse.org/job/yast-yast.github.io-master/47/display/redirect?page=changes>

Changes:

[lslezak] Updated Jenkins documentation

[lslezak] Code review fixes

------------------------------------------
Started by GitHub push by lslezak
Started by GitHub push by lslezak
[EnvInject] - Loading node environment variables.
Building remotely on yast-jenkins-original (yast-jenkins) in workspace
<http://ci.opensuse.org/job/yast-yast.github.io-master/ws/>
git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
git config remote.origin.url https://github.com/yast/yast.github.io.git #
timeout=10
Fetching upstream changes from https://github.com/yast/yast.github.io.git
git --version # timeout=10
git fetch --tags --progress https://github.com/yast/yast.github.io.git
+refs/heads/*:refs/remotes/origin/*
git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 89ab2289e15d63f479fe8010c655cf6a7b728870 (origin/master)
git config core.sparsecheckout # timeout=10
git checkout -f 89ab2289e15d63f479fe8010c655cf6a7b728870
Commit message: "Merge pull request #145 from yast/jenkins_update"
git rev-list --no-walk bbacc6c9f2cd59c469fd7463528e516f4ba6eea2 # timeout=10
Cleaning workspace
git rev-parse --verify HEAD # timeout=10
Resetting working tree
git reset --hard # timeout=10
git clean -fdx # timeout=10
[yast-yast.github.io-master] $ /bin/sh -xe /tmp/jenkins1376744084043416126.sh
+ NOKOGIRI_USE_SYSTEM_LIBRARIES=1
+ bundle install --path .vendor/bundle
Fetching gem metadata from https://rubygems.org/................
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Resolving dependencies...
Installing rake 12.3.0
Installing concurrent-ruby 1.0.5
Installing minitest 5.11.3
Installing thread_safe 0.3.6
Installing public_suffix 2.0.5
Installing coffee-script-source 1.11.1
Installing execjs 2.7.0
Installing colorator 1.1.0
Installing ffi 1.9.21 with native extensions
Installing multipart-post 2.0.0
Installing forwardable-extended 2.6.0
Installing gemoji 3.0.0
Installing net-dns 0.8.0
Installing rb-fsevent 0.10.2
Installing kramdown 1.16.2
Installing liquid 4.0.0
Installing mercenary 0.3.6
Installing rouge 2.2.1
Installing safe_yaml 1.0.4
Installing mini_portile2 2.3.0
Installing jekyll-paginate 1.1.0
Installing rubyzip 1.2.1
Installing jekyll-swiss 0.4.0
Installing unicode-display_width 1.3.0
Installing rainbow 3.0.0
Installing raspell 1.3 with native extensions
Using bundler 1.13.6
Installing packaging_rake_tasks 1.4.4
Installing i18n 0.9.4
Installing tzinfo 1.2.5
Installing addressable 2.5.2
Installing coffee-script 2.4.1
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

/usr/bin/ruby.ruby2.1 extconf.rb
checking for ffi.h... no
checking for ffi.h in /usr/local/include,/usr/include/ffi... no
checking for shlwapi.h... no
checking for rb_thread_blocking_region()... yes
checking for rb_thread_call_with_gvl()... yes
checking for rb_thread_call_without_gvl()... yes
creating extconf.h
creating Makefile

make "DESTDIR=" clean

make "DESTDIR="
Running autoreconf for libffi
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
configure.ac:376: warning: AC_PROG_LD is m4_require'd but not m4_defun'd
acinclude.m4:251: LIBFFI_CHECK_LINKER_FEATURES is expanded from...
acinclude.m4:349: LIBFFI_ENABLE_SYMVERS is expanded from...
configure.ac:376: the top level
configure.ac:376: warning: AC_PROG_LD is m4_require'd but not m4_defun'd
acinclude.m4:251: LIBFFI_CHECK_LINKER_FEATURES is expanded from...
acinclude.m4:349: LIBFFI_ENABLE_SYMVERS is expanded from...
configure.ac:376: the top level
autoreconf: configure.ac: tracing
configure.ac:376: warning: AC_PROG_LD is m4_require'd but not m4_defun'd
acinclude.m4:251: LIBFFI_CHECK_LINKER_FEATURES is expanded from...
acinclude.m4:349: LIBFFI_ENABLE_SYMVERS is expanded from...
configure.ac:376: the top level
autoreconf: configure.ac: not using Libtool
autoreconf: running: /usr/bin/autoconf --force
configure.ac:376: warning: AC_PROG_LD is m4_require'd but not m4_defun'd
acinclude.m4:251: LIBFFI_CHECK_LINKER_FEATURES is expanded from...
acinclude.m4:349: LIBFFI_ENABLE_SYMVERS is expanded from...
configure.ac:376: the top level
configure.ac:41: error: possibly undefined macro: AC_PROG_LIBTOOL
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure:7636: error: possibly undefined macro: AC_PROG_LD
autoreconf: /usr/bin/autoconf failed with exit status: 1
libffi.mk:6: recipe for target
'"<http://ci.opensuse.org/job/yast-yast.github.io-master/ws/.vendor/bundle/ruby/2.1.0/gems/ffi-1.9.21/ext/ffi_c/libffi-x86_64-linux-gnu"/.libs/libffi_convenience.a'>
failed
make: ***
["<http://ci.opensuse.org/job/yast-yast.github.io-master/ws/.vendor/bundle/ruby/2.1.0/gems/ffi-1.9.21/ext/ffi_c/libffi-x86_64-linux-gnu"/.libs/libffi_convenience.a]>
Error 1

make failed, exit code 2

Gem files will remain installed in
<http://ci.opensuse.org/job/yast-yast.github.io-master/ws/.vendor/bundle/ruby/2.1.0/gems/ffi-1.9.21>
for inspection.
Results logged to
<http://ci.opensuse.org/job/yast-yast.github.io-master/ws/.vendor/bundle/ruby/2.1.0/extensions/x86_64-linux/2.1.0/ffi-1.9.21/gem_make.out>

An error occurred while installing ffi (1.9.21), and Bundler cannot continue.
Make sure that `gem install ffi -v '1.9.21'` succeeds before bundling.
Build step 'Execute shell' marked build as failure
Skipped archiving because build is not successful
Performing Post build task...
Match found for : : True
Logical operation result is TRUE
Skipping post build task 0 - job status is worse than unstable : FAILURE
Not sending mail to unregistered user lslezak@xxxxxxx

< Previous Next >
This Thread
References