Mailinglist Archive: yast-commit (412 mails)

< Previous Next >
[yast-commit] Build failed in Jenkins: yast-autoyast-integration-test #36
  • From: jenkins@xxxxxxx
  • Date: Fri, 23 Oct 2015 18:59:01 +0200 (CEST)
  • Message-id: <-351312365.29.1445619541122.JavaMail.jenkins@ci>
See <https://ci.suse.de/job/yast-autoyast-integration-test/36/>

------------------------------------------
[...truncated 1815 lines...]

To use it:
vagrant init 'autoyast'
vagrant up --provider=libvirt
vagrant ssh
==> autoyast_vm: Removing domain...
error: failed to get vol 'vagrant_autoyast_vm.img'
error: Storage volume not found: no storage vol with matching path
'vagrant_autoyast_vm.img'


****** Importing vagrant box into pennyworth ******
Bundler is using a binstub that was created for a different gem.
This is deprecated, in future versions you may need to `bundle binstub
pennyworth` to work around a system/bundle conflict.
Importing box 'autoyast' into vagrant...

****** Running test on created system ******
.....Boot machine 'autoyast_vm' :
84.610725154
SLES 12 checks, if user -vagrant- has been created :
0.00014326
SLES 12 checks, if root has /root home :
5.3836e-05
SLES 12 checks, after installation snapshot has been created : 5.38e-05
SLES 12 checks, YaST2 packages are not installed :
5.0191e-05
SLES 12 checks, second stage was not executed :
5.4071e-05


Finished in 1 minute 34.97 seconds (files took 0.15149 seconds to load)
5 examples, 0 failures
+ rake 'test[test/partition.rb]'
********** Running test partition **********
I, [2015-10-23T15:27:31.313543 #18092] INFO -- : Creating KVM image
I, [2015-10-23T15:27:31.313673 #18092] INFO -- : Building KVM image
Building Box autoyast with Definition autoyast:
- debug : false
- cwd : <https://ci.suse.de/job/yast-autoyast-integration-test/ws/kiwi>
- force : true
- nogui : false
- auto : true
- checksum : false
- postinstall_include : []
- postinstall_exclude : []
- skip_to_postinstall : false
- use_emulation : false
- network_name : default

The isofile testing.iso already exists.
Running #before_create hook
[2015-10-23 15:27:32] INFO WEBrick 1.3.1
[2015-10-23 15:27:32] INFO ruby 2.1.2 (2014-05-08) [x86_64-linux-gnu]
[2015-10-23 15:27:32] INFO WEBrick::HTTPServer#start: pid=18094 port=8888
Hook #after_create is not defined
Hook #after_up is not defined
Waiting 10 seconds for the machine to boot
Skipping webserver as no kickstartfile was specified
Sending keystrokes to VNC port :1 - TCP port: 5901
Typing:[1]: <Esc><Enter>
Typing:[2]: linux
Typing:[3]: netdevice=eth0
Typing:[4]: instmode=dvd
Typing:[5]: textmode=1
Typing:[6]: insecure=1
Typing:[7]: netsetup=dhcp
Typing:[8]: autoyast=http://10.100.13.63:8888/autoinst.xml
Typing:[9]: <Enter>
Done typing.

Hook #after_boot_sequence is not defined
Waiting for ssh login on 192.168.122.64 with user vagrant to sshd on port => 22
to work, timeout=10000 sec
Hook #before_ssh is not defined
................192.168.122.64 - - [23/Oct/2015:15:29:50 CEST] "GET
/autoinst.xml HTTP/1.1" 200 18125
- -> /autoinst.xml
192.168.122.64 - - [23/Oct/2015:15:29:50 CEST] "GET /autoinst.xml HTTP/1.1" 200
18125
- -> /autoinst.xml
.....................................................................................................................................................................................................................................................
Transferring /tmp/.veewee_version20151023-18094-htw3cm to .veewee_version
..
Waiting for ssh login on 192.168.122.64 with user vagrant to sshd on port => 22
to work, timeout=10000 sec
Hook #before_ssh is not defined
.
Transferring /tmp/.veewee_params20151023-18094-17le78 to .veewee_params
..
Hook #before_postinstall is not defined
Waiting for ssh login on 192.168.122.64 with user vagrant to sshd on port => 22
to work, timeout=10000 sec
Hook #before_ssh is not defined
.
Transferring
<https://ci.suse.de/job/yast-autoyast-integration-test/ws/kiwi/definitions/autoyast/postinstall.sh>
to postinstall.sh
..
Waiting for ssh login on 192.168.122.64 with user vagrant to sshd on port => 22
to work, timeout=10000 sec
Hook #before_ssh is not defined
.
Executing command: chmod +x "postinstall.sh"
Waiting for ssh login on 192.168.122.64 with user vagrant to sshd on port => 22
to work, timeout=10000 sec
Hook #before_ssh is not defined
.
Executing command: echo 'vagrant'|sudo -S sh './postinstall.sh'

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

root's password: % Total % Received % Xferd Average Speed Time Time
Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0

100 409 100 409 0 0 544 0 --:--:-- --:--:-- --:--:-- 544
100 409 100 409 0 0 542 0 --:--:-- --:--:-- --:--:-- 0

update sudoers ...

speed-up remote logins ...
Hook #after_postinstall is not defined
The box autoyast was built successfully!
You can now login to the box with:
ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -p 22 -l
vagrant 192.168.122.64
[2015-10-23 15:50:21] INFO going to shutdown ...
[2015-10-23 15:50:21] INFO WEBrick::HTTPServer#start done.
I, [2015-10-23T15:50:21.293397 #18092] INFO -- : Exporting KVM image into box
file
Vagrant requires the box to be shutdown, before it can export
Sudo also needs to work for user vagrant
Performing a clean shutdown now.

Machine autoyast is powered off cleanly
Creating a temporary directory for export
Adding additional files
Creating Vagrantfile
Copying the box volume
Packaging the box
Cleaning up temporary directory

To import it into vagrant type:
vagrant box add 'autoyast'
'<https://ci.suse.de/job/yast-autoyast-integration-test/ws/kiwi/autoyast.box'>

To use it:
vagrant init 'autoyast'
vagrant up --provider=libvirt
vagrant ssh
==> autoyast_vm: Removing domain...
error: failed to get vol 'vagrant_autoyast_vm.img'
error: Storage volume not found: no storage vol with matching path
'vagrant_autoyast_vm.img'


****** Importing vagrant box into pennyworth ******
Bundler is using a binstub that was created for a different gem.
This is deprecated, in future versions you may need to `bundle binstub
pennyworth` to work around a system/bundle conflict.
Importing box 'autoyast' into vagrant...

****** Running test on created system ******
..Boot machine 'autoyast_vm' :
112.925098988
Minimal partition checks, if user -vagrant- has been created :
0.000141308
Minimal partition checks, if partition_id order fits :
0.010982551


Finished in 2 minutes 4.1 seconds (files took 1.55 seconds to load)
2 examples, 0 failures
+ rake 'test[test/http.rb]'
********** Running test http **********
I, [2015-10-23T15:55:35.018420 #3475] INFO -- : Creating KVM image
I, [2015-10-23T15:55:35.018550 #3475] INFO -- : Building KVM image
Building Box autoyast with Definition autoyast:
- debug : false
- cwd : <https://ci.suse.de/job/yast-autoyast-integration-test/ws/kiwi>
- force : true
- nogui : false
- auto : true
- checksum : false
- postinstall_include : []
- postinstall_exclude : []
- skip_to_postinstall : false
- use_emulation : false
- network_name : default

The isofile testing.iso already exists.
Running #before_create hook
[2015-10-23 15:55:38] INFO WEBrick 1.3.1
[2015-10-23 15:55:38] INFO ruby 2.1.2 (2014-05-08) [x86_64-linux-gnu]
[2015-10-23 15:55:39] INFO WEBrick::HTTPServer#start: pid=3478 port=8888
Hook #after_create is not defined
Hook #after_up is not defined
Waiting 10 seconds for the machine to boot
Skipping webserver as no kickstartfile was specified
Sending keystrokes to VNC port :1 - TCP port: 5901
Typing:[1]: <Esc><Enter>
Typing:[2]: linux
Typing:[3]: netdevice=eth0
Typing:[4]: instmode=dvd
Typing:[5]: textmode=1
Typing:[6]: insecure=1
Typing:[7]: netsetup=dhcp
Typing:[8]: autoyast=http://10.100.13.63:8888/autoinst.xml
Typing:[9]: <Enter>
Done typing.

Hook #after_boot_sequence is not defined
Waiting for ssh login on 192.168.122.182 with user vagrant to sshd on port =>
22 to work, timeout=10000 sec
Hook #before_ssh is not defined
................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................Ssh
timeout 10000 sec has been reached.
[2015-10-23 18:43:24] INFO going to shutdown ...
[2015-10-23 18:43:24] INFO WEBrick::HTTPServer#start done.
I, [2015-10-23T18:43:24.949944 #3475] INFO -- : Exporting KVM image into box
file
Vagrant requires the box to be shutdown, before it can export
Sudo also needs to work for user vagrant
Performing a clean shutdown now.

Machine autoyast is powered off cleanly
Creating a temporary directory for export
Adding additional files
Creating Vagrantfile
Copying the box volume
Packaging the box
Cleaning up temporary directory

To import it into vagrant type:
vagrant box add 'autoyast'
'<https://ci.suse.de/job/yast-autoyast-integration-test/ws/kiwi/autoyast.box'>

To use it:
vagrant init 'autoyast'
vagrant up --provider=libvirt
vagrant ssh
==> autoyast_vm: Removing domain...
error: failed to get vol 'vagrant_autoyast_vm.img'
error: Storage volume not found: no storage vol with matching path
'vagrant_autoyast_vm.img'


****** Importing vagrant box into pennyworth ******
Bundler is using a binstub that was created for a different gem.
This is deprecated, in future versions you may need to `bundle binstub
pennyworth` to work around a system/bundle conflict.
Importing box 'autoyast' into vagrant...

****** Running test on created system ******
F

Failures:

1) SLES 12 HTTP server checks, apache2 and firewall is running correctly
Failure/Error: Unable to find matching line from backtrace
Cheetah::ExecutionFailed:
Execution of "vagrant up autoyast_vm" failed with status 1:
/home/jenkins/.vagrant.d/gems/gems/fog-core-1.29.0/lib/fog/core/wait_for.rb:11:in
`wait_for': The specified wait_for timeout (2 seconds) was exceeded
(Fog::Errors::TimeoutError) (...).
# ./helper/spec_helper.rb:53:in `block (2 levels) in <top (required)>'

Finished in 15 minutes 25 seconds (files took 0.22507 seconds to load)
1 example, 1 failure

Failed examples:

rspec ./test/http.rb:4 # SLES 12 HTTP server checks, apache2 and firewall is
running correctly
Build step 'Execute shell' marked build as failure

< Previous Next >
This Thread
Follow Ups