Mailinglist Archive: uyuni-users (31 mails)

< Previous Next >
RE: [uyuni-users] change SUSE products
Hi,

# mgr-sync refresh

as root on the uyuni server? If that shows an error it's a bug.

smduyuni:/var/log/rhn # mgr-sync refresh
Refreshing Channels Please enter the credentials of SUSE Manager
Administrator.
Login: torsten.haupt
Password:

[DONE]
Refreshing Channel families [DONE]
Refreshing SUSE products [DONE]
Refreshing SUSE Product channels [DONE]
Refreshing Subscriptions [DONE]

No errors.

But it might be the case that your credentials don't have a subscription for
SLE15 and that's why you can't add them. But the fact that you can't see any
products now is weird with confirmed credentials.

Well, I have a SLES15 system, which is registered to SCC and gets updates. So I
think my subscription includes SLES15.
I checked it in SCC, too. SLES15 is included.

Also you have the latest packages installed on the server?

Before I wrote this question, I made a "zypper update".
I use this repo:
smduyuni:/var/log/rhn # cat /etc/zypp/repos.d/uyuni-server-stable.repo
[uyuni-server-stable]
enabled=1
autorefresh=0
baseurl=https://download.opensuse.org/repositories/systemsmanagement:/Uyuni:/Stable/images/repo/Uyuni-Server-4.0-POOL-x86_64-Media1/
type=rpm-md

Greets
Torsten


Best,
Kostas




On Mon, 2019-04-15 at 09:42 +0000, Haupt, Torsten wrote:
Hi Kostas,

after installation some month ago I configured my credentials in the
setup wizard and selected the products. The repos are still active and
synced last night.
Now I want to add SLES15 under Setup Wizard | SUSE products; the page
loads and shows the error. The credentials are still there and the
hook is still green (verified). I already tried to delete the
credentials and to reenter them. They were accepted, but now I can't
see any SUSE products anymore. Before I saw it. I took the credentials
fresh from the SCC.

Regards
Torsten


-----Original Message-----
From: Konstantinos Tsamis [mailto:ktsamis@xxxxxxx]
Sent: Monday, April 15, 2019 11:23 AM
To: uyuni-users@xxxxxxxxxxxx
Subject: Re: [uyuni-users] change SUSE products

Hi Torsten,

how did you setup the repositories for SLE12 and how are you trying
to add SLE15? You need to add SCC credentials that have
subscriptions for these products enabled to the Setup Wizard. That's
where that message comes from.

What I am surprised about is that SLE12 works without the
credentials.
Do you get updates there?

About the server error, what exactly were you trying to do that lead
to it? It could be a bug depending on what you were doing. But
without the SCC credentials it might not as well.


Best,
Kostas


On Mon, 2019-04-15 at 09:12 +0000, Haupt, Torsten wrote:
Hello,

I want to change /update my SUSE products in Uyuni.
I already configured repos for SLES12 some time ago. Now I want to
add SLES15, but the GUI shows "Server error, please check log
files.". And in rhn_web_ui.log I find:
2019-04-15 10:46:01,798 [ajp-apr-0:0:0:0:0:0:0:1-
8009-
exec-14] WARN
com.redhat.rhn.manager.content.ContentSyncManager
-
Error reading UUID: /etc/zypp/credentials.d/SCCcredentials (No
such file or directory)

There is no SCCcredentials file and the folder is empty.
What is going wrong and how can I add and change new SLES
products?

Regards
Torsten

Nry隊[x칻&ޢ'-wzf쮞+z> ޮ^ˬz
< Previous Next >
Follow Ups