Mailinglist Archive: radeonhd (699 mails)

< Previous Next >
RE: [radeonhd] Will the X1200 be supported?
  • From: "Bridgman, John" <John.Bridgman@xxxxxxx>
  • Date: Tue, 20 Nov 2007 13:32:06 -0500
  • Message-id: <898503EB1E15BA4F944D1BE69D55AAC809E47A@xxxxxxxxxxxxxxxxx>
Feel free to email me if you're having trouble getting your X1200 to
work. I've got an X1270 which is pretty similar. For giggles, can you
send me the output of "lspci -n" on that system, I am curious what the
PCI ID is for your IGP.

The problem here is that we have three different variants but it looks
like we only used two PCI device Ids, so it's pretty much impossible for
the driver to put the right name to each chip. In Windows the correct
device name is stored in an INF string in the driver builds we make
specifically for a customer, so the correct device name is always
reported. Generic drivers have an INF string like "X1200 family".

The Ids we used are 791E and 791F. The intent was that 791E be desktop
and 791F be mobile, but when the "T" variant was introduced it used the
same 791F device ID.

In theory the naming should be :

X1270 - 690T
X1250 - 690 / 690M
X1200 - 690C / 690MC (these are also called "...V" in some cases)...

... but the device Ids were not assigned along those lines. Now that
OEMs are starting to ship preconfigured Linux systems these issues will
go away over time. In the meantime a generic 12xx string might not be
the worst answer.

JB


--
To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >
References