Mailinglist Archive: radeonhd (699 mails)

< Previous Next >
Re: [radeonhd] RS690 nearly working
  • From: Coleman Kane <cokane@xxxxxxxxxx>
  • Date: Tue, 20 Nov 2007 13:15:37 -0500
  • Message-id: <47432449.2060205@xxxxxxxxxx>
savignien hercule wrote:
Coleman Kane a écrit :

Markus Keil wrote:

Am Samstag, 17. November 2007 10:44:04 schrieb savignien hercule:


Hello,

Starting with Coleman config file I finally got it working.

But only at 1152x854.

All higher resolution exhibits the "blurry stripes" problem.


I run my RS690 at 1280x768 with no problems connected to a Sony LCD-TV.

Markus


Mine is running at 1680x1050.

--
Coleman
--


So the problem seems to be related to the monitor...
Maybe the modelines are not correct.
How one can verify them ?
Can I compare the modes used by the vesa driver and the modes used by the
radeonhd ?

Sincerely, savi.

I think that the modelines that are used are dumped into the log file.
In the case of the VESA driver, these are indexed modelines that are
stored in BIOS ROM tables on the video card (and *may* vary from card to
card). In any case, the VESA system passes an index of the desired
screen resolution to the VBE call to set up the screen (which is done by
VGA ROM code that was shipped on the VGA board). The radeonhd driver
instead either builds Modelines according to the EDID/DPMS information
according to an algorithm in the driver code (or X.org code?).

Is there a way to get "radeonhd" to use VBE to set up the video mode
rather than performing the register magic itself? This would seem to me
to pick out that there may be a difference between VESA and radeonhd
mode setup.

--
Coleman Kane


--
To unsubscribe, e-mail: radeonhd+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: radeonhd+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References