Mailinglist Archive: opensuse (707 mails)

< Previous Next >
[opensuse] back to the 'fix this eternally broken temp file cleanup service' debate
Bonjour.

This is now driving me mad. Just over a year ago (I had to go hunt down the thread, here: http://lists.opensuse.org/opensuse/2014-01/msg00988.html) the issue was once again raised of why temp files were not being cleaned at boot (on openSUSE 13.1) if one tried to set the system to do so.

It was established that the cron job configurable from YaST's sysconfig editor was no longer functional since supposedly being replaced by the all-round saviour and tuck-your-sheets-in-would-you-like-a-cup-of-hot-cocoa-with-that princess that is systemd. Except that the replacement doesn't work. At least not on any of my 13.1 installations, whereupon both /tmp and /var/tmp become laden with relics that outright refuse to ever part my system, gradually filling my root partition until there is no more room for maneouvre. Currently my /tmp is sitting at 5GB. Looking at files in there, many are up to a year old. It seems to just accumulate stuff like an eccentric lonely old man with an attic. This was a fresh 13.1 installation made about a year ago. The root partition (ext4) is 17GB, about half of which was filled after installation. Now there's little left.

It was also established that SuSE likes to do its SuSEy thing and go its own way, against systemd defaults, in preserving temp files across reboots, since some SuSErs want their systems configured that way and consider /tmp to be a persistent directory.

So then jdd posted a response in that thread with a workaround:
http://lists.opensuse.org/opensuse/2014-01/msg00997.html

'found in 12.3 release notes (from google)

5.2. systemd: Cleaning Directories (/tmp and /var/tmp)

By default, systemd cleans tmp directories daily as configured in
/usr/lib/tmpfiles.d/tmp.conf. Users can change it by copying
/usr/lib/tmpfiles.d/tmp.conf to /etc/tmpfiles.d/tmp.conf and modifying the
copied file. It will override /usr/lib/tmpfiles.d/tmp.conf.

Note: systemd does not honor obsolete sysconfig variables in
/etc/sysconfig/cron such as TMP_DIRS_TO_CLEAR.

the /usr/lib/tmpfiles.d/tmp.conf file send to man 5 tmpfiles.d that is pretty
clear (IMHO). It allows cleaning only specific files'

Well, I just tried this. I copied the file from /usr/lib/tmpfiles.d/tmp.conf to /etc/tmpfiles.d/tmp.conf and still, nothing happens, either upon rebooting or any other time in the last 28 hours or so since. I have not modified the tmp.conf file as I found it, contents as follows:

# This file is part of systemd.
#
# systemd is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2.1 of the License, or
# (at your option) any later version.

# See tmpfiles.d(5) for details

# Clear tmp directories separately, to make them easier to override
# SUSE policy: we don't clean those directories
d /tmp 1777 root root -
d /var/tmp 1777 root root -

# Exclude namespace mountpoints created with PrivateTmp=yes
x /tmp/systemd-private-*
x /var/tmp/systemd-private-*
X /tmp/systemd-private-*/tmp
X /var/tmp/systemd-private-*/tmp

What do I have to do to make my Windows-esque cluttered system purge itself of useless crap?

I looked at the current 13.1 release notes via the link in YaST. There's no mention of this issue.

Having recently received a couple of emails relating to long-forgotten bug reports that have now, years later, having received no attention, been marked as WONTFIX for being related to a version of openSUSE that has reached End of Life, it doesn't inspire me with great hope that I'll see an actual proper fix for this during the lifetime of 13.1.

Peter
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >