Mailinglist Archive: opensuse (950 mails)

< Previous Next >
[opensuse] Loss of sound output
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yesterday, my sound output suddenly stopped. My system is openSUSE
13.2 with KDE 4.14.3. The kernel is 3.16.7-7-desktop.

The hardware is a 6 year old tower with 8GB RAM. The soundcard is an
ASUS Xonar D1.

The sound architecture is pulseaudio running on top of ALSA, and the
card sends its output to an external hifi amplifier.

When thing went wrong yesterday, I think it followed a re-login or a
reboot. When I play sound from gmpc (an mpd client) both gmpc and
Pulseaudio volume control behave as if everything was working OK. In
gmpc, the progress slider moves from left to right through each track,
and the tracks "play" one after another. Similarly, PA volume control
shows a moving output level for the MPD daemon.

The most useful information comes from KDE System Settings >
Multimedia > Audio and Video Settings, which now only shows PulseAudio
Sound Server in the Device Preference list. Prior to the failure there
was a list of about six devices, all variations on the Xonar D1, but
most of which produced no output. However, Analog Stereo always
worked. After the reboot/re-login which resulted in the loss of sound,
there was a single hardware device shown with a different name (sorry,
I didn't note it down).

Yast Sound shows a single device (I disabled the onboard sound device
in the BIOS a long time ago) as card 0, Virtuoso 100 (Xonar D1), using
driver snd-virtuoso.

If I remove and reinsert the output lead, the hifi system buzzes
briefly as the mini-jack goes back in, which suggests there cable is
OK and there is still life in the card.

I have googled for an answer, and though there is lots about
configuring sound from the alsa level upwards, there is nothing on a
suddenly silent system. My own feeling is that something has changed
at the sound driver or ALSA level. YaST has never offered any
configuration options for this card.

Any suggestions, please?

Bob
- --
Bob Williams
System: Linux 3.16.7-7-desktop
Distro: openSUSE 13.2 (x86_64) with KDE Development Platform: 4.14.3
Uptime: 06:00am up 12:11, 5 users, load average: 0.00, 0.01, 0.05
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlSvlqgACgkQ0Sr7eZJrmU5udgCdFFnzmDyE/PmfPZay05neLGgX
wwAAnR7GtlNp1cv2iGbcag0Baxmok+3u
=3AvO
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups