Mailinglist Archive: opensuse (1575 mails)

< Previous Next >
Re: [opensuse] Broadcom BCM43xx WiFi driver and 13.2
  • From: Vojtěch Zeisek <vojtech.zeisek@xxxxxxxxxxxx>
  • Date: Tue, 02 Dec 2014 21:37:41 +0100
  • Message-id: <2552747.C8NzqAr9pr@veles>
Dne Út 2. prosince 2014 12:19:03, John Andersen napsal(a):
On 12/02/2014 11:49 AM, Vojtěch Zeisek wrote:
Hello, in previous versions it was more or less working that driver for
Broadcom wifi card was automatically installed. I tried fresh install of
13.2 on two different machines equipped with Broadcom (BCM4313) and
during installation, I could connect to the wifi and use on-line
repositories. But after installation the driver was missing and network
card was not configured. This is really weird: some HW works during
installation but fails later. This driver should be part of kernel, I
think. I had to install it manually. KDE4 wasn't able to tell me what is
wrong. XFCE told me that firmware is missing. And I had to configure the
network card in YaST. I see this as regression when comparing with 13.1.
Anyone has similar experience? Should I report is as a bug? Best, Vojtěch

If you installed from a LiveCD this frequently happens.The LIVECD seems to
either have or fetch these drivers. On an upgrade, it can use the old
firmware

I was using DVD.

There is a firmware fetching step at the end of the install, before
rebooting as I recall. It asked me to run a command to fetch the firmware,
and I did and it worked perfectly.

No prompt like this for me.

I believe it was something like /usr/sbin/install_bcm43xx_firmware
But if all you have is wifi you have a bit of a catch22 after your first
reboot.

There are packages b43-firmware and/or broadcom-wl providing the driver.

-----------another issue
BTW, why is it I can never import your public key? OpenSuse tools find it
on the key server, but refuse to import it.

No idea :-(

--
Vojtěch Zeisek

Komunita openSUSE GNU/Linuxu
Community of the openSUSE GNU/Linux

http://www.opensuse.org/
http://trapa.cz/
< Previous Next >
Follow Ups