Mailinglist Archive: opensuse (924 mails)

< Previous Next >
Re: Re: [opensuse] Broken raid with 12.2 upgrade
  • From: Dennis Gallien <dwgallien@xxxxxxxxx>
  • Date: Sun, 14 Oct 2012 08:12:52 -0400
  • Message-id: <1910807.RS0jAIeTly@alien-suse>
On Sunday, October 14, 2012 12:00:25 PM Matthias Bach wrote:

Am 13.10.2012 um 02:05 schrieb Rodney Baker:
On Sat, 13 Oct 2012 08:36:33 Dennis Gallien wrote:
I have 3 simple arrays, each with 2 partitions - sda1/sdb1, sda2/sdb2,
sda3/sdb3. The first pair is for /boot, the second root, the third

After upgrading to 12.2 from DVD, at boot the stock 3.4.6 kernel throws
this message, once for each partition:

failed to executed /sbin/mdadm --incremental /dev/sda1 --offroot

The arrays are still mountable and accessible after the system comes up.

I am having the exact same problem with my root on LVM since I applied the
latest kernel update yesterday. :(

For me the following solved the problem:

Boot into rescue system (on Install-DVD). Simply enter `root` when asked for
a login.

Chroot into the system you want repaired. In my case:

mkdir /foo
vgchange -a y
mount /dev/noraid/root /foo
mount --bind /proc /foo/proc
mount --bind /dev /foo/dev
chroot /foo

Create a fixed initrd. I did add `lvm` to `INITRD_MODULES` in
`/etc/sysconfig/kernel`. However, as `mkinitrd` claims not to find any
such module I assume the problem simply that the initrd itself was broken,
not that lvm was missing.


Exit your chroot and reboot.


That fixed it for me. Hope you are as lucky.


Thanks. My problem was a bug in mdadm, fixed in a Oct 5 patch.
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >