Mailinglist Archive: opensuse (924 mails)

< Previous Next >
Re: [opensuse] More on Sound in 12.2
On 10/07/2012 09:08 AM, George Olson wrote:
On 09/22/2012 06:43 AM, Robin Klitscher wrote:
As I mentioned in the thread on "No sound in 12.2", for historical
reasons I'd avoided using pulseaudio and had fallen back to alsa. This
works well in 12.1 and 12.2, except that I couldn't get the gstreamer
backend in Phonon to work properly; only VLC. Desktop is KDE 4.9.x;
sound card is a PCI-e X-Fi Titanium.

Having followed the other thread I've now installed pulseaudio in 12.2.
And it works very well with the gstreamer backend (though not the VLC
backend) - except for one thing. I simply cannot persuade ann .mp3
sound track to play in the "Advanced Slideshow" in either Digikam or
Gwenview. It does play with alsa sans pulseaudio using the VLC backend,
but not with pulseaudio using either the gstreamer backend or the VLC
backend. And the oddest thing is that it does play if I hit "Preview"
on the soundtrack page of the advanced slideshow setup - but not when I
start the slideshow itself.

Obviously there is something I'm not doing right, but I don't know what
it is and it's driving me nuts. I've looked all over the place for
plugins or other modules I might have missed, and I've asked elsewhere
including a Digikam mailing list, but without result. So now I'm asking


FWIW, I have installed 12.2 on 2 systems now, and they both had a sound
problem related to

The first one was my laptop, and I did an upgrade rather than a clean
install. I had no sound and a "dummy" device. When I ran "ls -l
/dev/snd/*", I got that root was on all my sound devices.

I didn't think I was running sysvinit, because I assumed that systemd
was installed by default when I upgraded. It was, but I rebooted and hit
F5, positively selected systemd to be sure, and I still had the problem.

Then I went into yast and did a search for sysvinit, and lo and behold,
it was there, as well as systemd. I uninstalled sysvinit, rebooted, and
all my sound systems came back to normal, exactly as it worked with
movies, amarok, and anything else I needed that I used regularly.

On my desktop, I just completed the install of 12.2 last night. It was a
clean install on the root partition of 12.2 (I kept my KDE settings in
/home and did not have to adjust anything specific to KDE). After the
installation, upgrading to KDE 4.9.1, and installing again all the
programs I use regularly, I tested the sound. Nothing, just like before.
However, I did not have the "dummy" sound card as the only device - my
webcam was listed too and I can't remember if there was anything else.

On my desktop I assumed that because this was a "clean" install and it
had formatted the root partition, there would not be a problem with
sysvinit. However, just to be sure, I went to yast again and check, and
sure enough, sysvinit was installed right alongside systemd. I was
booting with grub2 on this system (since it was a clean install that was
automatic). So I uninstalled sysvinit in yast, rebooted, and then again,
all my sound settings worked.

I am sure that there are other issues people have specific to their own
systems, but it seems like having sysvinit installed, even if you are
booting with systemd, tends to cause problems with the audio functions.

I had a dummy device and no sound as well. I *am* using sysvinit and grub not grub2 on a fresh install of 12.2. In order to get sound to work, I added myself to the pulse, audio and video groups and sound magically started to work and the proper devices showed up instead of the dummy device.

Carpe Aptenodytes! (Seize the Penguins!)
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >