Mailinglist Archive: opensuse (1051 mails)

< Previous Next >
Re: [SOLVED]Re: [opensuse] Brother MFC-J6710dw compatibility?
upscope wrote:
Tom I've been looking for new printer and since both the brother's
printers my wife had I'd consider Brother for my Linux systems. Did you
resolve the problem of the busy signal? Also when you downloaded the
Brother software did it include Scanner software? Sane does not appear
to have a scanner driver for this printer and I need to be able to scan.

Brother's scanner software works with sane.
Follow the destructions, and everything will work.
I save the downloads in /local, a filesystem which I
preserve during upgrade installations.

For my own peace of mind, when doing the first installation of
a Brother product, I make shell scripts in case I have to reinstall
the drivers later.

For example for the MFC-5440 CN:

# Install printer driver for MFC-5440
rpm -ihv --nodeps MFC5440CNlpr-1.0.2-1.i386.rpm
rpm -ihv --nodeps cupswrapperMFC5440CN-1.0.0-1.i386.rpm
echo "checking software installation...this will take 1-2 minutes"
rpm -qa | grep -e MFC5440CN
echo "open http://localhost:631/printers";
echo Click "Modify Printer" and set following parameters.
echo for Device - "LPD/LPR Host or Printer" or "AppSocket/HP JetDirect"
echo for Device URI - - "lpd://(Your printer's IP address)/binary_p1"
echo for Make/Manufacturer - Brother
echo for Model/Driver Selection - MFC-6490CW
echo test print

For the Scanner:

# Install printer driver for MFC-5440CN
rpm -ihv --nodeps brscan2*.i386.rpm
rpm -qa | grep brscan2
brsaneconfig2 -a name=SCANLETTER model=MFC-5440CN ip=
brsaneconfig2 -q | grep SCANLETTE

And for the Fax:
# Install Fax driver for MFC-5440CN
rpm -ihv --nodeps brmfcfaxlpd-1.0.0-1.i386.rpm
rpm -ihv --nodeps brmfcfaxcups-1.0.0-1.i386.rpm
rpm -qa | grep -e brmfcfax
echo '"open http://localhost:631/printers";'
echo 'Click "Modify Printer" and set following parameters.'
echo 'for Device - "LPD/LPR Host or Printer" or "AppSocket/HP JetDirect"'
echo "for Device URI - - lpd://(Your printer's IP address)/binary_p1"
echo "for Make/Manufacturer - Brother"
echo "for Model/Driver Selection - Brother BRMFCFAX for CUPS (en)"
echo test print


On Monday, April 30, 2012 04:44:43 PM Thomas Taylor wrote:
On Fri, 27 Apr 2012 15:31:11 -0700

Thomas Taylor <linxt@xxxxxxxxxxx> wrote:
Hi All ;)
Have any of you used a Brother MFC-J6710dw with linux? Have there
been any problems with recognition/setup?

This is a fairly new printer and I couldn't find it on the HCL so am
asking here.

Thanks, Tom

Thanks to both Mike and Dirk for the responses.

Got the printer and installed the drivers per the Brother site.
Configured with cups via Yast2. It found the drivers and printed a
test page which looks great. That was last night. Today, after
working on a network problem my wife was having, I tried to print
several pages. Cups is returning a busy signal. Haven't had time to
trace that down yet.

Fortunately I also have a Brother HL-1440 laser printer (really old
but works fine) to print for now.


Tom Taylor - retired penguin
AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
openSUSE 12.1x86_64 openSUSE 12.2x86_64
KDE 4.6.00, FF 7.0 KDE 4.7.2, FF 10.0
claws-mail 3.8.0
registered linux user 263467
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

openSUSE 12.1(3.1.10-1.9-desktop x86_64)|KDE Platform Version
4.8.2 (4.8.2 "release 494"|Intel core2duo 2.5 MHZ,|8GB
DDR3|GeForce 8400GS(NVIDIA-Linux-x86_64-295.40)

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx

< Previous Next >