Mailinglist Archive: opensuse (929 mails)

< Previous Next >
Re: [opensuse] KDE 4.7 , opensuse 11.4 64bit.
  • From: ianseeks <ianseeks@xxxxxxxxxxxxx>
  • Date: Sun, 07 Aug 2011 19:14:38 +0100
  • Message-id: <17281203.BudnuiAevt@linux-k5wg>
On Sunday 07 Aug 2011 08:17:25 Anton Aylward wrote:
ianseeks said the following on 08/06/2011 04:26 PM:
I didn't realise there was a configuration for default apps in the
"system settings" so everytime i deleted it from the panel, the system
put it back the next time i logged in. Never seen that option before,
must be new to 4.7
Big Time

Back in May I encountered a bug
which I was told was 'fixed upstream'.

Back when I reported it the bus was fairly constrained, only the one
problem with things being written. Now I seem to be suffering from
something wider in scope but I suspect a similar root cause.

The phenomena was that:

"What is being restored seems to be settings from a week or more ago,
those settings and items on the panel and systray."

So if I delete the session as I did when I deleted all of ~/.kde4 to fix
another problem, I can set up new things (widgets, plasmoids) on the
panel and screen but they get fixed.

Phenomena like: The size and position of the widgets on screen is the
same every time I login even if I move, resize delete or add.

Phenomena like: the set of programs in the kickoff menu's "recently
used" set is the same on every new login regardless of what I ran in a
previous session.

I've verified the latter by looking at the kickoffrc file.

Points to consider:

All of ~/.kde4 is writeable

If I run "kcmshell4 kcmsmserver" its set to 'restore previous session',
as it always has been.

The settings I get on each login are all "from a week or more back" when
I wiped ~/.kde4 to fix another problem and the first session.after that.

Thomas Lubking told me that #272666 as fixed upstream in 4.6.4
Perhaps, but it seems I now have a larger scope version of this.

Ian, can you check that your ~/.kde4 is writeable and that you have
("kcmshell4 kcmsmserver") a restore previous sessions setting. Can you
see if you are suffering the same problems I am with the kickoff menu.
drwx------ .kde4
All the files and folders below ".kde4" are at least "r" or "rw".

the problem has gone away since i deconfigured Firefox in
SystemSettings/Default Applciations
Perhaps we need to reactivate that bug.


To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >