Mailinglist Archive: opensuse (963 mails)

< Previous Next >
[opensuse] create md RAID1 from old HD's ordinary partition with data plus new virgin HD's empty 0xFD partition
Before starting, I looked in /usr/share/doc/manual/opensuse-manuals_en/manual/ and and and and elsewhere without finding any example of doing what I am trying to do.

I want to make /dev/md7 out of sdb14 which is formatted EXT3 and is 86% full of data, plus sda14, which is identically partitioned but virgin space on a brand new HD replacing the old sda. I've already rebuilt /dev/md[0-7]. sdb14 was originally created using the excess of sdb's size over the size of the old sda.

On 11.4, I tried using YaST2 to do this, but it won't let me initialize md7 with only the old partition, and I see no clear indication that my data on sdb14 won't be eradicated by initially combining it with sda14 to create md7.

So I tried on cmdline instead of YaST2:

mdadm --create --verbose /dev/md7 --level=1 /dev/sdb14 missing

but that gives an error "mdadm: no raid-devices specified".

I tried:

mdadm --create --verbose --force -n1 /dev/md7 --level=1 /dev/sdb14

but this gives a warning:

mdadm: /dev/sdb14 appears to contain an ext2fs file system
size=156280288K mtime=Fri Apr 15 17:42:57 2011
mdadm: Note: this array has metadata at the start and
may not be suitable as a boot device. If you plan to
store '/boot/ on this device please ensure that
your boot-loader understands md/v1.x metadata, or use
mdadm: size set to 156579192K
Continue creating array?

The size disparity between the two size numbers, and lack of mention of the significance of the existing filesystem, has me worried what would happen if I answered yes.

Without really thinking about the --create results, I did:

mdadm --build --verbose --force -n1 /dev/md7 --level=1 /dev/sdb14

The result was "mdadm: array /dev/md7 built and started."

Fsck says /dev/md7 is clean. Mounted, things seemed to be OK, but /proc/mdstat shows differently for md7 than for others:

md7 : active raid1 sdb14[0]
156280288 blocks super non-persistent [1/1] [U]

md6 : active raid1 sda13[2] sdb13[1]
78140056 blocks super 1.0 [2/2] [UU]
bitmap: 0/150 pages [0KB], 256KB chunk

md5 : active raid1 sda12[2] sdb12[1]
1036148 blocks super 1.0 [2/2] [UU]
bitmap: 0/8 pages [0KB], 64KB chunk

md4 : active raid1 sda11[2] sdb11[1]
28362652 blocks super 1.0 [2/2] [UU]
bitmap: 0/217 pages [0KB], 64KB chunk

Before adding sda14 to md7 with mdadm, does anyone have any comments or advice that might prevent needing to restore sdb14's content from backup?
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata ***
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups