Mailinglist Archive: opensuse (888 mails)

< Previous Next >
Re: [opensuse] OpenSUSE 11.3 hangs with Firefox or Google Chrome running.
On Sunday, January 23, 2011 21:56 dwgallien's reply (fixed the top-posting


I have installed OpenSuse 11.3 on two machines. The first has been
running for almost a month now with no problems. The second hangs
everytime I have Firefox or Chrome running. Sometimes I can browse the
web for a few minutes before it hangs other times it just hangs on
loading a default set of tabs. Both are using KDE as the window manager.
Both machines previously had KDE3.? on them and now have KDE4. The
machine that now hangs had some trouble with migrating the KDE3 settings
to KDE4. When the machine hangs I even try CTRL-ALT-DEL and CTRL-ALT-2
but there is no response; needs a hard reset.

If I run the Kernel in failsafe mode then the machine does not hang; with
both KDE normal or failsafe mode.
If I run the Kernel in normal mode and either KDE normal or failsafe mode
with Firefox or Chrome running the system will hang.
If I run the Kernel in normal mode and KDE in normal mode then browse the
web with Konqueror there was no problem.

What type of information should I collect to find the problem? I would
really like to fix this.

I was thinking of deleting the .mozilla directory and re build from
scratch, except for my bookmark file.

I think this is a mozilla browser problem but why does it hang the

Thank you,

Pls take this with a large grain of salt, my memory may be faulty . . .

Are you using the nvidia proprietary driver? IIRC there have been issues
reported with the repo driver and the stock kernel that in particular
affected performance in Firefox and possibly Plasma (I don't recall
anything reported re Chrome, however). The solution that some found to
work was upgrading the kernel from :HEAD and then manually installing the
newer nvidia driver downloaded from their site (which means you should
first uninstall the driver from the repo via YaST or zypper). With some
searching through this list you should easily find the thread(s)
discussing this issue.

Good luck.

Btw, you should be able to re-install Firefox without any problem just
renaming .mozilla, and then migrating back your bookmarks file to the
newly created .mozilla. The bookmarks is just an xml file.

The unfortunate thing about downloading a whole new kernel is, it can't be
done very easily, if at all, when one is on dial-up, so the 'fix' is pretty

This kind of screw-up should not have been allowed to go into production
it was fixed first. Now those of us who *are* stuck on dial-up with no
alternative have to fret over *when* the system is going to freeze up on us (or
when it will do it again....and nauseum). It's happened to me
4 times and there's no telling when it's going to happen, it just does it. BTW,
it's doing it with Seamonkey too, not just Firefox. I use Seamonkey almost
exclusively on my KDE. Hard rebooting is going to tear up some hard drives
eventually, and it's something I can barely afford as is. This 'problem' of
freezing up in 11.3, is leaving a very bad taste and I've been using SuSE since
7.3. :(
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups