Mailinglist Archive: opensuse (882 mails)

< Previous Next >
[opensuse] Black screen/plasma crash after update to KDE 4.5.4
  • From: Rodney Baker <rodney.baker@xxxxxxxxxxxx>
  • Date: Sat, 18 Dec 2010 01:50:17 +1030
  • Message-id: <201012180150.18035.rodney.baker@xxxxxxxxxxxx>
Hi all.

Last night I upgraded from a working KDE 4.5.3 to the current 4.5.4 in
KDE:/Release:/45/openSUSE_11.2. After logging out and logging in plasma-
desktop crashed and I ended up with a black screen. I can still start apps via
alt-F2 and apps that were previously running e.g. amarok have restarted fine -
its just that no desktop is showing.

Oh, yes, instead of the splash screen both monitors are showing garbage
(messed up fragments of whatever is in the video card's frame buffer from
previous desktop sessions) after login and before the plamsa desktop crash.

Now, previously been through the exercise of removing .kde4/share/config or
even specific files (e.g. plasmarc, plasma-appletsrc) in that directory one-
by-one to find the culprit, but I really don't want to have to rebuild my
entire desktop (layout,backgrounds,themes etc.) again if I don't have to.

Is there a way to identify just what is causing plasmadesktop to crash and
trim that specific config file (or part thereof)? I suspect it is probably
related to a widget that hasn't been updated and therefore isn't compatible
with the newer release. How do I narrow it down? Log files? Any hints/pointers
gratefully received.

TIA,
Rodney.

--
===================================================
Rodney Baker VK5ZTV
rodney.baker@xxxxxxxxxxxx
===================================================

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups