Mailinglist Archive: opensuse (1185 mails)

< Previous Next >
Re: [opensuse] Kernel 2.6.33 Fails to Compile - ifenslave.c
  • From: Rares Aioanei <suse.listen@xxxxxxxxx>
  • Date: Fri, 14 May 2010 17:59:25 +0300
  • Message-id: <4BED654D.4040203@xxxxxxxxx>
On 05/14/2010 05:46 PM, Pete Eby wrote:
The kernel isn't linked against any library; and of course, because of your
change, whose purpose I do not understand,
no one will be able to test your config. Why do you need to alter the
initramfs source?

The reason why I am building a 2.6.33 or later kernel is because I am
trying to use uvesafb, which requires a user space tool, v86d to be
compiled against klibc with the binary for it in
/usr/share/v86d/initramfs, which it is. The initramfs then must be
modified to include this.

The make error however references ifenslave.c - part of ethernet
bonding I believe, which from what I can tell has little to do with
what I'm doing with the .config, unless I've missed something.

But please understand - I get the same error regardless of whether
CONFIG_INITRAMFS_SOURCE="/usr/share/v86d/initramfs" or is left UNSET
in the .config, so that is likely not the cause of the problem.

If I us a completely default config, with no modification, I get the
same error.

BTW, when issuing make oldconfig, I get some questions regarding new features; what did you answer?
And what is your hardware?
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups