Mailinglist Archive: opensuse (1185 mails)

< Previous Next >
Re: [opensuse] Kernel 2.6.33 Fails to Compile - ifenslave.c
  • From: Rares Aioanei <suse.listen@xxxxxxxxx>
  • Date: Thu, 13 May 2010 14:07:52 +0300
  • Message-id: <4BEBDD88.5010808@xxxxxxxxx>
On 05/13/2010 06:19 AM, Pete Eby wrote:
On Wed, May 12, 2010 at 11:22 AM, Rares Aioanei<suse.listen@xxxxxxxxx> wrote:
I do it like so :
1. tar x( z | j )vf linux-2.6.3xxx
2. cd linux-2.6.3xxx
3. cp /boot/config-<version> ./.config
4. make menuconfig
5. modify to taste
6. make -j3 (dual-core CPU) all
7. sudo make modules_install
8. sudo make install

What are the steps you're using?

Hi guys,

Yes, this is why this error is so odd - these steps are exactly how I
configured and built the kernel, with it failing of course on step 6.
I've tried both using my old .config, creating a brand new one, tried
building with make rpm and also make all, etc. (I've done a make
mrproper between build attempts.)

The error indicates a problem in ifenslave.c with several structs
being redefined in an included header, if_arp.h which is a bit odd in
itself really.

I was extremely surprised that disabling ethernet interface bonding,
the only reference to ifenslave.c I could find, did not clear this up.
I don't even know why it's trying to build this in if bonding is

This should be a very straight forward build, so I am a bit puzzled.

Maybe you should try a newer version, perhaps a git one, with the same config(s),
to see if problems persist.
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >